The Version is right but....whats wrong? Can me pls help someone? :(

lenscas

Over-Achiever
Jul 31, 2013
2,023
1,799
248
Looking at the screenshot it looks like you have launcher 1.4.3 and looking at the description of the modpack you need 1.4.6.
Try to redownload the launcher