Solved Thaumcraft Continuous Dimension Loading and Unloading

Discussion in 'Server Tech Support' started by WitherSauce, Jan 29, 2013.

  1. WitherSauce

    WitherSauce New Member

    Hi

    I have this bizarre issue. After updating to MindCrack v8.0.1 from v7, the server console spams this message two to three times a minute, and has continued to do so for over an hour.

    Code:
    CONSOLE: [INFO] Loading dimension 1 (world) ([email protected])
    CONSOLE: [INFO] Loading dimension 7 (world) ([email protected])
    CONSOLE: [INFO] Cache loaded. Size = 33787
    CONSOLE: [INFO] Readded hashes, hash size = 33787
    Thaumcraft: Loaded 709 aura nodes for world 7
    Thaumcraft: Removed 530 aura nodes when world 7 unloaded.
    CONSOLE: [INFO] Unloading dimension 7
    Thaumcraft: Removed -179 aura nodes when world 1 unloaded.
    CONSOLE: [INFO] Unloading dimension 1
    

    It currently seems to be pushing CPU load to 100%, and is probably the cause of the lag that is now afflicting the server.

    Could it be that thaumcraft is regenerating chunks since the last update? I know worldgen for apatite has changed.

    And ideas? Thanks.

    Edit:

    It also seems to be eating RAM incrementally. RAM usage goes from 30% at restart to 90 - 100% in under an hour.
     
  2. Velotican

    Velotican New Member

    If you haven't already, put a ChickenChunks chunk loader by the spawn point in each dimension. This should stop the server trying to unload the world at the very least. Bonus points if you put the chunk loader somewhere out of the sight of your players and reduce the number of chunks it keeps loaded to 1, which will be just enough to jam the dimensions open.
     
  3. WitherSauce

    WitherSauce New Member

    Thanks Velotican, but placing the chicken chunkloader at all spawns didn't help.
     
  4. Velotican

    Velotican New Member

    Double-check the Thaumcraft config. There's a set of options to regenerate chunks that don't have Thaumcraft features. Make sure they're disabled. I doubt this is actually causing the problem but it's worth checking it anyway.

    If it really comes to it you could enable the chunk regeneration and delete all the aura node data. What's surprising me if I'm reading that error log correctly is that Thaumcraft thinks some of your End nodes are in the Twilight Forest...
     
  5. WitherSauce

    WitherSauce New Member

    Ok, solved the issue by completely rolling back to v7 (thank god for full server snapshots), and reinstalling v8.0.1. Although a pain to do, the new v8.0.1 install does not spam the message. I guess something got corrupted during the first transition from v7 to v8. Thanks for the help Velotican, appreciate it :)
     
    Velotican likes this.

Share This Page