Mac [Solved] Ultimate fails to launch

Status
Not open for further replies.

leosayer

New Member
Jul 29, 2019
8
0
0
Hello,

I cannot get minecraft to launch, it tries and then fails and then just hangs on a black or white screen. I have a mac and I am on java 6. I have tried deleting everything and reinstalling. I have tried the parameters HERE and still does not work. I have installed as close to / as I can get.

Here is my console log:

http://pastebin.com/fZJ9v78C

Please help!

Thanks,
Liam.
 

seannyyx

New Member
Jul 29, 2019
135
0
0
Have you added optifine or other mods besides mods designed for that particular build?
 

HerbertIzMe

New Member
Jul 29, 2019
85
0
0
Update your java to 1.7 update 9 or higher. FTB executable is not compatible with Java 1.6. As well make sure you are using a 64 bit java version, all mac intel processors are 64 bit.
 

Booker The Geek

Well-Known Member
Feb 26, 2013
1,664
222
78
Pacific North West, USA
:D Hallo!

So...
Hey, I had the same problem.

Just follow this simple guide and mine works super!

http://support.apple.com/kb/HT5559?viewlocale=en_US
Nice find, I will research that and update my java upgrading guide. :)


EDIT: It appears, they only have the JDK version out. Nevermind use 1.6
Yeah, that sucks. BUT...:)
The new version of java for apple, when you download the JRE... does not really download all of it... (I don't know why...) SO you sort of have to use the JDK but only if...
  • YOU ARE ON A MAC OS X 10.7+ (10.7.x - 10.8.x)


I have added no other mods or Optifine.

Herb - from what I read on the Mac we should be using 1.6, at least this is what I read from Booker The Geek info - http://forum.feed-the-beast.com/threads/leaking-world-help-is-here.13230/ - is this not correct?

Thanks for responses so far.
Yes, and no... :( I am going to be updating it in a couple min to make the mac section a little bit easier to understand. At the moment if you are using the OS X 10.7.x or higher, you need to download 1.7, BUT you need to download the JDK not the JDE.


So Leo... go ahead and update the the latest version of Java JDK, then try again... You can get the version you need HERE. (It's this one = " jdk-7u17-macosx-x64.dmg")

If you still are having problems, then please repost you new log and we will go at it again. :D
 

leosayer

New Member
Jul 29, 2019
8
0
0
OK, so I have installed JDK as requested and now instead of hanging on a blank screen the luancher shuts down - http://pastebin.com/ggUbnpZ7

Something to do with this? -
  1. _NSJVMLoadLibrary: NSAddLibrary failed for /libjawt.dylib
  2. JavaVM FATAL: lookup of function JAWT_GetAWT failed. Exit
 

Booker The Geek

Well-Known Member
Feb 26, 2013
1,664
222
78
Pacific North West, USA
On my phone, sorry.

Now for the fun part....
You need to update the LWJGL...

I would post a link, but am on my phone.... There it's a walk through on the minecraft forum that is an easy google search....

:)
 

leosayer

New Member
Jul 29, 2019
8
0
0
I replaced these from version 2.8.5:

In .minecraft/bin/ (All operating systems)
  • jinput.jar
  • lwjgl.jar
  • lwjgl_util.jar
In minecraft/bin/natives/ (Mac)
  • libjinput-osx.jnilib
  • liblwjgl.jnilib
  • openal.dylib
I did not fully understand this:
libopenal.dylib should be replaced with a copy of openal.dylib
so I just replaced libopenal.dylib with openal.dylib renamed to libopenal.dylib.
It has change from LWJGL Version: 2.4.2 to LWJGL Version: 2.8.5 in the log but launcher still shuts down as before. http://pastebin.com/bbcaGXm0
Whats next! :)
 

MickTheLick

New Member
Jul 29, 2019
13
0
0
I'm having similar problems. I've tried all the above but with no results. The launcher basically just shuts down when it tries to open minecraft.
I'm on OSX Mac OS X Lion 10.7.5 (11G63b)
Using jdk-7u17-macosx-x64.dmg
Updated the LWJGL as above
Attached below is the minecraft log that FTB generates. Problem seems to be after where it says 'launching applet wrapper' this appears in red text when the FTB launcher is running.

Hope this helps. Hope you can help and sorry Leosayer for highjacking you post but it seems we are in the same boat.
 

Attachments

leosayer

New Member
Jul 29, 2019
8
0
0
OK, so a little drastic but I fixed it.

I performed a complete reinstall of Mountain Lion, installed Java for OS X 2012-006 and added -Xms512m -XX:permSize=128M -XX:MaxPermSize=512m to my java parameters.

I am now finally online with FTB Ultimate.

Thanks for everyones help along the way.
 

pojothechicken

New Member
Jul 29, 2019
6
0
0
Booker i tried following everything that you said to do in comment 8 and 10 but it didnt work so i tried disabling java and it didnt work. Could you please help me either disable the updated java or fix it so ftb is able to run with it? Thank you very much.

console log when i try to run mindcrack pack-http://pastebin.com/jcPvuiYn
 
Status
Not open for further replies.