Skyfactory 3 stuck on loading world

Discussion in 'Tech Support' started by Raindrop114, Mar 21, 2017.

  1. Raindrop114

    Raindrop114 Guest

    Title Skyfactory 3 stuck on loading world

    Launcher Type FTB Launcher

    Modpack FTB Presents Skyfactory 3

    Modpack version v3.0.8

    Have you modified the pack? No

    Link to log file http://paste.feed-the-beast.com/view/6b23c468

    Details of the issue I was playing the game yesterday, when it crashed my whole computer. When I restarted, it started up fine, but when I tried to load a world, it got stuck on the loading world screen. I took a break, thinking it would work the next day, but when I tried again, it still wouldn't load. I had thought it might be the world, so I created a new one, but that is also getting stuck on loading world. I have the newest java version, and my graphics drivers are up to date.
     
    Last edited by a moderator: Mar 21, 2017
  2. Raindrop114

    Raindrop114 Guest

    I tried to add an edit, but it wouldn't let me. I deleted the skyfactory 3 folder, and relaunched it, to do a fresh install, and it's working now. I was planning to do a new world, but, i don't think this fix is one others will wanna use if they have this trouble with worlds they already have.
     
  3. grandrolf

    grandrolf Global moderator Team Member Global Moderator Trusted User

  4. Raindrop114

    Raindrop114 Guest

    I actually did try a force update, when i saw the suggestion in a different thread when I was still looking, it didn't work. I had to completely delete the Sky Factory 3 folder, and launch it from scratch to get it to work again. But, well, that's not quite a solution if others run into the same issue, but don't wanna lose hours of work on a map.
     
  5. CDArena

    CDArena Guest

    The general tricks I use for situations like this:
    1) when it gets "stuck", (especially at the "loading" or "100% complete" screens), try tapping the escape key 2 or 3 times then waiting. (This works in many of the FTB packs)
    2) if that doesn't work, try adjusting the ram in your launcher for the pack (Curse or FTB) - 6GB usually evens things out for me.
    3) If all else fails (usually indicated by actual crashes to the desktop or error messages), look in your "Instances\FTB presents sky factory 3\backups" folder, and try manually unzipping and replacing the contents of your "\saves" folder.
     
  6. Jaari

    Jaari Active Member

    Please check the file named "island.json" found in "C:\ftb\FTBPresentsSkyfactory3\minecraft\" if it has been corrupted or not.
     
  7. CDArena

    CDArena Guest

    You might find "island.json" under (wherever you have curse configured)\Minecraft\Instances\FTB Presents SkyFactory 3\Config"
     
  8. IA12323

    IA12323 Guest

    Yo I had this problem the other day all you need to do is go to your files go to Documents then Curse then Minecraft then Instances then Sky Factory III then click on saves find you world copy your world to your homescreen. Copy it to your home screen twice to be safe. Then reinstall skyfactory then go to Curse and Minecrty And Sky Factory again and put your world in the saves folder
     
  9. awolJAK

    awolJAK Guest

    I ran into the same problem, and i found replacing all of the SF3 files the easiest way. BUT the saves weren't causing the problem, so I copied my saves (if your running from Twitch, you can open in folder from the modpack page) and deleted the pack, and reinstalled it.
     
    thomasvandeweg likes this.
  10. Doesn't that delete the world though, I have this problem and I want to keep my progress
     
  11. Spencer Hanson

    Spencer Hanson New Member

    I am also having the problem and I can't seem to find the file.
     

Share This Page