Solved SF3 Doesn't start after BSOD

Discussion in 'Server Tech Support' started by Megladon, Aug 12, 2018 at 8:42 PM.

  1. Megladon

    Megladon New Member

    I had my SF3 server running on my local computer as well as the client on my computer when my computer crashed with a BSOD think it was a memory exception error. I am not too worried about the crash but I can't get the server running again, I tried looking at the logs but don't really understand the syntax. If all else fails I will roll back to a previous backup but I will lose quite a lot.

    Attached is the server cmd log and the error log.
    Specs:
    Windows 10
    Ryzen 7 1700
    Gtx 1080
    16 GB ram

    A few things that might be key to the problem:
    Code:
    [21:38:50] [Server thread/INFO] [Actually Additions]: Successfully received WorldData for world 66!           //World 66 is the beneath I believe
    [21:38:50] [Server thread/ERROR] [FML]: Exception caught during firing event net.minecraftforge.event.world.WorldEvent$Load@26f3c809:
    com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
            at com.google.gson.Gson.fromJson(Gson.java:815) ~[Gson.class:?]
            at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
            at us.illyohs.itsbecauseuhasnogoodspawn.handler.IslandHandler.loadIslandList(IslandHandler.java:75) ~[IslandHandler.class:?]
            at net.minecraftforge.fml.common.eventhandler.ASMEventHandler_902_IslandHandler_loadIslandList_Load.invoke(.dynamic) ~[?:?]
            at net.minecraftforge.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:90) ~[ASMEventHandler.class:?]
            at net.minecraftforge.fml.common.eventhandler.EventBus.post(EventBus.java:185) [EventBus.class:?]
            at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:263) [MinecraftServer.class:?]
            at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:266) [ld.class:?]
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:431) [MinecraftServer.class:?]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
    Caused by: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
            at com.google.gson.stream.JsonReader.beginObject(JsonReader.java:374) ~[JsonReader.class:?]
            at com.google.gson.internal.bind.MapTypeAdapterFactory$Adapter.read(MapTypeAdapterFactory.java:183) ~[MapTypeAdapterFactory$Adapter.class:?]
            at com.google.gson.internal.bind.MapTypeAdapterFactory$Adapter.read(MapTypeAdapterFactory.java:145) ~[MapTypeAdapterFactory$Adapter.class:?]
            at com.google.gson.Gson.fromJson(Gson.java:803) ~[Gson.class:?]
            ... 9 more
    
    
    And this line:
    [21:38:51] [Server thread/INFO] [FML]: The state engine was in incorrect state SERVER_STARTING and forced into state SERVER_STOPPED. Errors may have been discarded.
    Please reply if you need any further info.
    EDIT
    SOLUTION:

    just copy over save files to a new skyfactory download.
     

    Attached Files:

    Last edited: Aug 13, 2018 at 3:16 PM
  2. lenscas

    lenscas Forum Addict

    Megladon likes this.
  3. adamich

    adamich Well-Known Member

    U can try:
    1. Download mod pack in diffirent folder and copy saves folders to there.
    2. Restore ONLY "world 66" from backup.

    In both cases if U have crash, add here NEW crash log
     
    Megladon likes this.
  4. Megladon

    Megladon New Member

    SOLVED
    Hi thanks for the quick response, I tried looking into the islands.json and ItsBecauseUHasNoGoodSpawn-1.0.5.jar but no luck and error didn't change.
    I then just unzipped the skyfactory files I still had and copied over my world save, this solved the problem as I suppose any corrupt files were part of the skyfactory and not part of the save.

    I was up late last night so couldn't think about just copying over save files to new install.
     
  5. adamich

    adamich Well-Known Member

Share This Page