Solved Server.BAT Not Working..?

Discussion in 'Server Tech Support' started by ZeMedic, Jan 24, 2013.

  1. ZeMedic

    ZeMedic New Member

    I have checked the forums, and I have not found any solutions.

    I use the Bat file, a command prompt flashes for a second before my eyes, and nothing.


    I don't know what to say, if there is a solution to this and I was simply too lazy to find it, I'm sorry.
    But it worked fine before, I don't understand why it would stop now.
     
  2. Lawbroken

    Lawbroken New Member

    What pack are you using? Also right click the .Bat and copy and paste what you see here. *Probably pointing to wrong location*
     
  3. ZeMedic

    ZeMedic New Member

    Mh, Magic World.
     
  4. Nessiroj

    Nessiroj New Member

    Lawbroken means copy the location you see from the properties after rightclicking you your server.bat file
    also edit your server start.bat and copy and paste the content inhere ;)
     
  5. ZeMedic

    ZeMedic New Member

    I'm afraid that I have no fupping idea as of what you are asking me to do.
    "Right click server.bat, go to properties (I assume)" and then what?

    Edit: After reading your post several times, I've come to the conclusion that you want me to "EDIT" the server.bat and then copy the text onto here.

    java -Xms512M -Xmx1G -jar magicworld.jar
     
  6. Nessiroj

    Nessiroj New Member

    The rightclicking => properties and there you should see a location of your .bat file (aka path)
    or do you know where your server is installed (aka c:\FTBserver\ etc)?

    Your on a windows OS?

    Can you make your server start.bat file the following:
    Code:
    java -Xms512M -Xmx1G -jar magicworld.jar
    pause
    Maybe we can see a quick error instead of the bat file closing.
     
  7. ZeMedic

    ZeMedic New Member

    The files are on my desktop in a seperate folder.

    'java' is not recognized as an internal or external command,
    operable program or batch file.
     
  8. Lawbroken

    Lawbroken New Member

    If you have moved the .bat file out of the folder that the .Jar is in you will have to add the path to it.

    Example.

    /User/Lawbroken/magicworld.jar

    Or you could put the .bat back and right click > Create shortcut to desktop.
     
  9. ZeMedic

    ZeMedic New Member

    The .bat file is in the folder with the rest of the files.
    It already says "C:/user blahblahblah"
     
  10. Lawbroken

    Lawbroken New Member

    If the bat and jar are both in same folder you don't need the long path. just magicworld.jar

    Also download and put the server into different folder to work.

    I got a new computer and works fine for me.
    I'm also out of ideas.
     
  11. ZeMedic

    ZeMedic New Member

    Just to be clear.

    My server has been working before, but suddenly it refuses to start.
    I use the "Server Start" file, which is the .bat file.
    A command prompt flashes before my eyes, saying;
    c:\Users\(myname)\desktop\New folder (2)>java -Xms512M -Xmx1g -jar magicworld.jar

    'java' is not recognized as an internal orexternal command,
    operable program or batch file.

    I am using Windows 7.

    I'm trying to make a Magic World server, I've been downloading the server files from the FTB Launcher itself.
    The files I got are as followed;
    config ------v
    coremods -(folder)
    mods ------^
    magicworld (zip file)
    Server Start (.bat)
    Server Start.sh

    You guys have been giving me advice, but sadly I am confusled as of what it is you've been trying to tell me.
     
  12. Nessiroj

    Nessiroj New Member

    Code:
    \New folder (2)>
    is prob your problem, we found out several times that non (alpha)numeric characters cause stuff to crash. rename that map to FTB orso
     
  13. ZeMedic

    ZeMedic New Member

    Renamed the map, still nothing.
    That wouldn't explain the sudden "Don't want to start" behaviour either.
     
  14. ZeMedic

    ZeMedic New Member

    A possible and probable fix has been dawned.
    For anyone else with the same kind of problem, go to 'Start' in the lower left corner, right click 'Computer' and go to 'Properties'

    Now check your system type, you will have to uninstall your current Java and re-install it with the same 'bit operating system' you have.

    If it says 64-bits, you download the 64 bits Java, if it's 32-bits, you download the 32 bits java.
    If this did not work, you either failed to uninstall your Java, or your computer is 'special'

    Good Day.
     
  15. RustyDagger

    RustyDagger New Member

    This can also be fixed by the default bat file that is being provided not being so mono system... I made a request on having it changed the other day.
     
  16. MisAdeline

    MisAdeline Guest

    Ran into this problem as well. I renamed my jar file to the previous name when it worked. I get it. It is a band aid. However, my server is back up and running :)
     
  17. MTXRooster

    MTXRooster Guest

    While I'm glad you got it solved, technically you can easily and successfully run 32-bit and 64-bit java on the same system without any problem, and use either interchangeably. Most likely cause of it "working" for you by uninstalling and reinstalling wasn't a bit version issue, but rather, when you reinstalled, it updated the path to the java executable.
    In one of your first posts on this thread you nailed it on the head
    That right there is straight up telling you no servers are going to run because Windows can't find Java. (Windows has a path variable that tells it when you say "run the java program" to look through various assigned folders known to contain applications till it finds the first one in the path called java.exe). If it doesn't find that program because, in this case it wasn't specified in the path, it will return that exact error you were receiving.
    Since this is a server category this is a great time to point out RAM allocation limits if you ARE running 32-bit java as well as java -version to tell you what version release as well as 32/64 bit you have installed ;)
     

Share This Page