Waiting RFTools Builder showing "Chunk not found" error, even when all appropriate chunks should be loaded

Discussion in 'FTB Presents Direwolf20 1.12' started by lifeseeker128, Feb 20, 2018.

  1. lifeseeker128

    lifeseeker128 New Member

    Summary of the problem RFTools Builder showing "Chunk not available" error, even when all appropriate chunks should be loaded (mistyped the title a little)

    Pack Version 1.8.0

    What is the bug? I recently took a break from playing this pack for a time, and even before that break (pack version being earlier), I've had this error message on my Builders from time to time: "Chunk not available." This has prevented me from quarrying consistently and smoothly as whenever I manage to clear the condition from the machine (via support mode activation or deactivation), the Builder only mines for a few more minutes to an hour.

    Before taking my break from Minecraft, I mostly experienced this error in the nether and nowhere else... Now, I'm seeing the error in one of my four RFTools dimensions on three of my four Builders running there (I mine a TON of blocks from those). As this dimension is my main source of coal (being made of whole blocks of the stuff), this creates a serious crimp in my energy supply lines.

    I've ensured that my config files facilitate the loading of chunks as the Builder works. I've placed a ChickenChunks spot loader where the Builder stands. I've made sure that the Builder has enough power at most any given time and has an inventory placed on top to collect what's mined... The error still occurs time and again, and only on my quarry Builders, not the ones fitted with pump cards (for oceans of lava). I haven't had this problem with quarry Builders set up in the overworld, only in alternate dimensions.

    Also, I've experienced this error with both clearing and normal quarry cards. I've done everything short of loading every single possible chunk my quarries could mine in their maximum areas via other means such as ChickenChunks, but nothing seems to alleviate this error for more than an hour. I've explored each area thoroughly to generate each respective chunk, but the error still occurs. It hasn't yet caused a crash (although traveling too fast through my dimensions has on occasion), but being an error, I still suspect this to be against mod developer wishes for intended game-play.

    If anyone has a suggestion or knows a solution I haven't yet tried, please tell me. Otherwise, it may be best to suggest a fix to this great mod's developer, and I would like to know where to place one of those.

    Mod & Version RFTools, version 1.12-7.24 (and various earlier versions from the Direwolf20 1.12 pack)

    Link to log file

    Is it repeatable? No. It has only happened to me randomly while using the specified machine in the widest possible area and specified settings with inconsistent results. While trying to repeat this error in other areas or worlds, I found it impossible.

    Known Fix Temporarily, it is possible to use the support/guide mode of the Builder to force the machine to continue operation (toggling this mode on and off)... but this only lasts a few minutes to an hour at a time, without losing quarry progress.
     
    Last edited: Feb 21, 2018
  2. SnowShock35

    SnowShock35 FTB Pack Developer Team Member FTB Pack Developer

    Hi there,

    Sorry to hear you are having this issue. Would you be able to update to 1.9.0 (backing up your world before hand) and see if you get any further problems.

    McJty has addressed several issues with the Builder in the last couple of updates which are now in the above mentioned version of the pack so its possible the issue is solved. However, if the issue continues to occur I'll do my best to find out what is happening and get it sorted for you.

    These types of issues, where there's no easy way to repeat them, are the worst! So, I can understand it being quite frustrating to you.

    Let us know how you get on.
     
  3. lifeseeker128

    lifeseeker128 New Member

    Well, I somehow managed to fix the builders I have in RFTools dimensions, but upon returning to a familiar spot in the Nether with another Builder ready, the same error occurred, preventing me from quarrying easily past some certain point. I tried this at the mentioned spot after updating my pack to 1.9.0 with no more luck than before of pushing past the "Chunk not available" error. The error still occurs but only really in the area they first occurred. I'll try to place the builder in a few different spots in the nether to see what happens. Here's a screenshot of my test builder setup so far:
    ChunkNotAvailable_NetherEdition.png
     

Share This Page