Problem RedPower Startup Crash

Jenial

New Member
Jul 29, 2019
249
0
0
Hello.

Since a restart, I suddenly can't start my server any more. Whenever I try, the server crashes with the following crash report below. (Before loading the map, so it's not a world corruption!)

Does anyone know a fix and is willing to share it with me? I'd rather not start up the server with Redpower uninstalled, or all players will lose their redpower progress.
I've tried reinstalling the mods, using a redpower config provided with the server files, and tried to edit it myself, however, none of this worked.

Thankyou,
Jenial.

Full crash report @ PASTEBIN: http://pastebin.com/2Md8z4Ju
Code:
---- Minecraft Crash Report ----
// Oops.
 
Time: 2/6/13 5:34 PM
Description: Exception in server tick loop
 
java.lang.NullPointerException
    at com.eloraam.redpower.RedPowerControl.setupBlocks(RedPowerControl.java:117)
    at com.eloraam.redpower.RedPowerControl.load(RedPowerControl.java:50)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:487)
    at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:69)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:317)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:300)
    at com.google.common.eventbus.EventBus.post(EventBus.java:268)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:140)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:69)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:317)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:300)
    at com.google.common.eventbus.EventBus.post(EventBus.java:268)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:83)
    at cpw.mods.fml.common.Loader.initializeMods(Loader.java:657)
    at cpw.mods.fml.server.FMLServerHandler.finishServerLoading(FMLServerHandler.java:94)
    at cpw.mods.fml.common.FMLCommonHandler.onServerStarted(FMLCommonHandler.java:355)
    at ho.c(DedicatedServer.java:135)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:458)
    at fy.run(SourceFile:849)
 

Symon

New Member
Jul 29, 2019
3
0
0
Did you ever find a fix? This has just happened to me when fragnet did a restart on my server last night.
 

Jenial

New Member
Jul 29, 2019
249
0
0
I used to fix it by starting the server without any redpower config. It was a temporary fix though. It reoccured every 2 days.