1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Project Ozone 3 very laggy [solved]

Discussion in 'General FTB chat' started by Boerny, Feb 13, 2019.

  1. Boerny

    Boerny New Member

    Hi everyone,

    so i just started PO3 (garden of glass) and it is very laggy. Just on the starting island doing nothing i am below 60fps when i craft some pebbles to cobble it freezes for a short moment and fps drops to 30.
    I normally dont have fps problems up to very late game. Skyfactory 3 PO2 Stoneblock 2 nothing was a problem but now with no machines/chuck updates whatsoever i get below 60 fps?

    I guess something is not right there. BetterFPS is set to Rivens Full Algorithm (default).
    I did change the GUI sice form auto to 3 because it somehow zoomed on auto so far in i cound see the text in the keybind options.

    Is it a PO3 problem or something i have to change?
    Memory is arond 40% (4 out of 9gb) and
    Allocated is 62% (5681) and i play on 1920x1080


    Hope somebody got an idea to fix this :)

    Thanks


    Edit: I remember from Stoneblock 2 that the debug Pie (shift + F3) showed manly "gameRenderer" but here 3/4 are taken form "tick" maybe this causes the lag
     
    Last edited: Feb 13, 2019
  2. BaconsTV

    BaconsTV Member

    So far my only issue with lag is when I place something on a pad I made which is quite large 128 diameter I think if not more. If I put a block down it pauses for a second :/ Also my AE system powers down each time I load the game up, id need to disconnect the power and reconnect. Have you had these issues?

    I would love to try increase the ram from 10 to 15 or 20 from the 32g ram I have.
    Anyway frames are 110 to 120 with a 8% GPU usage
    CPU is roughly 10 to 20% usage
    RAM used 21gig
    These figures are from Afterburner.

    In F3 Frames are somewhat the same as above
    Mem 40 to 50%
    Allocated 66%

    SHIFT F3 pie is
    [1]70%
    [2]12%

    1 decreases as 2 increases slowly.. This is 5 mins after loading and I think 2 may keep going up o_O
    Im on a ryzen 2700, ROG 1080TI, 32gig 3200 gskil ram and M.2 SSD for os and games. If that can help you for comparison.
     
  3. Boerny

    Boerny New Member

    Well compared i am playing on a wooden toaster^^

    i5 3350P @ 3.10GHz
    16gb of ram
    and HDD only


    also i noticed that with 0 block updates, while staring at stone my ram usage goes up to 7gb, drops to 3gb and starts rising to 7 again over and over. Just doesnt seem right. Im in the very beginning of the game so idk whats up with AP2.

    updated my java form .77 to .202 now.... xD
    maybe that helps if not i'll have to go full potato mode for this pack

    btw excuse my english pls im not a native speaker^^
     
  4. BaconsTV

    BaconsTV Member

    if you notice a difference from the java update tell me :)
     
  5. Boerny

    Boerny New Member

    Well that was kind of weird. I guess you know that there are multiple Java types. Not at the PC atm but it was a 3 letter "shortcut" for developer Java and runtime Java. I got the 77 version of runtime and updated to 202 of the dev version. To select a Java in twitch you have to set it to the old launcher and the old lauchner told me that my 77 "lite" version is newer than the 202 dev version wich everyone uses.
    Anyways the old launcher crashed with both versions trying to load po3.
    Also I added several performance mods but that version of po3 (with new launcher) also crashed.

    Tomorrow I'll try to add fastcraft (not recommended on reddit page) and vanilla fix to the pack and hope that it runs with just these two.

    I still got no clue why this pack runs so badly. 40 fps and when a crafting grit opens 20 fps. Normally at this point I run super large crop farms and multiple miners but in this pack 50 blocks seem to be enough....
    If you got anymore ideas why it is like this please tell me.
     
  6. BaconsTV

    BaconsTV Member

    My twitch client is 7.5.6941.40000 Live If this means anything to you :) and PO3 is 3.0.37 nothing added to the pack, yet using the resource file that came with it. May try KUDA shaders and stuff tomorrow
     
    Boerny likes this.
  7. Boerny

    Boerny New Member

    So it is running smoothly now. I installed VanillaFix and turned "Force threaded chunk rendering" in ingame Minecraft Forge Config on.
    Vanilla fix did the most for me and my debug chart isnt filled with "tick" anymore but game renderer now. (Wich i think is good/normal?)
    Running 90-120 fps now but when crafting. Maybe going to install fastcraft but idk since PO3 left it out for some reason.

    Well anyways it works fine now and maybe someone will find this helpfull as well :)
     
    BaconsTV likes this.
  8. Brotuulaan

    Brotuulaan Active Member

    I was playing on a server one time and getting frame drops down to 25 or so (normally run about 60) every time I looked one direction (built a house out in the wilderness, no animals/players in sight), and simply installing Optifine virtually eliminated all the frame drops. Not sure what caused it at the time, but Optifine has so many versions that I'm sure it could also help out in almost any mod pack you're running.
     

Share This Page