Offcial FTB Server Plugin thread!

Status
Not open for further replies.

Greedseed

New Member
Jul 29, 2019
1,107
0
0
Plugins
currently compatible with FTB server ! (1.4.7) Assuming you have MCPC+ or BukkitForge
What do i pick, MCPC+ or BukkitForge? Read more about that here.

Plugin Name: PEX
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/permissionsex/
Description: PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification. Has database support
Last mod Compatibility version: 1.19.5


Plugin Name: Grief Prevention
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/grief-prevention/
Descripion: A awsome replacement for Tany, Nations or any other area protection plugin. This is build for preformance and easy use by anyone. The simple golden shuvel is amazing for newbies to Minecraft and easy to use. Also it will not bug down your server when a lot of players are online like towny.
Last mod Compatibility version: 7.6.2


Plugin Name: LWC
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/lwc/
Description: LWC is a chest protection plugin. It works threw flatfile or SQL. Adding mod items to the protection list is easy and unlimited.
Last mod Compatibility version: 4.3.1


Plugin Name: Coreprotect
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/coreprotect/
Description: A very quick and fast block logging/rollback tool.
Last mod Compatibility version: 2.04


Plugin Name: WorldBorder
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/worldborder/
Description: WorldBorder is a world limitation plugin. Set a limit how big your world can be to limit HDD use and spare CPU and Ram power.
Last mod Compatibility version: 1.7.2


Plugin Name: TekkitCustomizer
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/tekkitcustomizer/
Description: This plugin will make you able to block the crafting, holding, placing, ... of items. Item ID's work two so perfect for Mod servers. Also adds the option to add permission nodes per banned item to then allow for certain groups.
Last mod Compatibility version: 1.6


Plugin Name: Essentails
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/essentials/
Description: This is a awsome admin tool that will make your life a lot easyer. More and simple commands. Server controll and much more.
Last mod Compatibility version: 2.10.1


Plugin Name: WorldEdit
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/worldedit/
Description: A awsome tool to edit, copy, paste and so much more.
Last mod Compatibility version: 5.5.5


Help us expand this list! Add plugins you know that work with MCPC+ or BukkitForge! Get it confirmed and even add configs!


Config files!

Ultimate pack 1.0.1
GriefPrevention
http://pastebin.com/hsKcxthG - By Greedseed - Not including XReliquary, PowerConvertors and EE3

TekkitCustomizer
http://pastebin.com/5CAg0tCe - By Greedseed - Not including XReliquary, PowerConvertors and EE3
 
  • Like
Reactions: SomniusX

Greedseed

New Member
Jul 29, 2019
1,107
0
0
WorldEdit link needs changing. On MCPC wiki theres a ported version for MCPC+.
The version on the MCPC+ wiki is 5.5.2 or higer, it links to the WorldEdit dev.bukkit.com page and is basicly the same link i post. 5.5.5 works
on MCPC+ L15 as i have bin using it on my server for some time now.
 

MRHeavyMetal_SIR

New Member
Jul 29, 2019
146
0
0
I have hawkeye on my server and all the commands seem to work fine there isn't full support because it doesn't log transactions from barrels and iron chests but the rest seems to work fine i also have essentials commandbook and buycraft working fine, i use MCPC+
 

Profjb

New Member
Jul 29, 2019
120
0
0
Thanks so much for including my thread
Ide like to expand this already :).

All of the essentials including groupmanager all work. I can say that, on bukkitforge and MCPC+.


Plugin Name: Coreprotect
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/coreprotect/
Description: A very quick and fast block logging/rollback tool.
Last mod Compatibility version: 2.04

proof: I run it on my server and this picture pretty much
sums this up: http://prot3ch.net/gallery/m/4361670/detail/114098#pid=1090108

Also. a lot of other plugins have moved to other forge based ways. I believe you
could include this in your post. E.g.

Enjinminecraft plugin: http://www.minecraftforum.net/topic/1659976-1467-forge-enjin-minecraft-plugin-beta-241/
votifer: http://www.minecraftforum.net/topic/1662210-1467-forge-votifier-version-190/
Dynmap: http://www.minecraftforum.net/topic...c-web-based-maps-for-minecraft/#entry18859919[DOUBLEPOST=1367048567][/DOUBLEPOST]Also, if you believe me on this xD. Saveit (newest 1.4.7 version) works.
and ontime(newest 1.4.7 version) works.
 

Profjb

New Member
Jul 29, 2019
120
0
0
No. I use a custom modpack with lockit (mod) to lock all these type things. I do reccoemdn LWC for this though. It does still log chests though.
 

Chrissy

New Member
Jul 29, 2019
460
0
0
i was unaware i could have plugins on an FTB server, It seems to only support the deafault server D:
 

Greedseed

New Member
Jul 29, 2019
1,107
0
0
i was unaware i could have plugins on an FTB server, It seems to only support the deafault server D:
currently compatible with FTB server ! (1.4.7) Assuming you have MCPC+ or BukkitForge
What do i pick, MCPC+ or BukkitForge? Read more about that here.
Means you need to install MCPC+ or BukkitForge on your FTB server instance. This is will NOT come with the download of the FTB website or launcher. See the links above where to get and install MCPC+ or BukkitForge
 

pirita

New Member
Jul 29, 2019
195
0
0
I am looking for plugin that can create world and flat worlds for Ultimate 1.1.0
I tested multiworld, Multiverse-core and mcworld, but all have issues.
 

Charles Kelly

New Member
Jul 29, 2019
5
0
0
anyone know where i can get patches for coreprotect, hawkeye, logblock or another plugin so it logs things like the wand of excavation, mining laser and quarry?
 

Profjb

New Member
Jul 29, 2019
120
0
0
mining lazers are logged with hawkeye, I know that for sure, at least they use to. Ide assume coreprotect logs it to. As for excavation wands, there are so many problems with them, even with LWC and a mod called lockit. Although drastic, ide ban them.
 

Charles Kelly

New Member
Jul 29, 2019
5
0
0
mining lazers are logged with hawkeye, I know that for sure, at least they use to. Ide assume coreprotect logs it to. As for excavation wands, there are so many problems with them, even with LWC and a mod called lockit. Although drastic, ide ban them.
Seems a shame to ban em, Can someone decompile thaumcraft and make the wand of excavation use proper block break events and released a patched version?
 

snaiperskaya

New Member
Jul 29, 2019
9
0
0

Plugin Name: WorldBorder
Compatible with: MCPC+
BukkitDev Link: http://dev.bukkit.org/server-mods/worldborder/
Description: WorldBorder is a world limitation plugin. Set a limit how big your world can be to limit HDD use and spare CPU and Ram power.
Last mod Compatibility version: 1.7.2

Out of curiosity, we're working with a custom 1.5.2 pack and I was wondering if anyone has tried the border fill/trim capability of this plugin. Does it behave properly with Forge mods' worldgen or will it break things? I have a few players that like to... explore, and I'd like to keep things roped in a bit more. However, seeing that functionality, I thought it might be nice to be able to pre-gen world to take a little bit of long-term stress off the server.
 

Alchemist

New Member
Jul 29, 2019
41
0
0
Out of curiosity, we're working with a custom 1.5.2 pack and I was wondering if anyone has tried the border fill/trim capability of this plugin. Does it behave properly with Forge mods' worldgen or will it break things? I have a few players that like to... explore, and I'd like to keep things roped in a bit more. However, seeing that functionality, I thought it might be nice to be able to pre-gen world to take a little bit of long-term stress off the server.
It does work, I tested it personally on my 1.5.2 server.
 
Status
Not open for further replies.