Bug NEW Server crashing constantly, and now crashing on startup

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Eventual bugs for older packs will not be fixed.

dtoxftw

New Member
Dec 31, 2019
10
1
3
https://paste.feed-the-beast.com/view/c00bd163

c00bd163 : paste of full report. (I'm not sure if mods have approved me posting links yet)

Skyfactory 3 (1.10.2) no other mods installed

Only 2 players. We've always had some major rubberbanding issues and have started manually crafting since we believed Refine Storage autocraft was the culprit. Not a whole lot has change though, and now the sever crashes on startup! I've reinstalled the server a few times now. (Using what twitch provides)

Also, the FTB launcher (FTBserver-1.10.2-12.18.3.2477) has never worked for us. I use the 'ServerStart' batch file. (Not sure if that matters)

The final few lines of CMD promt:

[17:08:14] [Server thread/INFO] [net.blay09.mods.twitchcrumbs.Twitchcrumbs]: Registering 0 Twitchcrumbs users...
[17:08:14] [Server thread/INFO] [FML]: Loading dimension 4 (world) ([email protected])
[17:08:15] [Server thread/INFO] [Actually Additions]: Successfully received WorldData for world 4!
[17:08:15] [Server thread/INFO] [FML]: Found 1 islands list now loading islands.
[17:08:17] [Thread-16/INFO] [immersiveengineering]: Finished recipe profiler for Arc Recycling, took 2953 milliseconds
[17:08:54] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 39836ms behind, skipping 796 tick(s)
[17:09:54] [Server Watchdog/FATAL]: A single server tick took 60.00 seconds (should be max 0.05)
[17:09:54] [Server Watchdog/FATAL]: Considering it to be crashed, server will forcibly shutdown.
[17:09:54] [Server Watchdog/ERROR]: This crash report has been saved to: C:\Users\dtox_04\Desktop\FTBPresentsSkyfactory3Server_3.0.15\.\crash-reports\crash-2020-01-08_17.09.54-server.txt
[17:09:54] [Server Shutdown Thread/INFO]: Stopping server
> Exiting...
Press any key to continue . . .

The "Can't keep up" error is something that is constantly up while playing. 1,000ms here, 10,000ms there. :/

A couple other notifications i notice while the information zips by:

[17:07:36] [Server thread/WARN] [ColossalChests]: The config file of ColossalChests is out of date and might cause problems, please remove it so it can be regenerated.
[17:07:36] [Server thread/WARN] [CommonCapabilities]: The config file of CommonCapabilities is out of date and might cause problems, please remove it so it can be regenerated.


And:

[17:07:43] [Server thread/INFO] [draconicevolution]: Adding ore entry for Dragon Mounts Dragon Eggs...
[17:07:43] [Server thread/WARN] [bitdrawers]: Your version of Storage Drawers (3.7.10) differs majorly from the one Drawers & Bits was compiled with (3.6.1). Use at your own discretion, in case of issues please open an issue on GitHub and revert the version of Storage Drawers to the one known working until I can fix compatibility.


Not sure how seriously I should be taking these errors since they can barely be noticed as the server loads, and skyfactory 3 is already a bit old...

Dedicated server PC:

i3-9100f (3.6GHz)
16GB ram (3200mhz)

Ram dedicated to server:
MIN- 1024
MAX- 5120

I've tried 8bg, 6bg, and now 5gb, in hopes that it was simply a java garbage issue. No change though.

I really want to play! Any help is appreciated! :)
 

grandrolf

Global moderator
Team Member
Global Moderator
Trusted User
Aug 29, 2014
2,329
220
108
sweden
Try removing the refined storage controller, and then replace it
 

dtoxftw

New Member
Dec 31, 2019
10
1
3
Try removing the refined storage controller, and then replace it
We did that yesterday after realizing we didn't do it correctly on our previous server. Seems to have helped but just a bit. Server doesn't crash on load but still crashes during game-play. I'll add an updated crash report when I sneak out for lunch break. thx