1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Need help using launcher in linux (Ubuntu)

Discussion in '[Archived] Tech Support' started by theEPiK1, Nov 19, 2012.

Thread Status:
Not open for further replies.
  1. theEPiK1

    theEPiK1 New Member

    Well the story is, I have Xubuntu operating system on my computer and really want to play the mod pack on this computer.
    I have tried the .jar and .exe. I have the latest version of JDK(Java developer kit). Minecraft and other jar based files work on my computer, but not any of the ftb ones. Any help on how I can get it to work?.

    In summary:
    Operating System: Xubuntu 12.04
    FTB Launcher version : Newest (Tried recently)
    Minecraft Version: 1.4.2, can't open the launcher though.
    Java version: JDK(Java Dev Kit Runtime) 6
    Detailed description of the issue / how can the issue be recreated: None of the launcher files downloaded from the site can be launched.
    Error logs: The file '***' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.
    Thanks for any help in advance!
     
  2. Ashzification

    Ashzification New Member

    To run the FTB launcher you need JRE 7u9.
    Take your JDK and put it elsewhere (a partition on the HDD, a thumb drive, anywhere it won't interfere with JRE7u9)
     
  3. knaar

    knaar New Member

    Hi theEPiK1, fellow ubuntu user here.

    If xubuntu has nautilus do this:

    Right click the jar file, click properties, and in the permissions tab at the top, put a checkmark in the box that says "Allow executing file as program" and click OK. Another option is to right click and "run with Java" (it might say OpenJDK or whatever as well).

    If you don't have nautilus (I have no idea if xubuntu comes with nautilus or not, it's a gnome thing so... yeah dunno), do this in the terminal:

    cd ~/path/where/ftb/is
    java -jar FTB_Launcher.jar

    You could make those two lines into a bash script if you know how so you don't have to type them every time. If it still complains about it not being executable run this once:

    chmod +x FTB_Launcher.jar

    That will turn on the 'x' bit (aka executable bit).
     
  4. theEPiK1

    theEPiK1 New Member

    Thanks! will try it now
    -edit-
    Both solutions work, problem solved!
     
Thread Status:
Not open for further replies.

Share This Page