Problem My Ubuntu linux server setup doesn't work. ( doesn't execute) FTB revelation 3.4.0


New Member
Jan 31, 2022
I've been having some issues with my FTB server. I am very new to Linux and am just planning to run a server on an old shitty laptop. Everything worked as planned. 1; wrote in cmd: "sudo apt update" (it worked and no issues were found) 2; I installed java through the "sudo apt-get install default-jre" and it also worked as expected. 3; I downloaded FTB revelation (, nothing wrong yet. 4; I then ran / unpacked the executable. 5; I ran the "sh" and then it gave an error code that is as follows:
A problem occurred running the Server
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reclect.NativeMethodAccessorImpl.invoke(
at java.base/jdk.internal.reclect.DelegatingMethodAccessorImpl.invoke(
at java.base/java.lang.reflect.Method.invoke(
at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(
Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class (jdk.internal.loader.ClassLoader$AppClassLoader and are in module java.base of loader 'bootstrap')
at net.minecraft.launchwrapper.Launch.<init>(
at net Minecraft.launchwrapper.Launch.main(
. . . 6 more

It should be said that I did get a normal Minecraft 1.12.1 to work before this. But since I have those files in a separate folder I don't reckon they should make a difference unless java does something stupid... :)

Thank you in advance for helping me solve this issue!

(And if you find some spelling mistakes in my code:
Yes, I was really stupid and just wrote all that code above instead of just copy N' paste it... I really should have mailed it or something but I didn't)