Minecraft 1.12.2 crashes with Forge (vanilla launcher)

Flexico

Well-Known Member
Dec 15, 2012
302
39
53
Today I was fiddling with mods to get my pack updated to 1.12.2, and it was going well (aside from a few mods not playing nicely), until Minecraft suddenly refused to run. I removed mods one by one to see which one caused it, but it crashes with only Forge installed. It only works if I run totally vanilla. I re-installed Forge and cleared my instance folder, but it keeps happening! It doesn't even get far enough to create a "mods" folder. This is the shortest error log I've ever seen:
Forge:
[00:19:48] [Client thread/INFO]: Setting user: Flick_Penrose
[00:19:50] [Client thread/INFO]: LWJGL Version: 2.9.4
[00:19:50] [Client thread/INFO]: Reloading ResourceManager: Default
[00:19:51] [Sound Library Loader/INFO]: Starting up SoundSystem...
[00:19:51] [Thread-3/INFO]: Initializing LWJGL OpenAL
[00:19:51] [Thread-3/INFO]: (The LWJGL binding of OpenAL. For more information, see http://www.lwjgl.org)
[00:19:51] [Thread-3/INFO]: OpenAL initialized.
[00:19:51] [Sound Library Loader/INFO]: Sound engine started
[00:20:05] [Client thread/INFO]: Created: 1024x512 textures-atlas
[00:20:10] [Client thread/INFO]: Narrator library successfully loaded
[00:20:19] [Client thread/INFO]: Stopping!
[00:20:19] [Client thread/INFO]: SoundSystem shutting down...
[00:20:19] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com
MC Launcher:
OpenJDK 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Exception in thread "main" java.lang.NoClassDefFoundError: jline/console/ConsoleReader
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
at java.lang.Class.getDeclaredMethods(Class.java:1975)
at org.apache.logging.log4j.core.config.plugins.util.PluginBuilder.createBuilder(PluginBuilder.java:147)
at org.apache.logging.log4j.core.config.plugins.util.PluginBuilder.build(PluginBuilder.java:119)
at org.apache.logging.log4j.core.config.AbstractConfiguration.createPluginObject(AbstractConfiguration.java:952)
at org.apache.logging.log4j.core.config.AbstractConfiguration.createConfiguration(AbstractConfiguration.java:892)
at org.apache.logging.log4j.core.config.AbstractConfiguration.createConfiguration(AbstractConfiguration.java:884)
at org.apache.logging.log4j.core.config.AbstractConfiguration.doConfigure(AbstractConfiguration.java:508)
at org.apache.logging.log4j.core.config.AbstractConfiguration.initialize(AbstractConfiguration.java:232)
at org.apache.logging.log4j.core.config.AbstractConfiguration.start(AbstractConfiguration.java:244)
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:545)
at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:617)
at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:634)
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:229)
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:242)
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:45)
at org.apache.logging.log4j.LogManager.getContext(LogManager.java:174)
at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:618)
at net.minecraft.launchwrapper.LogWrapper.configureLogging(LogWrapper.java:14)
at net.minecraft.launchwrapper.LogWrapper.log(LogWrapper.java:28)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
Caused by: java.lang.ClassNotFoundException: jline.console.ConsoleReader
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:338)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 23 more
 

Flexico

Well-Known Member
Dec 15, 2012
302
39
53
Just in case anyone else has this problem and finds this thread, I ended up fixing it by just clearing my whole .minecraft folder, except for my "saves" and "screenshots" folders, and reinstalling. Still have no idea what caused the problem, but it hasn't come back since. *shrug*
 

BWA

New Member
Jul 29, 2019
26
0
0
I also have this problem with revelations modpack. any forge update from 1.12.2-14.23.2.2651 on up. and minecraft wont even start. doesn't even get to the point to create a log file. puts up a java.lang.noclassdeffounderror: jline/console/consolereader on the console
 

MacAisling

Popular Member
Apr 25, 2013
1,073
606
128
Kearneysville, West Virginia
I also have this problem with revelations modpack. any forge update from 1.12.2-14.23.2.2651 on up. and minecraft wont even start. doesn't even get to the point to create a log file. puts up a java.lang.noclassdeffounderror: jline/console/consolereader on the console
A couple weeks ago there was 1 specific bad update of forge, but I think you are having a different problem. My best guess is that there is at least 1 mod in the pack that did not keep up with the forge updates and had something break compatibility.
 

BWA

New Member
Jul 29, 2019
26
0
0
possibly, I posted it up on its own thread. seems to be with every forge update since 51. hopefully the revelations modpack team can find it and either update it, or kick it out. I would settle for the name of the mod if nothing else.