Lonsdaleite ??

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Bugs for older packs will not be fixed, unless they are critical.

zaq_hack

New Member
Jul 29, 2019
23
4
1
Title Lonsdaleite ??

Launcher Type Twitch Desktop App

Modpack Revelation

Modpack version 1.8.0

Have you modified the pack? No

Link to log file

Details of the issue How do you get Lonsdaleite? The doesn't seem to be a recipe, but it is required for Environmental Tech modifiers.
 

SolManX

New Member
Jul 29, 2019
989
-1
1
It comes from the void ore miner itself.

You need to run the first tier (for quite a while) to get to the second tier etc anyway.

EDIT: Don't put any focus on the first tier - it'll reduce your chances.
 
Last edited:

zaq_hack

New Member
Jul 29, 2019
23
4
1
Okay, but nothing tells me that it produces it. So, if I look at the miners in JEI, they aren't linked to this ...
 

zaq_hack

New Member
Jul 29, 2019
23
4
1
Okay, but nothing tells me that it produces it. So, if I look at the miners in JEI, they aren't linked to this ...
Meaning: The other crystals, if I look them up, it tells me which mining tier I need to produce it. I just upgraded to T2, and all the upgrades for it require this thing ... which I can't figure out how to get.
 

GamerwithnoGame

Forum Addict
Jan 29, 2015
2,746
1,478
194
Just as a point of interest, when playing Horizons III, which was a 1.12 pack, I had my void ore miner up for a long time and never got any Lonsdaleite. But then the upgrades didn’t need it either, they only needed mica. If it doesn’t tell you anything at all for it in JEI - like at all - then that’s slightly worrying.
 

zaq_hack

New Member
Jul 29, 2019
23
4
1
And here is the speed modifier showing a dependency on it ... Should I find a way to hack the mod pack to put this back to Mica? That sounds a lot less impossible. (I have a resource miner and some Mica, already.)

upload_2018-3-31_15-28-41.png
 

GamerwithnoGame

Forum Addict
Jan 29, 2015
2,746
1,478
194
And here is the speed modifier showing a dependency on it ... Should I find a way to hack the mod pack to put this back to Mica? That sounds a lot less impossible. (I have a resource miner and some Mica, already.)

View attachment 36218
And there’s no separate recipe for the block of lonsdaleite apart from 9 individual ones I take it? That being the case, I think your best bet is to look at the modtweaker/craftweaker scripts. The custom recipe will be defined in there; messing with them when you aren’t familiar with them can lead to trouble so I’m not keen to suggest it, but in theory there should be a remove.recipe that takes away the normal recipe for it, and a line that adds the custom recipe. If those two are removed then you should just be able to use the normal recipe for the modifier.

It seems very odd that they’d add in a custom recipe specifically that’s impossible to make, rather than just removing the modifier recipe if they didn’t want you to make it, so it’s possible there may be some alternate method of making it using an atypical crafting process that JEI doesn’t cover.

Is there a pack author or admin that has particular responsibility for Revelation?

EDIT: so apparently there is an absolute dearth of information about Revelation...!!! No official post dedicated to it on the forum, no info about changes or anything... it doesn’t seem to be super well supported :/
 
Last edited:

SolManX

New Member
Jul 29, 2019
989
-1
1
Okay - I had to check. In JEI I can see four modifiers (null, speed, piezo and accuracy), none of which require lonsdaleite.
 

zaq_hack

New Member
Jul 29, 2019
23
4
1
Revelation has been interesting because it has forced me to use mods I have never used before. Some of them are better, some not so much. I miss Thaumcraft. I can't build a Turbine with Extreme Reactors (different glitch). The changelog is pretty spotty. But I'm having fun with it in spite of all that, so I've kind of stuck with it. Learning XNet has been totally worthwhile, and using Industrial Foregoing has been fun, too. So, I want to explore the pack some more before I give up on it.

That said, this is the 4th or 5th issue like this that I've had. Super annoying. It is turning a time-gate into a super-duper time-gate.

I linked a quick video of browsing for the solution ...
 

GamerwithnoGame

Forum Addict
Jan 29, 2015
2,746
1,478
194
That’s super weird! So @SolManX you tried it on Revelation and didn’t find any altered recipes? Something screwy is going on. Those recipes in @zaq_hack’s video absolutely had the 1.12-specific ET minerals (like kyronite and aethium), and yet also lonsdaleite... what version of Revelation were you both using? I know your post said 1.8.0. zaq.

You both should have the same recipes available so something has gone awry there.
 

SolManX

New Member
Jul 29, 2019
989
-1
1
Pardon me guys, it seems that Twitch doesn't necessarily download the very latest version unless you specifically request it, only the latest release version, which was 1.6.
 

GamerwithnoGame

Forum Addict
Jan 29, 2015
2,746
1,478
194
Ah! Now, that might be the root cause; not being the release version, 1.8 is presumably one that’s still being worked on, which might explain broken/incomplete recipe paths.

That being the case @zaq_hack, it may be worth rolling back your version (as long as it doesn’t break anything) or else waiting for it to be updated.

I was wondering privately about whether there was going to be some weird crafting route, like I’ve seen in Project Ozone Lite, whereby graphite dust is turned into hyper diamonds via explosion. I don’t think there was a JEI entry for that. And I wasn’t sure whether there might be something similar here, where diamonds are converted to lonsdaleite (which is, after all, an allotrope of diamond also called hexagonal diamond) via explosion or something. I had no basis for that thought, it just occurred to me as something they might do! But I doubt it’s anything that in depth.
 

SolManX

New Member
Jul 29, 2019
989
-1
1
What's a bit confusing though is that there doesn't seem to be any config difference between either of the two Revelation versions and between those and DireWolf20 1.12 pack, which does use lonsdaleite and generates correctly in the void ore miners.

Also no scripts that could explain the differences (that I can see, of course :) )
 

GamerwithnoGame

Forum Addict
Jan 29, 2015
2,746
1,478
194
What's a bit confusing though is that there doesn't seem to be any config difference between either of the two Revelation versions and between those and DireWolf20 1.12 pack, which does use lonsdaleite and generates correctly in the void ore miners.

Also no scripts that could explain the differences (that I can see, of course :) )
How bizarre! How bizarre.

So I haven’t come across lonsdaleite in 1.12 as mentioned, and I think the version of ET used in Horizons III is fairly up to date.

There is one other factor; with Environmental Tech, when updating between big version changes, you often need to delete the .jsons for things like the void ore miner, and let them regenerate when you start up the pack again. If that isn’t done, you can sometimes get some janky behaviour. That’s the last unresolved peculiarity I can think of!
 

zaq_hack

New Member
Jul 29, 2019
23
4
1
Because of other glitches, I often upgrade as soon as I see a new version to see if it fixes previous goofiness. 1.7 was unstable, and I rolled back to 1.6 right away. But 1.8 was out like a day later; it seems more stable. So, I stuck with it. My upgrade path is typically to run the server once, then swap "world" folders. I might try a 1.8 "solo" game just to see if it has the same issue.

Anyway, thanks for the speculation on things. If there were some oddball method of generating lonsdaleite, what's the best way to figure it out?
 
  • Like
Reactions: GamerwithnoGame

GamerwithnoGame

Forum Addict
Jan 29, 2015
2,746
1,478
194
Because of other glitches, I often upgrade as soon as I see a new version to see if it fixes previous goofiness. 1.7 was unstable, and I rolled back to 1.6 right away. But 1.8 was out like a day later; it seems more stable. So, I stuck with it. My upgrade path is typically to run the server once, then swap "world" folders. I might try a 1.8 "solo" game just to see if it has the same issue.

Anyway, thanks for the speculation on things. If there were some oddball method of generating lonsdaleite, what's the best way to figure it out?
The best way is probably what you’ve done here; throw the question out and see if anyone who’s played the pack knows about it. But my feeling is still that there might be an oddity with the .json files. Those define what the miners can pull up and their probabilities if memory serves. If an earlier version of ET didn’t have lonsdaleite, and it’s jsons weren’t overwritten by up to date ones, it would still register as not being able to get it with the miner.
 

Folbad

New Member
Jul 29, 2019
1
0
0
I joined Valkyrie's discord last night because I was having this same problem with Lonsdaleite. He says "It is mined with the Void Ore Miner. Currently the FTB packs have it removed from the loot tables so report it to them for a fix." Hope this helps
 
R

Robear

Guest
If you feel comfortable tinkering around with the JSON files, you can add lonsdaleite in. The files are in the minecraft server folder here:
./config/environmentaltech/multiblocks/void_miner/ore/
There's one JSON file for each miner level.
If you want the machines to actually produce the ore, edit the files on the server.
If you want the changes to show in NEI, you'll need to update the client files as well.

I recommend editing them on your local machine FIRST. Then load up a single player creative world to verify that you didn't muff up the files somehow. Once you're sure they work, upload them to your server with Filezilla or something. Once uploaded, you'll need to restart your server.

The weight is relative. I made it 1 for tier 1, 2 for tier 2, and so on.

For example, this is what I added to tier_4.json
Code:
  "outputs": [
    {
      "target": "lonsdaleite",
      "weight": 4,
      "id": "environmentaltech:lonsdaleite_crystal"
    },
    {
      "target": "litherite",
      "weight": 20,
      "id": "environmentaltech:litherite_crystal"
    },
    {
      "target": "erodium",
 
  • Like
Reactions: GamerwithnoGame