Legacy launcher wont show all thirparty modpacks

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Eventual bugs for older packs will not be fixed.

LetMePlay

New Member
Oct 22, 2019
3
0
2
Title: Legacy launcher wont show all thirparty modpacks

Launcher Type: FTB legacy launcher (I thinks thats what its called, it's not the twitch one)

Logs: https://paste.feed-the-beast.com/view/d2b76a4d

The problem:

So i've been playing AgrarianSkiesHQ for a while without problems however one day while trying to start it up the modpack was gone from the launcher. My save files are still in place and so is the modpack when looking in %appdata%/local/modpacks.
But the launcher says
[12:47:50] [WARN] in Launcher LaunchFrame.updateTpInstallLocs:719: Can't find modpack: AgrarianSkiesHQ

Things ive already tried after lots of googling about what the problem could be:
- restarting the launcher (many times over different days)
- force update
- reinstall the launcher (also tried installing the launcher on a different pc but still has the same issue)

What ive found and what I think the issue is. Is that the thirdparty.xml file that the launcher downloads on launch is incomplete, changed or wrong.
This is (as far as i could find) what the thirdparty.xml file should be
https://ftb.cursecdn.com/FTB2/static/thirdparty.xml
However when I look up the thirdparty.xml file in %appdata%/local/modpacks it's missing the last two modpacks. (AgrarianSkiesHQ and Vanilla Minecraft)
The last modpack on my thirdparty.xml file is CrashLanding, which is also the last thirdparty modpack my launcher shows.

Ive tried editing the thirdparty.xml file myself to include AgrarianSkiesHQ but the launcher just overrides all the changes ive made on launch. So that doesnt work.

I've also read that changing the download location in advanced options might help. But my launcher only shows two options there (automatic and CurseCDN). Ive tried both and they both dont fix my problem.

So i think there is a problem with the thirdparty.xml file that my launcher downloads (it's missing modpacks). But I cant find a way to check that or fix it.

I would really like to play again cause ive put alot of time into my world. But cant play right now cause my launcher cant find the modpack. Any help is greatly appreciated.