Launcher Error "Could not create Java Virtual Machine" (have 64 bit Java)

Discussion in 'Tech Support' started by Benie76, Jan 31, 2016.

Thread Status:
Not open for further replies.
  1. Benie76

    Benie76 Active Member

    Title:
    Launcher Error "Could not create Java Virtual Machine" (have 64 bit Java)
    Launcher Version:
    1.4.11
    Modpack:
    Any
    Modpack Version:
    N/A
    Log Link:

    Details of the issue:
    Java: 1.8.0_71(64 bit) (Installed in default location. No other Java installed)
    RAM: 8GB
    OS: Windows 7 Home Premium 64 bit (SP1)

    Getting an issue when trying to launch any modpack. Either the log 'freezes' and/or just crashes, showing two error messages;
    'Error: Could not create the Java Virtual Machine.'
    'Error: A fatal exception has occurred. Program will exit.'
    After pressing OK, the launcher comes back up.

    I have 64 bit java, all I have. Java 1.8.0_71. Here's the augments my friend gave me months ago when I was using the latest version of Java 7;
    -Xmx4G -Xms512M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSParallelRemarkEnabled -XX:[have to leave space here due to smilie]ParallelGCThreads=3 -XX:MaxGCPauseMillis=5 -XX:+UseAdaptiveGCBoundary -XX:-UseGCOverheadLimit -XX:+UseBiasedLocking -XX:SurvivorRatio=8 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=15 -Xnoclassgc -XX:UseSSE=3 -XX:+UseLargePages -XX:+UseFastAccessorMethods -XX:+UseStringCache -XX:+UseCompressedStrings -XX:+OptimizeStringConcat -XX:+AggressiveOpts -XX:+CMSPermGenSweepingEnabled -XX:+CMSClassUnloadingEnabled
    I haven't changed any of these. I just haven't played FTB in months, wanted to today and I get this error. I also tried to set up a new System Variable (named '_JAVA_OPTIONS' and the value being '-Xmx512M' (also tried changing it to '-Xmx4G', still not fixing the problem).

    Since I have already updated my 64 bit of Java, I didn't bother reinstalling (since I doubt it would help). I can run other Java-based games fine without issues, but this one is. Please assist.

    Also tried to update my GPU drivers. Didn't help. Same error. As for providing a log, I feel I don't really need to. The error doesn't show up anywhere there. All I saw was the augments that I specified up there before it crashes and that's it. If it did provide crash info, I would had definitely provided it.​
     
    Last edited: Jan 31, 2016
  2. AuricPolaris

    AuricPolaris Active Member

    Have you tried deleting and reinstalling the launcher? Or trying without the Java arguments?
     
  3. rinomasaya

    rinomasaya New Member

    Most of the time you can fix this problem by uninstalling the Java runtime and then reinstalling it all over again.

    To do this, go to the control panel and then Programs and Features. If you’re running Windows 8.1 Update 1, just right-click on the Start button and click on Programs and Features. Locate the Java runtime, uninstall it and reboot your PC.

    Next, download the latest Java Runtime from java.com, taking care to install the correct version for your PC. You will likely want the 32-bit version as the 64-bit option is specifically for 64-bit browsers. Most browsers are 32-bit on Windows, even on 64-bit editions of the OS.

    Sometimes this error can be caused by not having enough system memory allocated to the Java Virtual Machine – or not enough system memory full stop.

    You can also try increasing the amount of system memory allocated to the Java virtual machine by setting an environment variable.

    To do this, go back to the Control Panel and click on System, then Advanced system settings. Now click the Environment Variables button to bring up a list of all those currently set.
     
  4. grandrolf

    grandrolf Popular Member Trusted User

    Of all the things you've said here - the only usefull thing was the first line about reinstalling java, rest is kind of bad advice.

    If you got 64-bit OS then you should install 64-bit java - if you plan to use it with moded minecraft.

    Every setting that has to do with java and minecraft should be set on the launcher, avoid the control panel.

    @Benie76 - Update your launcher to the latest one https://www.feed-the-beast.com/ (red button = twitch/curse launcher - under the button is the FTB launcher marked as legacy)

    Update your java to the latest version (64-bit), remove the added java parameters and try again.

    If it still fails, try to do a repair (twitch/curse) or a force update (FTB launcher), instructions are found here:
    http://support.feed-the-beast.com/faq/

    If it still fails, please post full log - you'll find instructions for that on the FAQ page as well.
     
  5. joviermark

    joviermark New Member

    • Open the Control Panel
    • Go to System
    • Go to Advanced Systems Properties
    • Then Environment Variables
    • In System Variables, click Add
    • New Variable Name: _JAVA_OPTIONS
    • New Variable Value: -Xmx512M
    • Click OK
    That's it, your Java program should now be able to execute properly.
    For those interested, Java -Xmx/s is the configuration parameter that control the amount of memory Java uses.
    • Xmx sets the maximum heap memory size
    • Xms sets the minimum heap memory size
    More about...Java Virtual Machine

    Mark
     
  6. jikuja

    jikuja Launcher Dev Launcher Developer

    At least FTB launcher removes that environment variable. Twitch and Curse probably does the same. All three launchers have proper way to control memory allocation, please open the launcher ans see settings.

    +1 I'm curious to see your log.
     
  7. Jaari

    Jaari Active Member

    Please take a moment to check the date OP posted this, and imagine what your chances for that log are.
     
  8. jikuja

    jikuja Launcher Dev Launcher Developer

    Oh well. Maybe this should be just closed because of bad solutions
     
Thread Status:
Not open for further replies.

Share This Page