Open Huge CPU lag spikes

Discussion in 'FTB Beyond' started by JDLENL, Jul 11, 2017.

  1. JDLENL

    JDLENL Guest

    Summary of the problem Huge CPU lag spikes

    Pack Version 1.1.0

    What is the bug?
    :Footage of the bug happening in-game
    Basically, every few seconds while I'm doing something, my CPU will max out at 99% (the problem is caused by FTB; no other programs are spiking, and I have as little programs running as possible). It's making it incredibly frustrating. Read the video desc. for detailed information.

    Mod & Version FTB Beyond version 1.10 for Minecraft 1.10.2

    Link to log file http://paste.feed-the-beast.com/view/cd3655e9

    Is it repeatable? I'm not sure.

    Known Fix ¯\_(ツ)_/¯
    Nothing I've tried has worked. This has only been happening since yesterday, and restart of either FTB or my computer hasn't stopped it.
     
  2. Henry Link

    Henry Link Popular Member

    That looks to be java's garbage collector kicking in. Do some searches about changing the java command line parameters involving the garbage collector.
     
  3. JDLENL

    JDLENL Guest

    https://www.ibm.com/support/knowled....doc/diag/appendixes/cmdline/commands_gc.html
    A quick google search gave me this, but I don't know much about java. The only thing I know how to do is assign more or less RAM to Minecraft. What should I add to it? My current command-line arguments look like this:
    -Xmx5120m -Xms256m -XX: PermSize=256m -Dminecraft.applet.TargetDirectory="C:\Users\_name\Documents\Curse\Minecraft\Instances\FTB Beyond" -Dfml.ignorePatchDiscrepancies=true -Dfml.ignoreInvalidMinecraftCertificates=true -Duser.language=en -Duser.country=US
     
  4. JDLENL

    JDLENL Guest

    Never mind. I found the issue. Whenever I launch the Minecraft Launcher using Twitch, it resets my Java settings back to the default of 4GB. Since FTB Beyond can't even run on 4GB, it was causing massive lag spikes. I just have to set it to 5 or 6GB whenever I relaunch FTB Beyond.
     
  5. jikuja

    jikuja Launcher Dev Launcher Developer

    I wonder if Twitch app has any kind of seeting for RAM and maybe even instance specific settings.
     
  6. JDLENL

    JDLENL Guest

    Thank you for pointing that out! It's set to "System Settings" by default, which doesn't seem to mean anything other than "4GB." If you untick that, it lets you move a slider for the RAM...unfortunate that I can't set the number directly, though.
     
  7. Henry Link

    Henry Link Popular Member

    See I just set the system default setting up to about 5 GB. And that works for most packs.
     

Share This Page