Problem Horizons Daybreaker Server on Windows Server 2012

Discussion in 'Server Tech Support' started by Odys, Oct 18, 2015.

  1. Odys

    Odys Active Member

    Hey all,

    In short, here are the steps I have taken on my Windows Server 2012:
    1. Installed FTB Launcher
    2. From Launcher selected Horizons Daybreaker
    3. Clicked on Download Server
    4. Unzipped Server files from zip package "FTBHorizonsIIServer"
    5. In new folder I copied all files from zip over to include:
      1. Folders config, libraries, mods, scripts
      2. Files eula, FTBInstall.bat, FTBInstall.sh, FTBServer-1.7.10-1446.jar, ServerStart.bat, ServerStart.sh and version.json
    6. I double-clicked the ServerStart.bat and it ran very shortly and exited after I hit any key
    7. I then double-clicked the FTBInstall.bat after feeling that the ServerStart.bat did nothing and wondering if I even should have used serverstart.bat yet.
      1. FTBInstall.bat went even shorter running some stuff in a console window and closed
    8. So I finally tried the FTBServer jar file and it has not stopped running.
    9. Currently it is updating another line every ten mins or more and when I try to scroll in the window it is non-responsive.

    I am leaving for a bit and letting it run, hopefully it will work.

    But if any of you can point out any errors in my setup attempt I would greatly appreciate it!

    Remember, this is a Windows Server 2012. Thanks!
     
  2. jikuja

    jikuja Launcher Dev Launcher Developer

    There must be something really broken if ServerStart.bat and FTBInstall.bat prints nothing into command prompt...
     
  3. Baaleos

    Baaleos Active Member

    Open a cmd prompt and navigate to the install directory.
    Run the bat file from that command prompt.

    Now that you are running from an independent cmd prompt, it should stay open and allow you to see the output.
    It suggests to me that Java may not be installed properly or added to the java path variable.
     
  4. jikuja

    jikuja Launcher Dev Launcher Developer

    Should not be needed. There is extra "pause" at end of .bat to keep window open.
     
  5. Baaleos

    Baaleos Active Member

    In any case- if the batch file is running, but no output being fired - it sounds like Java might not be able to run the jar file.
    Make sure you have JRE or JDK 1.7+ or 1.8+ installed.

    Then point the systems java_path / java_home environment variable to the install directories of JRE/JDK
    If that does not work - modify the batch file directly and hardcode the java.exe or javaw.exe (think javaw.exe does the launcher?)
    Put the path to either of those in the batch file directly.
    Re-Run - do you get new output?
     
  6. Odys

    Odys Active Member

    I know this is coming way late, but I wanted to thank you guys for your help.

    Silly enough, the problem was just my reading comprehension. Yeah yeah, believe it or not, yet another issue that was just user error. Foolish user error.

    My problem was my handling in my steps above between step 5.2 and step 6. I wasn't reading the console well enough to see that it wanted me to go into the eula file and change from FALSE to TRUE. So when I finally FINALLY read that text on my 5th repeat of these steps to catch my errors, I went into the eula file and edited it to TRUE and everything worked as intended.

    shrug, my bad for sure, but couldn't it be programmed into the .bat to ask if you agree or not and then if you agree it changes the eula for you and moves along with the install? Too many times I kept hitting any key and closing that console window without reading what it said there enough to realize that I needed to go to the eula.

    But at any rate, it was my error and it is working now. (Minus a graphical glitch, it is working.)

    Thanks again and finally said!
     

Share This Page