1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Guide - How to run FTB via MultiMC(while launcher isn't working)

Discussion in '[Archived] Tech Support' started by Sephrik, Nov 14, 2012.

Thread Status:
Not open for further replies.
  1. Sephrik

    Sephrik New Member

    There isn't, currently, a way to obtain the FTB pack without using the links on the website, as far as I'm away. There may be other places to get it from dropbox links uploaded by other people around the forum, but the download links are the only official download links that I'm aware of, and those are the only links I support for originally obtaining FTB.

    I do apologize for not being able to provide those links, but unless I get permission, I'm not going to upload it to dropbox.
     
  2. QueWhat

    QueWhat New Member

    Sephrik, thanks for the walkthrough. I was itching to play FTB but since there are issues with the FTB launcher I decided to go ahead and use this option. Thanks again! +1 Like.

    EDIT: Added a link to this thread on my signature, since other folks might be itching to play FTB using this option as well. Hope it's ok :D
     
  3. Sephrik

    Sephrik New Member

    Yea that's alright. No worries on the walkthrough, it's pretty simple since the developer of MultiMC added the FTB launcher option. But hey, the more FTB people play, the better it'll be, so I'll help with whatever I can.
     
  4. ScruffyRules

    ScruffyRules New Member

    So what about Mac OS X 10.6 users that can't run MultiMC because i haven't upgraded to Mt Lion or Lion (Which costs money).
     
  5. Sephrik

    Sephrik New Member

    Not sure, don't have a mac, sorry =/
     
  6. monsted

    monsted New Member

    The upgrade costs about as much as minecraft. It's cheap enough that i feel comfortable just saying "go pay for it".

    The biggest problem facing developers of all kinds is that so many people are running ancient operating systems and browsers so nothing ever just works.
     
  7. ScruffyRules

    ScruffyRules New Member

    Here is AUD Lion Read the Reviews they are all complaining about how unstable and its low performance it is. so with my already SLOW as Macbook mid 2010 and minecraft barely runs with a good FPS so yeah, I might(very low) buy it. i also have another computer that has 512mb RAM. HOW IS THIS OS "ancient"?
     
  8. stargater93

    stargater93 New Member

    I almost interpreted that wrongly; and now I can't even explain how considering how stupid it sounds. That being said, considering that Snow Leopard was released 2 months AFTER Windows 7, to call Mac OS X 10.6 ancient, is to call Windows 7 MYTH. Something tells me that the 'PC' world hasn't switched over to Windows 8 overnight, so everything is still being developed for Windows 7 - an arguably ancient OS according to this discussion.


    Back to the topic of the thread, I've had some mod list mismatches with the FTB server package ever since an update back around 2012-11-19. As a result, I restored my server to the version I got back on 2012-11-10 or whatever and have been avoiding the "Do you want to update this modpack" notification like the plague.

    I used MultiMC for a week or two before the FTB launcher and really enjoyed how it worked; aside from getting a Segmentation fault when I quit a Minecraft instance. I might have to switch back to using that - and getting everyone else on my server using it as well - since the FTB modpack updates don't seem to be reliable yet. I've had to turn some people away from using my server due to them not being able to get the proper version; and what has basically become a 2 player server is hardly the most interesting thing in the world.
     
  9. ScruffyRules

    ScruffyRules New Member

    Thanks for the feed back mate.
     
  10. SilvasRuin

    SilvasRuin New Member

    So the FTB launcher doesn't seem to like me adjusting the RAM allocation and hangs up whenever I don't use the default setting, so I tried this. No matter what I do with the RAM settings, even leaving them alone, I get an automatic close (before it even opens even) and this as my last few error lines:

    2012-11-26 17:45:28 [INFO] [ForgeModLoader] Forge Mod Loader has successfully loaded 37 mods
    2012-11-26 17:45:28 [FINER] [ForgeModLoader] Registered texture override 0 (0) on TextureCreosoteOilFX (0)
    2012-11-26 17:45:28 [FINER] [ForgeModLoader] Registered texture override 16 (16) on TextureSteamFX (0)
    2012-11-26 17:45:28 [FINER] [ForgeModLoader] Registered texture override 20 (20) on TextureComputerFX (32)
    2012-11-26 17:45:28 [FINER] [ForgeModLoader] Registered texture override 25 (25) on TextureComputerFX (33)
    2012-11-26 17:45:28 [FINER] [ForgeModLoader] Registered texture override 5 (5) on TextureAnimation (69)
    2012-11-26 17:46:26 [INFO] [STDERR] Someone is closing me!

    I'm assuming the relevant line is the last one. It is frustratingly vague, however, and I can't imagine what is doing it. Any help?

    I take that back. Sorry for wasting your time. I did manage to get it to work again by figuring out what the default RAM was and setting it back to that. So... I guess my computer just doesn't have enough RAM? I'm guessing I should probably blame Windows for eating it all... And to think this was at one point all the RAM anyone needed.
     
  11. Sephrik

    Sephrik New Member

    Not really sure, about the ram problems. This thread is mainly for MultiMC, rather than other tech support. The tech support forum, and new website is a great resource if you need help though.
     
    ScruffyRules likes this.
  12. sethward314

    sethward314 New Member

    i got this crash when i tried to play can you help?

    ------------- MultiMC Crash Report -------------
    Information:
    Date: 01-05-2013 15:59:06
    Operating System: Windows XP (build 2600, Service Pack 3)
    MultiMC Version: 4.3.0 jenkins-MultiMC4Windows-68
    Minecraft Version: Unknown

    ------------------ Mod Lists -------------------
    Jar Mods:
    liteloader_1.4.6.zip
    Version:
    Filename: liteloader_1.4.6.zip

    MinecraftForge.zip
    Version: 6.5.0.489
    Filename: MinecraftForge.zip


    ModLoader Mods:
    [1.4.6]PetroGen-1.1.zip
    Version:
    Filename: [1.4.6]PetroGen-1.1.zip

    [1.4.6]ReiMinimap_v3.2_06.zip
    Version:
    Filename: [1.4.6]ReiMinimap_v3.2_06.zip

    mod_AdvancedSolarPanels_3_3_2.zip
    Version: 3.3.2
    Filename: mod_AdvancedSolarPanels_3_3_2.zip

    buildcraft-A-3.3.0.jar
    Version:
    Filename: buildcraft-A-3.3.0.jar

    ChickenChunks 1.2.1.1.jar
    Version:
    Filename: ChickenChunks 1.2.1.1.jar

    ComputerCraft1.481.zip
    Version: 1.481
    Filename: ComputerCraft1.481.zip

    EnderStorage 1.3.1.1.jar
    Version:
    Filename: EnderStorage 1.3.1.1.jar

    extrabees-1.4.9.6-prerelease.zip
    Version:
    Filename: extrabees-1.4.9.6-prerelease.zip

    ExtrabiomesXL-universal-1.4.6-3.7.0.jar
    Version: 3.7.0
    Filename: ExtrabiomesXL-universal-1.4.6-3.7.0.jar

    Factorization-0.7.10.jar
    Version: 0.7.10
    Filename: Factorization-0.7.10.jar

    forestry-A-1.6.4.1.jar
    Version:
    Filename: forestry-A-1.6.4.1.jar

    mod_zGraviSuite_1_6.zip
    Version: 1.6
    Filename: mod_zGraviSuite_1_6.zip

    GregTechMod_2.73c.zip
    Version: 2.73c
    Filename: GregTechMod_2.73c.zip

    AdvancedMachines_4.7a.zip
    Version: 4.7a
    Filename: AdvancedMachines_4.7a.zip

    industrialcraft-2_1.112.170-lf.jar
    Version: 1.112.170-lf
    Filename: industrialcraft-2_1.112.170-lf.jar

    InventoryTweaks_1.46.zip
    Version:
    Filename: InventoryTweaks_1.46.zip

    ironchest-universal-1.4.6-4.5.1.203.zip
    Version: 4.5.1.203
    Filename: ironchest-universal-1.4.6-4.5.1.203.zip

    miscperipherals-2.3.zip
    Version:
    Filename: miscperipherals-2.3.zip

    ModularForceFieldSystemV2.2.8.2.14.zip
    Version: 2.2.8.2.14
    Filename: ModularForceFieldSystemV2.2.8.2.14.zip

    ThermalExpansion-NEI-2.1.6.zip
    Version: 2.1.6
    Filename: ThermalExpansion-NEI-2.1.6.zip

    NEI_RedPowerPlugin 1.4.3.jar
    Version:
    Filename: NEI_RedPowerPlugin 1.4.3.jar

    NEIPlugins-1.0.4.1.jar
    Version:
    Filename: NEIPlugins-1.0.4.1.jar

    IC2NuclearControl-1.4.5.zip
    Version: 1.4.5
    Filename: IC2NuclearControl-1.4.5.zip

    obsidiplates-universal-1.2.0.3.zip
    Version: 1.2.0.3
    Filename: obsidiplates-universal-1.2.0.3.zip

    OmniTools-2.2.5.zip
    Version: 2.2.5
    Filename: OmniTools-2.2.5.zip

    portalgun1.4.6v2.zip
    Version: 1.4.6v2
    Filename: portalgun1.4.6v2.zip

    Railcraft_1.4.6-6.12.2.0.zip
    Version: 6.12.2.0
    Filename: Railcraft_1.4.6-6.12.2.0.zip

    RedPowerMechanical-2.0pr6.zip
    Version: 2.0 Prerelease 6
    Filename: RedPowerMechanical-2.0pr6.zip

    RedPowerDigital-2.0pr6.zip
    Version: 2.0 Prerelease 6
    Filename: RedPowerDigital-2.0pr6.zip

    RedPowerCompat-2.0pr6.zip
    Version: 2.0 Prerelease 6
    Filename: RedPowerCompat-2.0pr6.zip

    RedPowerCore-2.0pr6.zip
    Version: 2.0 Prerelease 6
    Filename: RedPowerCore-2.0pr6.zip

    SoulShards-v1.21-universal.zip
    Version: 1.21
    Filename: SoulShards-v1.21-universal.zip

    StevesCarts2.0.0.a41.zip
    Version:
    Filename: StevesCarts2.0.0.a41.zip

    Thaumcraft3.0.1c.zip
    Version: 3.0.1c
    Filename: Thaumcraft3.0.1c.zip

    twilightforest-1.14.0.zip
    Version: 1.14.0
    Filename: twilightforest-1.14.0.zip

    ThermalExpansion-2.1.6.zip
    Version: 2.1.6
    Filename: ThermalExpansion-2.1.6.zip

    Traincraft-3.1.13_010.jar
    Version:
    Filename: Traincraft-3.1.13_010.jar

    WR-CBE Addons 1.3.2.4.jar
    Version:
    Filename: WR-CBE Addons 1.3.2.4.jar

    WR-CBE Core 1.3.2.4.jar
    Version:
    Filename: WR-CBE Core 1.3.2.4.jar

    WR-CBE RedPower 1.3.2.4.jar
    Version:
    Filename: WR-CBE RedPower 1.3.2.4.jar

    xycraft-universal-1.4.6-0.9.44.zip
    Version: 0.9
    Filename: xycraft-universal-1.4.6-0.9.44.zip

    lib_voxelcommon_1.4.6.litemod
    Version: File
    Filename: lib_voxelcommon_1.4.6.litemod

    lib_voxelpacket_2.0.1_mc1.4.6.litemod
    Version: File
    Filename: lib_voxelpacket_2.0.1_mc1.4.6.litemod

    mod_voxelmenu_1.4.6_03.litemod
    Version: File
    Filename: mod_voxelmenu_1.4.6_03.litemod

    mod_voxelplayer_0.9.4_mc1.4.6.litemod
    Version: File
    Filename: mod_voxelplayer_0.9.4_mc1.4.6.litemod

    rei_minimap
    Version: Folder
    Filename: rei_minimap

    VoxelModPack
    Version: Folder
    Filename: VoxelModPack

    VoxelMods
    Version: Folder
    Filename: VoxelMods


    Core Mods:
    CodeChickenCore 0.7.0.2.jar
    Version:
    Filename: CodeChickenCore 0.7.0.2.jar

    NotEnoughItems 1.4.5.0.jar
    Version:
    Filename: NotEnoughItems 1.4.5.0.jar



    ----------------- Console Log ------------------
    Instance folder is:
    C:\Documents and Settings\Seth and Sydney\My Documents\Downloads\instances\mindcrack\minecraft\

    Instance started with command:
    "C:\Program Files\Java\jre6\bin\java.exe" -Xms512m -Xmx1024m -jar MultiMCLauncher.jar "<username>" "Offline" "MultiMC: mindcrack" "854x480" "Mojang"

    Loading jars...
    Loading URL: file:/C:/Documents%20and%20Settings/Seth%20and%20Sydney/My%20Documents/Downloads/instances/mindcrack/minecraft/bin/minecraft.jar
    Loading URL: file:/C:/Documents%20and%20Settings/Seth%20and%20Sydney/My%20Documents/Downloads/instances/mindcrack/minecraft/bin/lwjgl.jar
    Loading URL: file:/C:/Documents%20and%20Settings/Seth%20and%20Sydney/My%20Documents/Downloads/instances/mindcrack/minecraft/bin/lwjgl_util.jar
    Loading URL: file:/C:/Documents%20and%20Settings/Seth%20and%20Sydney/My%20Documents/Downloads/instances/mindcrack/minecraft/bin/jinput.jar
    Loading natives...
    Exception in thread "main" java.lang.NoClassDefFoundError: lg
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$000(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at MultiMCLauncher.main(MultiMCLauncher.java:157)
    Caused by: java.lang.ClassNotFoundException: lg
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 12 more
    Minecraft exited with code 1.
    Minecraft has crashed!
     
  13. Gunner Smith

    Gunner Smith New Member

    i have a problem, when i select the folder to choose my mod pack of FTB, nothing shows up. How do i fix this?
     
  14. Ashzification

    Ashzification New Member

    Are you using MultiMC?
     
  15. Lawbroken

    Lawbroken New Member

    While importing FTB to MultiMC you need to select the folder that all modpacks are located.

    So if have a folder called FTB and in that folder i have the launcher/modpacks i will have to select FTB not the modpack you want. It will ask you which one after you select the folder.

    (Yes i know i suck at explaining things)
     
  16. DylanP

    DylanP New Member

    when I pick the dw20 modpack folder in the ftb_launcher/modpacks folder I get a blank folder, from the import from ftb launcher menu item in multimc. There is no selection to make and if we use the dw20 folder nothing happens.

    Same as Gunner Smith, but I see his question wasn't understood.
     
  17. ashouri

    ashouri New Member

    so i have to select the folder that have the ftb launcher.exe or the folder that it runs on
     
Thread Status:
Not open for further replies.

Share This Page