Problem Guide API Doesn't Load - Impossible to Play

Discussion in 'FTB Pyramid Reborn' started by Lyric Rhapsody, Apr 8, 2018.

  1. I've tried reloading the game multiple times, recreating the worlds, and playing with and without resource packs, but the Guidebook just doesn't work whatsoever. The timer will start but nothing comes up and without that the modpack is just unplayable.
     
    AENOH, HachiroMC and genthug like this.
  2. Same issue. I even tried loading a previous version of the pack. No dice.
     
  3. VikeStep

    VikeStep New Member

  4. Lavasyris

    Lavasyris Guest

    Same issue here as well.
     
  5. HachiroMC

    HachiroMC Guest

    I have the same problem too.
     
  6. dm8mydog

    dm8mydog Guest

    the game guide used to work for me in the first few days, now I get:
    [15:27:42] [ReloadGuides/ERROR] [FTB Guides]: Failed to load the API!​
     
  7. AENOH

    AENOH Guest

    This is a problem for me as well. It’s a shame since I just bought a creeperhost server for me and my little sister to play this pack on and it’s pretty much unplayable.
     
  8. dm8mydog

    dm8mydog Guest

    hmm it's not game-breaking - atleast not if you've read through it once...
    if the game guide exists online somewhere can we have a link for it plz?
     
  9. choekstr

    choekstr Guest

    Same issue here for 2 of us. Fresh download of the 2.1.1-1 version (new profile), changed gui scale to normal is all, and spawn in and it doesn't work.
     
  10. SolManX

    SolManX New Member

    The config folder (ftb_guides) has all the text in json format. Not perfect but good enough until a solution comes.
     
  11. SolManX

    SolManX New Member

  12. Lunathealicorn

    Lunathealicorn New Member

    how do you have it load from the ftb_guides folder then?
     
  13. SolManX

    SolManX New Member

  14. choekstr

    choekstr Guest

    The issue was http vs https in the ftbguides code as the website changed. It was fixed in github 2 days ago and a new version pushed 1 day ago of ftbguides however just updating to the new version of ftbguides doesn't fix the issue. We'll probably have to wait for a pack version to update. I am sure @slowpoke is all over this and we can expect a working version shortly...
     
  15. Lunathealicorn

    Lunathealicorn New Member

  16. SolManX

    SolManX New Member

    Oh okay - I didn't get it to load - I just parsed the JSON files in the config/ftb_guides folder into BB code and pasted onto the forum while we wait for a proper fix.
     
  17. usafphoenix

    usafphoenix New Member

    confirmed, guides GUI doesn't open in single player (don't have friends so that's all i can play lol).
     

Share This Page