1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Gregtech 5 (Infitech 2) Titanium - how?

Discussion in 'General FTB chat' started by headsh0t_harry, Feb 27, 2019.

  1. Hi all, would someone mind explaining Titanium within Gregtech (Infitech 2 modpack) please.

    I've got the Titaniumtetrachloride fluid, I've got some magnesium dust, I've also got an Electric Blast Furnace, but hoping I'm having a senior noob moment - I can't seem to get the Hot Titanium Ingot to cook.

    I've tried inputting fluid into the EBF, I've also used Cells containing 1000 fluid (NEI recipe suggests 2 magnesium dust and 1000 Titaniumtetrachloride) - although it does only reference "Blast Furnace", not "Electric Blast Furnace" - and the "Blast Furnace" in Infitech 2 is a disabled item.

    Just after a bit of a kick in the right direction please.

    Thanks
     
    Last edited: Feb 28, 2019
    wertley.wa likes this.
  2. SolManX

    SolManX New Member

    You've must've already used the EBF successfully for cooking other stuff (eg aluminium) so can't be that the EBF isn't set up properly, although it's worth double-checking to see if any maintenance is needed.

    Is the fluid actually showing in the inventory of the input hatch, or is it staying in the cell? I remember had various little niggles with the the two different types of cells (empty cells and universal cells). If it isn't you might have to pump the fluid in somehow (a gregtech pump is able to pull in from an adjacent tank)

    Are you giving it enough power - 480EU/t, requiring a high voltage energy hatch (actually two medium voltage hatches might do it because they can carry 2 Amps of 128 EU/t each)?

    Have you turned it off with the soft hammer and forgot to re-hit it?
     
    wertley.wa likes this.
  3. Absolutely :) yes, been cooking Aluminium successfully - so no issue with the EBF that I can see yet (also ran a test cook with some more Aluminium and that worked fine again)

    I can't get the fluid to flow from say a Drum or Fluid Tank, but I did place a Cell containing 1000 units of the Titaniumtetrachloride (which is enough for 1 run of the recipe) into the input bus. That didn't work though...


    This I have just checked - and we do only currently have x1 MV Energy Hatch working with the EBF. Might be the issue?

    Yes, did this, and also chucked in a run of Aluminium to validate.

    Thanks for your help with this - really appreciated.
     
    wertley.wa likes this.
  4. SolManX

    SolManX New Member

    Just to be sure, you need an input hatch, not a bus, to input fluids. You should be able to place a cell into that, but as I said, I remember having issues with that. There are two cells to try - 'empty' and 'universal'.

    The way I got it working was to place an lv pump (the component version) as a cover onto the hatch, configure it to pull from adjacent inventories and place an enderio tank next to it - any fluid container should work though.


    This is crucial. Replace it with an HV version or add a second MV. Two MV's should be enough since, as I said, each MV can handle 2 amps of MV power, so you'll get 2 x 2 x 128 EU/t = 512 EU/t, which is enough. I don't remember trying this so I'd do a backup before testing this, just in case :)

    One thing you have to be aware of is that there is always some energy loss from cables, battery buffers and, I think, transformers. I used to try and counter this as much as possible by placing battery buffers pointing directly into the energy hatches, with enough batteries to maximise the power going in.

    I had a 4-slot MV battery buffer, with 4 medium lithium batteries, pointing directly at an HV energy hatch.

    EDIT: Needed to be clear I used an MV battery buffer :)
     
    Last edited: Feb 28, 2019
    wertley.wa likes this.
  5. Thank you - yes - I've got both the hatch and the bus installed now.

    Awesome - I actually already had a battery buffer with x4 medium lithium batteries installed - so hoping that should do that trick.

    With your help, I think the issue is indeed power, but also that I need to upgrade the coil blocks (probably to Kanthal?) - as the heating capacity required for Titanium is more than the 1800 Kelvin the Cupronickel support (Hot Titanium Ingot's require 2140 K).... so there may also be the issue?

    So in short - give it more juice, probably go with x1 HV Energy Hatch (I did put x2 MV ones in, but when testing on Aluminium the EBF sucked the Aluminium dust in, but shut off immediately and never produced an ingot - remove the second MV Energy Hatch and it produced Aluminium ingots perfectly... odd?) and upgrade Cupronickel Coil Blocks to Kanthal - see where that leaves me :)

    Just to say thanks for the help - still finding my way around with this.
     
    wertley.wa likes this.
  6. SolManX

    SolManX New Member

    Re heating capacity - I thought the cupronickel coils would be enough, but haven't played for a while and maybe it's been updated since then. Whatever, it'll tell you on the NEI panel.

    In fact, in the version I played on I think The EBF cooked titanium ingots directly as opposed to hot ones. So probably the heat capacity's changed as well.

    Let us know how you get on.

    PS Not sure why the 2xMV energy hatches didn't work, but if you're going HV, save that problem for another day :)
     
    headsh0t_harry and wertley.wa like this.
  7. asb3pe

    asb3pe New Member

    Infitech 2 modpack is using what's known as "GT5u" which stands for "GregTech mod, version 5, unofficial". Altho you might think "unofficial" is sorta like a pirated version, that's absolutely not the case - the developer of the GregTech mod (ironically, his name being "Greg" haha) gave people such as BloodAsp and Jason McRay and others the full authorization to modify the GT v5 mod and add on to it... the reason being, Greg had already dropped GT5 and moved on to a new version 6 of GregTech. Basically, GT5 was never fully finished, even tho it is in a fully playable state - there was no stuff in the mod geared for "end-game" play. What BloodAsp did was add many more multiblock structures, the major one being the Fusion Reactor, which gave GT5 the end-game items it didn't have, and thus GT5u was borne... then Jason McRay created the Infitech 2 modpack with full recipe modifications, and we ended up with (in my opinion) the perfect GregTech modpack for minecraft... and since I'm familiar with it, I would also suggest you also try out the modpack called "Inftech 2 Fear The Night" which is basically a fork of the Infitech 2 modpack, adding even MORE stuff to end-game. At some point, Jason McRay moved on from Infitech 2, and it has kept an older version of GT5u in the modpack. What "Fear The Night" did is to keep installing the later versions of GT5u, as well as adding other mods to the modpack (such as Lycanites Mobs, making it a somewhat unique play-thru with a whole lot more mobs), making the nether especially difficult to deal with (in early game at least)... and also, the mobs which spawn in darkness... :)

    Anyhow it sounds like SolManX has solved your titanium issue, I agree it sounds like it was a power supply problem coupled with the heating coil issue as well... for me, I always went to HV feed for my EBF and all the multiblocks, but that's because once you get to the Large Diesel Engine multiblock in the Fear The Night modpack version of GT5u, those put out EV-tier power supply, so it's nice and easy to step the EV down to HV for running all the large multiblocks. Good luck with it, I consider Infitech 2 to be the absolute peak of minecrafting, it won't ever get any better than those modpacks, they are the absolute best!!
     
  8. Thanks both - yes, we are moving from MV to HV currently - and also yes, thoroughly enjoy the game. I'll add though, I was introduced to Minecraft via a friend who had already played quite a bit of the modded stuff. I've never actually played anything close to vanilla, in fact Infitech 2 is the only flavour I've really spent a serious amount of time with. I still get confused with the recipes sometimes, or more importantly, finding the correct recipe for that one item I can't seem to make - but that's all part of the long play fun right?

    I'm sure I'll be back in no time with more questions - but for now, thank you again for your support in navigating my latest roadblock :)
     
    GamerwithnoGame likes this.

Share This Page