Problem ftbu config is resetting itself after restart.

Discussion in 'Server Tech Support' started by tiwaz1994, Sep 8, 2016.

  1. tiwaz1994

    tiwaz1994 Guest

    Hey,
    i am very new to modded minecraft and startet hosting a server for me and my friends.
    I want to enable the ftbu chunkloading in the ftbu config file (/local/ftbu/config.json), but its always resetting after restart. I tried changing it manually, while the minecraft server was offline, but after a restart it changed. I also tried changing it ingame with the command (i don´t remember the command i used, ill edit it in if i figure it out again), but the config changed again after restart. I did other changes (disabling a few commands) in the config and it DID NOT reset those.

    Something wrong with my config? What else can i try?

    All i try to edit is the chunkloading enabled to "true".

    My config:
    Code:
    {
      "backups": {
        "backup_timer": 5.0,
        "backups_to_keep": 5,
        "compression_level": 1,
        "display_file_size": true,
        "enabled": false,
        "folder": "./backups/",
        "need_online_players": true,
        "use_separate_thread": true
      },
      "chunkloading": {
        "enabled": false,
        "max_player_offline_hours": -1.0
      },
      "commands": {
        "back": false,
        "home": false,
        "name_admin": "theTiwaz",
        "spawn": false,
        "tplast": false,
        "warp": false
      },
      "general": {
        "blocked_entities": [],
        "restart_timer": 0.0,
        "safe_spawn": false,
        "server_info_difficulty": true,
        "server_info_mode": true,
        "spawn_area_in_sp": false,
        "spawn_pvp": true
      },
      "login": {
        "motd": [
          "Welcome to the server!"
        ],
        "starting_items": [
          "minecraft:apple 16 0"
        ]
      },
      "permissions_admin": {
        "allow_creative_interact_secure": true,
        "badge": "",
        "break_whitelist": [
          "OpenBlocks:grave"
        ],
        "cross_dim_homes": true,
        "custom_config": {},
        "dimension_blacklist": [],
        "forced_chunk_security": "-",
        "forced_explosions": "-",
        "max_claims": 1000,
        "max_homes": 100,
        "max_loaded_chunks": 50,
        "show_rank": true
      },
      "permissions_player": {
        "allow_creative_interact_secure": false,
        "badge": "",
        "break_whitelist": [
          "OpenBlocks:grave"
        ],
        "cross_dim_homes": true,
        "custom_config": {},
        "dimension_blacklist": [
          1
        ],
        "forced_chunk_security": "-",
        "forced_explosions": "-",
        "max_claims": 100,
        "max_homes": 1,
        "max_loaded_chunks": 6,
        "show_rank": true
      },
      "tops": {
        "deaths": true,
        "deaths_ph": true,
        "first_joined": true,
        "last_seen": true,
        "time_played": true
      }
    }
    http://pastebin.com/Xg7WJARS

    I really want this to work, because chunk loading is something very important for us. I know that there are other ways to chunk load, but doing it with that ftbu map click thing is just so simple for everyone.

    So... what else should i try? Is there something wrong with my config file?
     
  2. Bennyboy1695

    Bennyboy1695 New Member

    Can you post a copy of your config once you've edited it too, as configs usually only reset if the format gets broken
     
  3. tiwaz1994

    tiwaz1994 Guest

    Sure, here is the edited version:
    Code:
    {
      "backups": {
        "backup_timer": 5.0,
        "backups_to_keep": 5,
        "compression_level": 1,
        "display_file_size": true,
        "enabled": false,
        "folder": "./backups/",
        "need_online_players": true,
        "use_separate_thread": true
      },
      "chunkloading": {
        "enabled": true,
        "max_player_offline_hours": -1.0
      },
      "commands": {
        "back": false,
        "home": false,
        "name_admin": "theTiwaz",
        "spawn": false,
        "tplast": false,
        "warp": false
      },
      "general": {
        "blocked_entities": [],
        "restart_timer": 0.0,
        "safe_spawn": false,
        "server_info_difficulty": true,
        "server_info_mode": true,
        "spawn_area_in_sp": false,
        "spawn_pvp": true
      },
      "login": {
        "motd": [
          "Welcome to the server!"
        ],
        "starting_items": [
          "minecraft:apple 16 0"
        ]
      },
      "permissions_admin": {
        "allow_creative_interact_secure": true,
        "badge": "",
        "break_whitelist": [
          "OpenBlocks:grave"
        ],
        "cross_dim_homes": true,
        "custom_config": {},
        "dimension_blacklist": [],
        "forced_chunk_security": "-",
        "forced_explosions": "-",
        "max_claims": 1000,
        "max_homes": 100,
        "max_loaded_chunks": 50,
        "show_rank": true
      },
      "permissions_player": {
        "allow_creative_interact_secure": false,
        "badge": "",
        "break_whitelist": [
          "OpenBlocks:grave"
        ],
        "cross_dim_homes": true,
        "custom_config": {},
        "dimension_blacklist": [
          1
        ],
        "forced_chunk_security": "-",
        "forced_explosions": "-",
        "max_claims": 100,
        "max_homes": 1,
        "max_loaded_chunks": 6,
        "show_rank": true
      },
      "tops": {
        "deaths": true,
        "deaths_ph": true,
        "first_joined": true,
        "last_seen": true,
        "time_played": true
      }
    }
     
  4. Ommina

    Ommina Well-Known Member

    A week after the fact, but it may be worth noting that there is an open config-resetting issue for FTBLib. Presumably it is this that is affecting you.

    Have you had any success in determining when the reset takes place? That is, if you make a change, does it work once, then revert to default on exit? Or does it not even take effect once?
     
  5. Robijnvogel

    Robijnvogel Well-Known Member

    @Ommina, it may be worthwhile to reference this thread on that Github issue. :)
     
  6. tiwaz1994

    tiwaz1994 Guest

    Sorry for the late answer, i was really annoyed with this and kind of gave up. If i edit the config with the command ingame (/edit_config ftbu chunkloading enabled true) it changes it, reloads the config and the chunkloading actually works. Until i restart the server and it is all changed to false again. I tried changing different things in the config, to see what else it wants to reset. It looks to me like only 2 things are affected.

    The: "enabled" true, part from chunkloading AND the "enabled" true, part from backups (which i don´t need anyway)

    I hope this gives some info on what could be wrong, i have no idea honestly :D
    I will look a bit more into this thread now, sorry was really not thinking people would answer anymore.

    Edit: I also came across the issue listed on github, i hope this means i am not the only one affected :D
     
    Last edited: Sep 23, 2016
  7. Aetherpirate

    Aetherpirate New Member

    I marked the file as read-only after I saved my changes.
     
    Ommina likes this.
  8. EODCrafter

    EODCrafter Guest

    Necro Post....I just checked mine and it retains it's settings after restart so this issue is not present on my server. What other changes did you say you made? Also, what editor are you using? Some editors make hidden tab entries, ect that would cause the .json to be Invalid Format.

    Code:
    {
      "backups": {
        "backup_timer": 6.0,
        "backups_to_keep": 7,
        "compression_level": 1,
        "display_file_size": true,
        "enabled": true,
        "folder": "./backups/",
        "need_online_players": true,
        "use_separate_thread": true
      },
      "chunkloading": {
        "enabled": true,
        "max_player_offline_hours": -1.0
      },
     
  9. tiwaz1994

    tiwaz1994 Guest

    Tried it earlier (sorry for not mentioning) did not work, it still changes it. I will try again though, in case i missed something.
    I didn´t change much, just added my minecraft name as admin and disabled a few commands. I even deleted the config to let it make a new one with default settings. That didn´t change anything though.

    As editor i use notepad++ and the normal windows texteditor (tried it with both).
    And i also tried editing the config ingame with the commands, which works until i restart the server and it changes again.
     
  10. EODCrafter

    EODCrafter Guest

    Might be a little late, but the command for editing in game is
    Code:
    /edit_config ftbu
    That will make all the settings click-able and should edit just fine. This command is not easy to find.
     
  11. tiwaz1994

    tiwaz1994 Guest

    Yeah, that is what i used
    Code:
    /edit_config ftbu chunkloading enabled true
    But again, after restart it changes back.
     
  12. Ommina

    Ommina Well-Known Member

    For those not following the issue tracker, this issue has been closed, and there has been a pair of beta 1.10.2 specific releases.

    That said, chunkloading on the new releases seems a bit buggy. Or, alternately, I'm wholly failing to understand the various config files. (One of which appears to be a .txt file in a custom format.) If I successfully figure out if the problem is with me or FTBU, I'll post a new issue. In the meantime, should somebody else start using the newest version, I'd sure appreciate any insights gained.
     
  13. EODCrafter

    EODCrafter Guest

    I just checked my Version that I have had no issues with...1.7.10.1.0.18.3. The version you have listed is for MineCraft 1.10. Maybe that is the issue.
     
  14. tiwaz1994

    tiwaz1994 Guest

    I am not sure what that means for me. I just noticed though that i never mentioned which modpack i am using. Its the infinity evolved one (mc 1.7.1).
     

Share This Page