FTBA for Linux is broken

Status
Not open for further replies.

druuhl

New Member
Jul 31, 2020
10
0
2
After an update today, i am unable to start any modpack (Direwolf/omnia). i got this error on my normal instance and when i install the direwolf instance newly.
- System Linux
- /usr/lib/jvm/adoptopenjdk-11-hotspot-amd64/bin/java -classpath /home/druuhl/tools/FTBA/.install4j/i4jruntime.jar:/home/druuhl/tools/FTBA/.install4j/launcher9a2f5e52.jar:/home/druuhl/tools/FTBA/launche
r-202104081147-534c2a1ea3-release-all.jar install4j.net.creeperhost.creeperlauncher.CreeperLauncher

[email protected]:~$ FTBApp
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Reloading instances..
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Skipping Cloud instance reload.
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Loaded 2 out of 2 instances in 90ms(90088430ns).
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Finished instance reload in 97ms(97995818ns)
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.CreeperLauncher]: No PID args
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.CreeperLauncher]: Starting Electron: /home/druuhl/tools/FTBA/bin/ftb-app --no-sandbox --ws 10978:edf24f6b-068e-44d6-bcc4-6e375e0eaa65 --pid 6324
[19:14:39] [WebSocketSelector-39/INFO] [net.creeperhost.creeperlauncher.api.WebSocketAPI]: Server started successfully - 202104081147-534c2a1ea3-release
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Reloading instances..
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Skipping Cloud instance reload.
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Loaded 2 out of 2 instances in 5ms(5618788ns).
[19:14:39] [main/INFO] [net.creeperhost.creeperlauncher.Instances]: Finished instance reload in 6ms(6627915ns)
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: xdg-mime: application argument missing
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: Try 'xdg-mime --help' for more information.
[19:14:39] [ForkJoinPool.commonPool-worker-23/INFO] [net.creeperhost.creeperlauncher.CreeperLauncher]: 19:14:39.594 › We have a --ws
[19:14:39] [ForkJoinPool.commonPool-worker-23/INFO] [net.creeperhost.creeperlauncher.CreeperLauncher]: 19:14:39.597 › Got the lock
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]:
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: (ftb-app:6396): Gtk-WARNING **: 19:14:39.606: Theme parsing error: gtk.css:127:35: The style property GtkButton:child-displacement-x is
deprecated and shouldn't be used anymore. It will be removed in a future version
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]:
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: (ftb-app:6396): Gtk-WARNING **: 19:14:39.607: Theme parsing error: gtk.css:128:35: The style property GtkButton:child-displacement-y is
deprecated and shouldn't be used anymore. It will be removed in a future version
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]:
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: (ftb-app:6396): Gtk-WARNING **: 19:14:39.607: Theme parsing error: gtk.css:132:46: The style property GtkScrolledWindow:scrollbars-withi
n-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: 19:14:39.689 › (electron) The default value of app.allowRendererProcessReuse is deprecated, it is currently "false". It will change to
be "true" in Electron 9. For more information please check https://github.com/electron/electron/issues/18397
[19:14:39] [ForkJoinPool.commonPool-worker-5/ERROR] [net.creeperhost.creeperlauncher.CreeperLauncher]: 19:14:39.717 › (node:6396) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
[19:14:40] [WebSocketWorker-27/INFO] [net.creeperhost.creeperlauncher.api.WebSocketAPI]: Front end connected: /127.0.0.1:38470

-- Start Mod here
[19:14:46] [ForkJoinPool-1-worker-19/INFO] [net.creeperhost.creeperlauncher.pack.LocalInstance]: Checking for Launch Mod for instance 247d08d7-0c0a-4b55-af0b-a3dd54b58d84}(FTB Presents Direwolf20 1.16)..
[19:14:46] [ForkJoinPool-1-worker-19/INFO] [net.creeperhost.creeperlauncher.pack.LocalInstance]: Didn't find Launch Mod for instance 247d08d7-0c0a-4b55-af0b-a3dd54b58d84(FTB Presents Direwolf20 1.16) in 590ms(590267841ns).
[19:14:47] [ForkJoinPool-1-worker-19/INFO] [net.creeperhost.creeperlauncher.pack.LocalInstance]: Starting launcher at /home/druuhl/.ftba/bin
[19:14:47] [ForkJoinPool-1-worker-19/ERROR] [net.creeperhost.creeperlauncher.pack.LocalInstance]: Unable to initialize MineTogether Connect!
[19:14:47] [ForkJoinPool.commonPool-worker-27/ERROR] [Minecraft Launcher 0]: terminate called after throwing an instance of 'std::logic_error'
[19:14:47] [ForkJoinPool.commonPool-worker-27/ERROR] [Minecraft Launcher 0]: what(): basic_string::_M_construct null not valid
 

druuhl

New Member
Jul 31, 2020
10
0
2
I tried it on a seconds machine with debian buster, same problem, works with windows
 

druuhl

New Member
Jul 31, 2020
10
0
2
Here the debug.log what is the same content as the lastest.log. It happens on omnia and direwolf on Debian GNU Linux Buster on java 8, 11, 15. This log is with java 8.


Today i got the update on windows too, but there it works
 

grandrolf

Global moderator
Team Member
Global Moderator
Trusted User
Aug 29, 2014
2,658
246
133
sweden
Here the debug.log what is the same content as the lastest.log. It happens on omnia and direwolf on Debian GNU Linux Buster on java 8, 11, 15. This log is with java 8.

Please share full log and not only the debug - the java version loaded is not showing.

The reason for asking is that it's very common that users claim to be using a specific java version, but when we check the logs it's still the non-java-8 that's in use.
 

druuhl

New Member
Jul 31, 2020
10
0
2
Puh, thats strange, when i look with "ps fax" what is running, i see openjdk11, not the version which is provided as default version by Debian.

So i have to edit

- /home/druuhl/tools/FTBA/.install4j/inst_jre.cfg

to choose the right JVM for FTBApp.

I have added the debug flag to the FTBApp launcher ( bash -x ) to provide more information

Launching FTBApp with java8 (No suitable Java Virtual Machine could be found on your system., The version of the JVM must be at least 11.0.5 and at most 11.0.999)
- https://paste.feed-the-beast.com/view/55188d05

Launching FTBApp with java11
- https://paste.feed-the-beast.com/view/2cdcbd3d
Latest.log
- https://paste.feed-the-beast.com/view/b6e20ffe

i tried it with a local version of oracle Java 8 JRE, but the same here (No suitable Java Virtual Machine could be found on your system., The version of the JVM must be at least 11.0.5 and at most 11.0.999)


Installed JVMs
Code:
aptitude search adopt | grep ^i

iB adoptopenjdk-11-hotspot-jre - OpenJDK Runtime Environment 11 (JRE) with Hotspot by AdoptOpenJDK
iB adoptopenjdk-8-hotspot-jre - OpenJDK Runtime Environment 8 (JRE) with Hotspot by AdoptOpenJDK


The JVM Chooser is changed, i cant choose other JVM than 11.

Instance_setting.png


I used FTBApp with java 11 or 15 in the past and the direwolf instance with java 15 (direct choosen in the settings, which is not more possible)

I think java8 is a bit outdated, no actual linux system provides java8 out of the box, thats the reason im using the adoptopenjdk source.
 

Attachments

  • Instance_setting.png
    Instance_setting.png
    145.8 KB · Views: 126
  • 1618042846434.png
    1618042846434.png
    145.8 KB · Views: 69
  • Instance_setting.png
    Instance_setting.png
    145.8 KB · Views: 116
Last edited:

grandrolf

Global moderator
Team Member
Global Moderator
Trusted User
Aug 29, 2014
2,658
246
133
sweden
The latest update of java 8 by oracle is version 281 and that was released the 19th of January 2021.

If you want to play modded Minecraft you need to stick to java version 8, it's still available to install either via package or manually on your system.

If you can't get to work and don't need higher versions of java, remove those versions and only use java 8.
 

druuhl

New Member
Jul 31, 2020
10
0
2
Unisnatlled all JDK/JRE, downloaded actual oracle Java8, entered in

- /home/druuhl/tools/FTBA/.install4j/inst_jre.cfg

Started FTBApp

Code:
+ echo /home/druuhl/tools/jre1.8.0_281
+ sed -e s/ /\\ /g
+ dir_escaped=/home/druuhl/tools/jre1.8.0_281
+ echo JRE_VERSION      /home/druuhl/tools/jre1.8.0_281 1       8       0       281
+ echo JRE_INFO /home/druuhl/tools/jre1.8.0_281         1607518054      102
+ chmod g+w /home/druuhl/.install4j
+ [ 1 =  ]
+ [ 1 -lt 11 ]
+ return
+ [ -z  ]
+ [ true = false ]
+ [ -z  ]
+ echo No suitable Java Virtual Machine could be found on your system.
No suitable Java Virtual Machine could be found on your system.
+ echo The version of the JVM must be at least 11.0.5 and at most 11.0.999.
The version of the JVM must be at least 11.0.5 and at most 11.0.999.
+ echo Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
+ exit 83

FTBApp doesnt allow Java 8 and doesnt allow to configure java8 for direwolf, when starting FTBApp with java 11 plus. Something has change with the last update, FTBApp was running with java 11 and direwolf was manual configured with adoptopenjdk 15 and it was running.

After that i reinstalled java11 and 15. In the settings for the instance direwolf, i can only choose the newest java version, in this case 15. I would try it with java8, but im not able to configure it in FTBApp, because

- The version of the JVM must be at least 11.0.5 and at most 11.0.999
 

druuhl

New Member
Jul 31, 2020
10
0
2
The Check for minimum Java11 is hard coded in this files

- uninstall
- .install4j/bgupdater
- FTBApp

I dont have the pre update versions of the file, but i suggest, this is part of what someone has changed.

The test_jvm function, written in bash, only Java 11 is allowed (second part)

Code:
test_jvm() {
  tested_jvm=na
  test_dir=$1
  bin_dir=$test_dir/bin
  java_exc=$bin_dir/java
  if [ -z "$test_dir" ] || [ ! -d "$bin_dir" ] || [ ! -f "$java_exc" ] || [ ! -x "$java_exc" ]; then
    return
  fi

  modification_date=0
  date_output=`date -r "$java_exc" "+%s" 2>/dev/null`
  if [ $? -eq 0 ]; then
    check_date_output
  fi
  if [ $modification_date -eq 0 ]; then
    stat_path=`command -v stat 2> /dev/null`
    if [ "$?" -ne "0" ] || [ "W$stat_path" = "W" ]; then
      stat_path=`which stat 2> /dev/null`
      if [ "$?" -ne "0" ]; then
        stat_path=""
      fi
    fi
    if [ -f "$stat_path" ]; then
      date_output=`stat -f "%m" "$java_exc" 2>/dev/null`
      if [ $? -eq 0 ]; then
        check_date_output
      fi
      if [ $modification_date -eq 0 ]; then
        date_output=`stat -c "%Y" "$java_exc" 2>/dev/null`
        if [ $? -eq 0 ]; then
          check_date_output
        fi
      fi
    fi
  fi

  tested_jvm=false
  read_db_entry || create_db_entry $2

  if [ "$ver_major" = "" ]; then
    return;
  fi
  if [ "$ver_major" -lt "11" ]; then
    return;
  elif [ "$ver_major" -eq "11" ]; then
    if [ "$ver_minor" -lt "0" ]; then
      return;
    elif [ "$ver_minor" -eq "0" ]; then
      if [ "$ver_micro" -lt "5" ]; then
        return;
      fi
    fi
  fi

  if [ "$ver_major" = "" ]; then
    return;
  fi
  if [ "$ver_major" -gt "11" ]; then
    return;
  elif [ "$ver_major" -eq "11" ]; then
    if [ "$ver_minor" -gt "0" ]; then
      return;
    elif [ "$ver_minor" -eq "0" ]; then
      if [ "$ver_micro" -gt "999" ]; then
        return;
      fi
    fi
  fi
 
Last edited:

druuhl

New Member
Jul 31, 2020
10
0
2
After testing more, i mean deactivating the java version restriction i was able to start FTBApp with java8 and java15 properly.

Code:
  tested_jvm=false
  read_db_entry || create_db_entry $2

  if [ "$ver_major" = "" ]; then
    return;
  fi
  if [ "$ver_major" -lt "8" ]; then
    return;
  elif [ "$ver_major" -eq "8" ]; then
    if [ "$ver_minor" -lt "0" ]; then
      return;
    elif [ "$ver_minor" -eq "0" ]; then
      if [ "$ver_micro" -lt "5" ]; then
        return;
      fi
    fi
  fi

  if [ "$ver_major" = "" ]; then
    return;
  fi
  if [ "$ver_major" -gt "15" ]; then
    return;
  elif [ "$ver_major" -eq "15" ]; then
    if [ "$ver_minor" -gt "0" ]; then
      return;
    elif [ "$ver_minor" -eq "0" ]; then
      if [ "$ver_micro" -gt "999" ]; then
        return;
      fi
    fi
  fi

After removing all JREs except 8, and try starting direwolf20 i got the same Error

Code:
[18:00:47] [ForkJoinPool-1-worker-19/ERROR] [net.creeperhost.creeperlauncher.pack.LocalInstance]: Unable to initialize MineTogether Connect!
[18:00:47] [ForkJoinPool.commonPool-worker-27/ERROR] [Minecraft Launcher 0]: terminate called after throwing an instance of 'std::logic_error'
[18:00:47] [ForkJoinPool.commonPool-worker-27/ERROR] [Minecraft Launcher 0]:   what():  basic_string::_M_construct null not valid

Which means, this has nothing todo with java versions. Its a bug which came with the last update a few days ago.
 

druuhl

New Member
Jul 31, 2020
10
0
2
What do you mean with full log. I have teh lastest.log and teh debug log, both have the same content, except teh date format. Otherwise, nothing different than

Launching FTBApp with java8 (No suitable Java Virtual Machine could be found on your system., The version of the JVM must be at least 11.0.5 and at most 11.0.999)
- https://paste.feed-the-beast.com/view/55188d05

Launching FTBApp with java11 (add debug flag (-x) to bash interpreter)
- https://paste.feed-the-beast.com/view/2cdcbd3d

Latest.log
- https://paste.feed-the-beast.com/view/b6e20ffe
 

grandrolf

Global moderator
Team Member
Global Moderator
Trusted User
Aug 29, 2014
2,658
246
133
sweden
You still need to install and use java 8 - all I see is later versions of java.

If it fails with java 8, then post a link to full log - if you still keep trying with other versions of java, don't bother reporting issues with that.
 

druuhl

New Member
Jul 31, 2020
10
0
2
Again, FTBApp doesnt start with java 8, i got this. The Start Script FTBApp "DOES NOT ALLOW" Java 8 ----> (No suitable Java Virtual Machine could be found on your system., The version of the JVM must be at least 11.0.5 and at most 11.0.999) It must be Java 11.
- https://paste.feed-the-beast.com/view/55188d05


When i start FTBApp with java11 i dont have a chance to select another than the newest Java version, not an older like java 8 to start an instance of a modpack
and this leads to the Error


Launching FTBApp with java11 (add debug flag (-x) to bash interpreter)
- https://paste.feed-the-beast.com/view/2cdcbd3d

Latest.log
- https://paste.feed-the-beast.com/view/b6e20ffe
 

druuhl

New Member
Jul 31, 2020
10
0
2
Still broken, now as a video for the people who dont want to read comments

- https://easyupload.io/u0bkvy

The Launcher needs Java11, but with java11 mods cant start. i cant set another java version in mod than the newest one, so launcher needs java11, but java 11 is noch allowd for mod.
Please fix the this, in the moment THE LINUX CLIENT SUPPORT IS BROKEN!
i tried this with

- Fresh installed Debian Linux 10
- Fresh installed FTBApp (FTBA_unix_202105051818-5b1f30277f-release.sh)
- Fresh installed Direwolf
- Installed Java 8 / 11

Or is there another way to start the mod instance ?
 

pooves

New Member
Nov 27, 2020
2
0
2
Grandrolf, what part of "The Start Script FTBApp "DOES NOT ALLOW" Java 8" do you not understand. forward this thread to someone who is actually involved with writing the code and stop acting like its our fault.
 
Status
Not open for further replies.