FTB Revelations Nether Fortress Spawn-rate

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Eventual bugs for older packs will not be fixed.

LifesHarlequin

New Member
Jan 4, 2020
2
0
1
US
Been playing FTB Rev on and off for a few months, and took a while to actually get to the Nether. When I did, I'm getting zero spawns on the Nether Fortress except for blazes from the blaze spawner. I tried to chunk load the whole fortress and even found a second fortress, but still, no spawns aside from blaze spawners.

Realized it's not just the Nether Fortress. Only spawns in the Nether are the fire foxhounds from Quark and a few Zombie Pigmen.

Tried tweaking Quark configs to allow for Blazes to spawn naturally, and have restarted both the game, FTB launcher, and computer to try and fix the issue, but still no luck. Created a Creative mode FTB Rev and found a larger fortress and finally got Wither Skeleton spawns and Ghasts with Blazes spawning naturally outside their spawners.

Really don't want to dump the world I've spent a few good weeks on with mid tier build ups for a few magick mods if there is a config or way to reset the spawn rates in the Nether.

Any help is appreciated.
 

LifesHarlequin

New Member
Jan 4, 2020
2
0
1
US
Update: tried /kill @e, ensuring /gamemode 0, and unclaimed all chunks to make sure nothing in the overworld was allowing a massive mob group to just survive... got spawns on the fortress and killed a few wither skellies... then nothing respawned...
 

GameAbyss

New Member
Sep 17, 2020
2
0
2
Hi, I ran into this same issue and found the root cause and a workaround.

CAUSE:
The Foxhound in Quark mod is inappropriately implemented based on the vanilla wolf (because both are tameable as I think),
although the former is registered for spawning as a hostile mob.
As a result, foxhounds are continuously spawned in nether and NEVER DESPAWN, soon filling up the nether mob capacity and completely blocking the other mobs from being spawned.

WORKAROUND:
Edit {your_instance}/config/quark.cfg file and set the "B:Foxhounds" value to false.
Restart the game. When loading the saved data, you will be warned that the quark: foxhound entity which is present in the saved world is now absent from the entity registry so the entity is removed from the world. No problem, for that is what you want.
Now you will never see that annoying herd of dogs and the nether spawn rate is back to normal. Enjoy!

Decreasing the foxhounds spawn weight or executing "/kill @e[type=quark:foxhound]" command will make the situation better only for a while and to a limited degree, for newly spawned foxhounds will soon fill the mob cap anyway.
 
Last edited: