1. This section of the forums is now closed. You can post and answer support requests on the new support site here

FTB Launcher crashes with unhandled exception

Discussion in '[Archived] Tech Support' started by Phylacista, Dec 26, 2013.

  1. Phylacista

    Phylacista New Member

    I just downloaded the current FTB Launcher and tried to run it, but it keeps crashing with a unhandled NPE @ at net.ftb.util.winreg.JavaFinder.parseWinJavaVersion(JavaFinder.java:159).

    I do use Windows 7 x64 and Java 1.7.0_45. JAVA_HOME is set, but i suspect that the launcher can not handle my "way of installation", as I was bad and simply extracted all the binaries instead of running the installer - as i always do. No application has problems with that (Eclipse / IDEA / Tomcat etc.) but the FTB launcher seems to look up the registry for installations paths etc. (if Github is up to date). Why is the Java version / paths being looked up in the registry even if the launcher is already being executed by the "correct" version which could be determined by using System.getProperty("java.version")?

    But mabye i am blaming the wrong code because Github is not up to date. In that case -> Sorry, here is the java console output ;-):

    From Console: Exception in thread "AWT-EventQueue-0"
    From Console: java.lang.NullPointerException
    From Console: at net.ftb.util.winreg.JavaFinder.parseWinJavaVersion(JavaFinder.java:159)
    From Console: at net.ftb.gui.panes.OptionsPane.<init>(OptionsPane.java:132)
    From Console: at net.ftb.gui.LaunchFrame.<init>(LaunchFrame.java:504)
    From Console: at net.ftb.gui.LaunchFrame$1.run(LaunchFrame.java:274)
    From Console: at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
    From Console: at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
    From Console: at java.awt.EventQueue.access$200(EventQueue.java:103)
    From Console: at java.awt.EventQueue$3.run(EventQueue.java:694)
    From Console: at java.awt.EventQueue$3.run(EventQueue.java:692)
    From Console: at java.security.AccessController.doPrivileged(Native Method)
    From Console: at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    From Console: at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
    From Console: at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    From Console: at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    From Console: at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    From Console: at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    From Console: at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    From Console: at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
  2. lavarthan

    lavarthan Well-Known Member

    This is a known error with one known solution. You have multiple versions of Java installed and need to remove them. Go into your control panel and remove all 32bit versions of Java and all remove all 64bit versions, but 7u45. Also your log might/should list the versions you have and their folders and help you find them if the Control Panel does not list them.
  3. Phylacista

    Phylacista New Member

    As I mentioned -> I did not use the Java installer and I never did. There is no other "installation" to be found on my system. The only version all logs show is 1.7.0_45.
  4. lavarthan

    lavarthan Well-Known Member

    Then your idea about 'being bad' is probably correct. Unless you have a major reason for doing that I suggest using the installer otherwise I'm out of ideas for help. Sorry, good luck.
  5. Phylacista

    Phylacista New Member

    Grabbed the current Github code and already solved it by forcing the launcher to use the Java environement given by JAVA_HOME :). Anyways someone should add some exception handling to the initial exception I found ;-).

Share This Page