FTB Infinity Evolved - Enable Ranks

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Eventual bugs for older packs will not be fixed.

Ziperar

New Member
May 7, 2020
6
0
2
Hey guys :)

Im running a FTB Infinity Evolved Server where i want to enable the FTB Utilities Ranks.

I googled already and found this for example:


Enabling Ranks

They are enabled by default, but if they aren't, set Enabled & Override Chat to true in config/ftbutilities.cfg.
But i can not find the option in my config file.
Ingame the /ranks comands do not work eather.



Hope you guys can help me out =)
 
Last edited:

grandrolf

Global moderator
Team Member
Global Moderator
Trusted User
Aug 29, 2014
2,276
216
108
sweden
Infinity Evolved is a 1.7.10 based pack, so the commands might differ from the current ones on the wiki.

Check the ../local/ftbu/ranks.txt file (could be /local/ftbutilities/ranks.txt)

And check for commands starting with /ftb (make sure you're op as well)
 

Ziperar

New Member
May 7, 2020
6
0
2
Hey =)

Thanks for the answer.

Check the ../local/ftbu/ranks.txt file (could be /local/ftbutilities/ranks.txt)
I have no such file, i searched all folders. At /local/ftbutilities/ there is only a "config" file:
Code:
{
  "backups": {
    "backup_timer": 1.0,
    "backups_to_keep": 100,
    "compression_level": 1,
    "display_file_size": true,
    "enabled": true,
    "folder": "./backups/",
    "need_online_players": true,
    "use_separate_thread": true
  },
  "chunkloading": {
    "enabled": true,
    "max_player_offline_hours": -1.0
  },
  "commands": {
    "back": true,
    "home": true,
    "name_admin": "admin",
    "spawn": true,
    "tplast": true,
    "warp": true
  },
  "general": {
    "blocked_entities": [],
    "restart_timer": 0.0,
    "safe_spawn": true,
    "server_info_difficulty": true,
    "server_info_mode": true,
    "spawn_area_in_sp": false,
    "spawn_pvp": true
  },
  "login": {
    "motd": [
      "Welcome to INFINIT BRAIN - please consider joining us on Teamspeak: 91.200.101.84  Enjoy your Stay!"
    ],
    "starting_items": [
      "minecraft:apple 16 0"
    ]
  },
  "permissions_admin": {
    "allow_creative_interact_secure": true,
    "badge": "",
    "break_whitelist": [
      "OpenBlocks:grave"
    ],
    "cross_dim_homes": true,
    "custom_config": {},
    "dimension_blacklist": [],
    "forced_chunk_security": "-",
    "forced_explosions": "-",
    "max_claims": 1000,
    "max_homes": 100,
    "max_loaded_chunks": 50,
    "show_rank": true
  },
  "permissions_player": {
    "allow_creative_interact_secure": false,
    "badge": "",
    "break_whitelist": [
      "OpenBlocks:grave"
    ],
    "cross_dim_homes": true,
    "custom_config": {},
    "dimension_blacklist": [
      1
    ],
    "forced_chunk_security": "friends",
    "forced_explosions": "disabled",
    "max_claims": 200,
    "max_homes": 20,
    "max_loaded_chunks": 50,
    "show_rank": true
  },
  "tops": {
    "deaths": true,
    "deaths_ph": true,
    "first_joined": true,
    "last_seen": true,
    "time_played": true
  }
}
I tryed adding a permisson_xyz myself but this isnt working eather. And i can not assign them ingame.


And check for commands starting with /ftb (make sure you're op as well)
I checked them and i only got these two commands starting with ftb: ftb_mode and ftb_notify

I looked trough google alot the past two weeks and tryed new stuff and old stuff nothing seems to work.