Failure to register Dimension id 7

Discussion in 'Server Tech Support' started by SeanMcNinja, Nov 7, 2012.

  1. SeanMcNinja

    SeanMcNinja New Member

    Had this crash all yesterday, I was unable to keep my old server world at all, the only thing that worked was a complete reset. I suspect it's a mod issue, not specifically a problem with FTB.
    Crash report follows:

    ---- Minecraft Crash Report ----
    // Why is it breaking :(

    Time: 11/6/12 2:31 AM
    Description: Exception in server tick loop

    java.lang.IllegalArgumentException: Failed to register dimension for id 7, One is already registered
    at net.minecraftforge.common.DimensionManager.registerDimension(
    at xcompwiz.mystcraft.MystcraftEventHandler.registerDimensions(
    at xcompwiz.mystcraft.MystcraftEventHandler.handleWorldLoadEvent(
    at net.minecraftforge.event.ASMEventHandler_58_MystcraftEventHandler_handleWorldLoadEvent_Load.invoke(.dynamic)
    at net.minecraftforge.event.ASMEventHandler.invoke(
    at net.minecraft.server.MinecraftServer.a(
    at hg.c(

    Relevant Details:
    - Minecraft Version: 1.4.2
    - Operating System: Linux (amd64) version 2.6.18-308.el5.028stab099.3
    - Java Version: 1.7.0_07, Oracle Corporation
    - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    - Memory: 7229656 bytes (6 MB) / 41222144 bytes (39 MB) up to 1240858624 bytes (1183 MB)
    - JVM Flags: 5 total; -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts -Xmx1200M
    - AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    - FML: ~ERROR~ NullPointerException: null
    - Is Modded: Definitely; 'forge,fml'
    - Profiler Position: N/A (disabled)
    - Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    - Player Count: 0 / 20; []
    - World FTB-Beta-A Entities: 0 total; []
    - World FTB-Beta-A Players: 0 total; []
    - World FTB-Beta-A Chunk Stats: ServerChunkCache: 0 Drop: 0
    - Type: Dedicated Server
  2. Vauthil

    Vauthil Professional Lurker Retired Staff

    Was your existing server running MystCraft? If so, had you created ages on it?

    If you added the latest FTB pack, it included Twilight Forest in it. Twilight Forest by default requires Dimension ID #7. It's likely that Twilight Forest co-opted this upon load and then MystCraft tried to load its own Dimension ID #7 (kept in world/DIM_MYST7, versus the one Twilight Forest creates under world/DIM7) and that's what irritated MystCraft a lot.

    If so, solutions besides a reset could include:

    A) Change the Dimension ID on Twilight Forest to be outside the range of Mystcraft Ages you've already created (this can be done in the config/TwilightForest.cfg file with the dimensionID parameter). You may need to push the config change to your users (I'm unsure, this is untested by me).
    B) If you don't really care to keep the current Age #7, Remove the offending Mystcraft Age (remove DIM_MYST7 folder from the world folder, also remove agedata_7.dat from the world/data folder).
    C) Advanced option if you want to not edit configs and you want to keep the age and renumber it: Rename world/data/agedata_7.dat to agedata_<insert available number>.dat. Rename the world/DIM_MYST7 folder to world/DIM_MYST<insert same available number>. This is how you can "salvage" the current Age #7, although you may or may not need to ditch the linking/descriptive books involved and use /myst-agebook on an op account to give yourself a new descriptive book for that age (I'm not certain of the metadata for the books, so I'm just playing it safe).
  3. Greedseed

    Greedseed Well-Known Member Retired Staff

    You need to reset your world on Beta releases. This is not always the case but will save you tons of trouble. Its beta so thats what can happen

    Reason for this. Since its beta a lot of things get changed. This time FTB changed some ore generation. Some ore got out and stuff got added as well.

    This might not directly couse this issue but still. We are at beta so its fairly normal to regen the world on mayor pack changes.
  4. SeanMcNinja

    SeanMcNinja New Member

    I'll try and keep the world through the beta releases, even so. If it doesn't work, I won't worry too much about it.

    I suspected it was twilight causing an age conflict with the Age7 thing, I tried removing both the DIM_MYST7 and its agedata, as well as DIM7, to no effect, the same error kept repeating.
  5. Chinthor

    Chinthor Active Member

    Thanks for the heads up! Changed twilight's number and all is well.

Share This Page