Problem Exec format error on Raspberry Pi 4 with Ubuntu server


New Member
Jan 5, 2022
Hello you helpful people,

I currently try to setup a server for my bf and me to play on. Normal server worked just great.
Now I tried to install FTB Academy 1.16, but it didnt work.

OS: Ubuntu server with "uname -m" "armv7l " is shown
We are using a Raspberry Pi 4
We tried FTB Academy 1.16 Version 1.2.0, 1.1.0 and 1.0.1 in the Linux and Linux arm version
We didnt add any mods.

So I downloaded the serverfiles and moved them to the Pi via Filezilla. There I made it executable and wanted to execute it with "./xxx" but always the Error "cannot execute binary file: Exec format error" occurred.

Is my architecture not supported, am I doing something completely wrong or do you have any ideas what I could try?
Thanks for reading :)


New Member
Apr 8, 2022
I had this problem when I first set it up to. I don't remember the exact fix however I remember a few things I had to check along the way.
Is Java installed? I'm personally using OpenJDK v 1.8.0_312 (found with "java -version" command).
Is your file properly set?
Towards the bottom of does it have something similar to "-jar forge-1.16.5-36.2.26.jar nogui" (your forge version may vary?)
I am no linux expert but I'd confirm those things first