Open Ex compressum auto hammer gui crashes game when modified tinkers' pickaxe is in inventory.

  • This section is closed. Please do bug reports over at the FTB GitHub repos.
  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord

SoYman

New Member
Jul 29, 2019
1
0
0
Summary of the problem Ex compressum auto hammer gui crashes game when modified tinkers' pickaxe is in inventory.

Pack Version 1.1.0

What is the bug? I wanted to try to put a tinkers' construct platinum pickaxe with the smashing modifier -- combining a TC pickaxe and a ex nihilo hammer -- but when i open the ex compressum auto hammer the game crashes when I pick anything up with the modified pickaxe in the inventory.

Mod & Version It's actually version 1.2.0 as far as I can tell and the mod is FTB Infinity Evolved Skyblock as per where I am posting this.

Link to log file http://paste.feed-the-beast.com/view/ce0d46b1

Is it repeatable? I tried 3-4 times and the same effect was observed in all cases. I doubt that the specific ingame setup has an effect on the bug and I changed some graphics settings (for another reason) which had no effect on the bug. The steps are detailed in the "What is the bug?" section.

Known Fix No workaround besides not doing it. I could imagine that this wasn't intended on being used but I decided to try anyways . Icarus would be proud of me.
 
G

got_bored_again

Guest
Errors like this shows how crunshed this whole modding stuff is and how deep some injections go using refelctions and asm-level "hacking" ... makes me still wonder why the all-mighty cpw as creator of the underlying fml just doesn't fix this buggy mc-code (as he has access to inject his code) to get rid of such crap ...

... nevermind - back to topic:

The error-message (or to be more correct in terms of programmer language: Exception StackTrace) only says that an Exception occured while reading some inventory. Without your information this happend after putting in a TC-pick (wich, according to the changelog, shouldn't be possible) it would just be impossible to track it down where it came from because there are no other information.
But there is a very helpfull information wich says IntegratedServer - so you play this on "single player". Did you tried it on a "multi player" "server" (yes, I use these quotes on purpose)? Maybe its a SSP issue and doesn't occur on SMP.
But to explain the Exception: it is throws because on some point in the memory there is an integer wich says: "Ok, there are 53 or more different Stacks in this inventory and I want to get data from the 53rd Stack (lists and arrays in java always starts at index 0)" wich is really confusing when such code mostly gets called inside a loop - so the crash should occur on the 45th index (wich is the 46th stack) as there are only 45 elements in this list - so the max index is 44. So some code tries to direclty access this very slot wich means some gui-handling code is badly written. Why? Cuase in some point some has to tell the gui wich slot is wich index - so this seems to be a counting issue and someone did the maths wrong.

I have to add as in my thread: that's what unit tests are for ... just sayin'