Direwolf20 pack having "failed to synchronize registry data from server" after updates. Twice. Help!

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Bugs for older packs will not be fixed, unless they are critical.

GiftoftheMagi

New Member
Feb 5, 2021
1
0
1
Twice now my friend and I have started a DW20 world with the new pack, and twice after an update one or the other cannot join. We have tried removing mods, altering mod order, direct connection...nothing works AT ALL. the ONLY solution is to restart an entirely new world. Any copy fails to work too.


So twice now we have had to delete worlds just to play together. This is getting tiring. Is there any other solutions?
 

thexalien

New Member
Jan 17, 2021
10
0
2
Is this hosted locally on a pc, rented server, personal server etc. What error code is it throwing when trying to connect to the server. Do you have logs?
 

Galvas

New Member
Jul 29, 2019
35
0
1
Maybe not the same, but I'm having the same problem. Hosted locally with "Open to Lan".

Code:
[06Feb2021 13:25:04.070] [Render thread/INFO] [Astral Sorcery/]: Client cache cleared!
[06Feb2021 13:25:04.077] [Render thread/INFO] [net.minecraft.client.gui.screen.ConnectingScreen/]: Connecting to 192.168.2.107, 51569
[06Feb2021 13:25:04.624] [Render thread/INFO] [Astral Sorcery/]: Built PerkTree with 417 perks!
[06Feb2021 13:25:07.611] [Render thread/ERROR] [net.minecraftforge.fml.network.FMLHandshakeHandler/FMLHANDSHAKE]: Missing registry data for network connection:
  minecraft:block: industrialforegoing:milk_block

[06Feb2021 13:25:07.611] [Netty Client IO #5/ERROR] [net.minecraftforge.fml.network.FMLHandshakeHandler/FMLHANDSHAKE]: Failed to load registry, closing connection.
[06Feb2021 13:25:07.611] [Netty Client IO #5/ERROR] [net.minecraftforge.fml.network.FMLHandshakeHandler/FMLHANDSHAKE]: Connection closed, not continuing handshake
Not sure if there is anywhere I can get more specific networking logs. We are both on the same version, tried to reinstall the modpack on the client user but still same issue.

EDIT: Oh actually looks like that minecraft:block: industrialforegoing:milk_block could be the issue right? Any way to do a local fix without waiting for a modpack update?
 

Icemanap

Member
Jul 29, 2019
3
0
17
Maybe not the same, but I'm having the same problem. Hosted locally with "Open to Lan".

Code:
[06Feb2021 13:25:04.070] [Render thread/INFO] [Astral Sorcery/]: Client cache cleared!
[06Feb2021 13:25:04.077] [Render thread/INFO] [net.minecraft.client.gui.screen.ConnectingScreen/]: Connecting to 192.168.2.107, 51569
[06Feb2021 13:25:04.624] [Render thread/INFO] [Astral Sorcery/]: Built PerkTree with 417 perks!
[06Feb2021 13:25:07.611] [Render thread/ERROR] [net.minecraftforge.fml.network.FMLHandshakeHandler/FMLHANDSHAKE]: Missing registry data for network connection:
  minecraft:block: industrialforegoing:milk_block

[06Feb2021 13:25:07.611] [Netty Client IO #5/ERROR] [net.minecraftforge.fml.network.FMLHandshakeHandler/FMLHANDSHAKE]: Failed to load registry, closing connection.
[06Feb2021 13:25:07.611] [Netty Client IO #5/ERROR] [net.minecraftforge.fml.network.FMLHandshakeHandler/FMLHANDSHAKE]: Connection closed, not continuing handshake
Not sure if there is anywhere I can get more specific networking logs. We are both on the same version, tried to reinstall the modpack on the client user but still same issue.

EDIT: Oh actually looks like that minecraft:block: industrialforegoing:milk_block could be the issue right? Any way to do a local fix without waiting for a modpack update?
I just posted this but in my single player world, game is unable to load after "Built PerkTree with 417 perks". I can join older back ups of the world.
 

Galvas

New Member
Jul 29, 2019
35
0
1
Still happens in 1.6.1

Creating a new map works, problem seems to be with the map that was ported from 1.5.1
 
Last edited:

Krakanu

New Member
Feb 6, 2021
1
0
2
I'm having this exact same issue and error message in the log. Seems like the only thing that works for me is rolling back to 1.5.1.

Tried removing/rolling back industrial foregoing but that didn't help.
 

Jackalb

New Member
Feb 8, 2021
3
0
2
My partner and I have been having these exact same problems over LAN. We're relatively new w to the Minecraft scene and eager to get immersed but this has been causing some difficulties and has been pretty disheartening.

If anyone's aware of a fix please let us know.
 

BaineWolf

Member
Jul 29, 2019
6
0
16
Same issue, we(3) play together for hours. After updates sometimes one sometime two of us can't join. Local lan, no changes to files other than updates.