1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Windows .exe Crash during FML setup

Discussion in '[Archived] Tech Support' started by Andazeus, Nov 5, 2012.

Thread Status:
Not open for further replies.
  1. Andazeus

    Andazeus New Member

    Alright, I think I found the problem!

    It worked after I encrypted my connection for testing purposes. So the problem must be network related in some way, probably located at my ISP. They block P2P traffic and use a web reputation filter that filters http, that might be a possible cause.

    The only question that remains: is there a way to permanently fix this for all users? I know I am not the only one with this problem and not everyone has access to a VPN to circumvent this. Since this seems to happen during the FML setup, maybe try contacting the forge team to provide an alternate method of acquiring the files?

    However: thanks to everyone for their effort. This was a rather exotic problem after all (although it could become a bigger deal in the future with more and more ISPs regulating traffic).

    Also: since I can't edit the thread title, can a mod change it so we know it is solved now?
  2. Ashzification

    Ashzification Over-Achiever

    Maybe a nice (fix) tag would be useful! And I wasn't meaning to disregard your java version. There are many people out there who will read your thread not knowing older versions won't work, but now they will!
  3. Andazeus

    Andazeus New Member

    That's why I asked a mod to do it. I can't edit it....

    It still has NOTHING to do with Java! It is a NETWORK problem! And I stated my Java version in the very first post, as I already told you earlier! I really appreciate your effort and don't mean to disregard it, but I am really getting the feeling you are not reading my posts at all, yet comment on them.

    Anyways... while the problem itself isn't fixed per se, we at least have a workaround now.
  4. Ashzification

    Ashzification Over-Achiever

    However, you also stated that you had multiple versions of Java, and found the network problem later.
    Other users coming by trying to fix things may have their problem fixed by finding out they shouldn't have multiple versions of Java, and that they need the most up to date version.

    So to clarify [for other users]: only have one version of Java, make sure it is the most recent version and update.

    As for my comment about a (fix) tag, that was me agreeing that a staff member should change something and trying to hint at a change that would help the forums.

    So, sorry you didn't like my attempt at helping. I don't just try to help the original poster, I try to make it so fixes will help others with similar problems.
  5. Greedseed

    Greedseed Well-Known Member Retired Staff

    Il hit it up in the Website Dev room today on teamspeak Ashzification :)
  6. Andazeus

    Andazeus New Member

    No, I didn't :)

    I guess I misunderstood you on that part. My apologies.
    Hey, I told you I still appreciate it! Even if it doesn't not always lead to a solution, any response is better than none! Maybe you just confused me with someone else and I got somewhat confused when you insisted on the Java problematic while I was very sure that it wasn't the cause. I do realize though, that Java is the most common cause of problems and it's therefore the first thing to blame (and the first thing for me to double check every time).
    Even though we maybe got rubbed the wrong way in confusion, I hope we can still be cool (I will!) :)
    Soo... a workaround has been found, Java is not to blame this time and we need the title changed. I think we can agree on these things :)
  7. Evil Hamster

    Evil Hamster Active Member

    What exactly is the fix here? I have an encrypted connection (WiFi)- or are you talking about something else?
  8. Andazeus

    Andazeus New Member

    I used a VPN. Encrypted WiFi only means the connection between your computer and your wifi access point is encrypted. Using VPN allowed me to get a point to point encryption, circumventing my ISPs traffic shaping. There are various VPN providers out there, but most are paid.

    If you are looking for a free solution, I think HotSpot Shield should work.
  9. Ashzification

    Ashzification Over-Achiever

    Yep, right here:
    See, I pay attention! ;)
  10. frederikam

    frederikam Well-Known Member

    Java Development Kit - A tool for java programmers like the modders and Mojang.
  11. Ashzification

    Ashzification Over-Achiever

    Yes, I know. However, from my gathered knowledge, more than one Java, any Java, makes running minecraft and mod packs difficult.
  12. frederikam

    frederikam Well-Known Member

    Think that the mod developers run it, if it was a problem they would fix it.
  13. Andazeus

    Andazeus New Member

    JDK and JRE are two different things :)

    How am I supposed to learn Minecraft modding without the JDK? :p
  14. Fyrby

    Fyrby New Member

    I had the same issue. Installing the free version of HotSpot Shield and using it for the launcher helped. I use the university's internet but all ports greater than 1000 should be free and I never had problems with that before. In my opinion there is no reason for the launcher to use something like p2p or whatever is causing the issue. It just has to download stuff. If there is a problem with web reputation filters on the http port there should be a method implemented to load the files via another port which is configurable. I just want to say that however there is method to fix the problem it shouldn't occur in the first place.
  15. SlipperyPete

    SlipperyPete New Member

    I have been searching the internet and From other forum posts and other sites i have found that the promlem is that in the lib folder some of the forge files are missing and this cannot be fixed simply by reinstalling for some reason and you have to download the files separately and insert them yourself, unfortunately I have no idea where to download theses files.
Thread Status:
Not open for further replies.

Share This Page