Closed Consistent "can't keep up!" on VM box server.

Discussion in 'FTB Revelation' started by Essentiality, Jan 18, 2018.

  1. Essentiality

    Essentiality New Member

    Summary of the problem Consistent "can't keep up!" on VM box server.

    Pack Version 1.2.0

    What is the bug? The server seems to have the "Can't keep up!" message roughly every 14-20 seconds endlessly. We've attempted to unload specific chunks to see if it'd stop or change in consistency to no avail. We're also not convinced it is a hardware issue as I'll share specs below.

    Mod & Version

    Link to log file

    Is it repeatable? Yes, it seems to always happen, even when changing JVM arguments, unloading chunks and trying new ones, etc.

    Known Fix
     
  2. Essentiality

    Essentiality New Member

    The hardware running on the box is an Intel Xeon CPU E5-2670 @ 2.60 GHz with 10 GB of RAM and a 64-bit OS.
    CPU Usage and a Speed Test are attached to this, as well as the log.

    We also played around with the JVM arguments in an attempt to fix it. This is what we're set at currently, though I want to stress that all changes we made yielded no noticable results or change:


    rem Do not touch
    set MCVER=1.12.2
    set JARFILE=minecraft_server.%MCVER%.jar
    set LAUNCHWRAPPERVERSION=1.12
    set LAUNCHWRAPPER=net\minecraft\launchwrapper\%LAUNCHWRAPPERVERSION%\launchwrapper-%LAUNCHWRAPPERVERSION%.jar
    set FORGEJAR=FTBserver-1.12.2-14.23.1.2573.jar

    rem can be changed by user
    set MIN_RAM=4G
    set MAX_RAM=4G
    set PERMGEN_SIZE=256M
    set JAVA_PARAMETERS=-XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -XX:parallelGCThreads=2 -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10


    Any input on what might be the issue, please let me know! The server is still playable for everyone, I'd just like to make it better if possible.

    Thanks.
     

    Attached Files:

  3. DrDurandal

    DrDurandal New Member

  4. Essentiality

    Essentiality New Member

    It is running Hyper-V 2016 core and it is on a HP DL380P, with 32 (we're giving it 8) Xeon 2.8 Ghz processors with 128 GB of DDR3 RAM. It also has 8 200 GB server-grade SSDs on a RAID6.

    We're going experiment with a Linux based system since this is using Win7 Pro 64-bit. We'll try MineOS here soon and I'll share the results. For science.
     
  5. DrDurandal

    DrDurandal New Member

    Keep in mind single threaded performance > more cores for MC.

    Look forward to your results.
     
  6. grandrolf

    grandrolf Global moderator Team Member Global Moderator Trusted User

    Host is forcing time-sync on the guest, either configure (should be able to do that), the service or the easiest way:

    Turn off "Time synchronization" (integration services), on that VM - either using Hyper-V manager, vmm or PowerShell.

    And configure time sync to run on the guest less often, and not from the host.

    EDIT: question - have you turned on the raid controller instead of using storage spaces, or are you just having the raid controller in pass-through and using storage spaces? <-- has nothing to do with your issues with MC, just curious. :)
     

Share This Page