AE2 Can't keep up?

Discussion in 'Mod Discussion' started by MacSkills, Oct 27, 2014.

  1. MacSkills

    MacSkills New Member

    Hello,

    I just made my ore processing a little bit bigger.

    Just 4 redstone furnaces and pulverizers doing all the ore processing.

    I dumped all the ores that i had in Deep storage units into to the system so all the machines are busy.

    I have about 7-8 dense cable lines to all kinds of machines and things like automatic crafting, auto inscibers, storage drives etc.

    I have acceleration cards in all the auto ore processing machines (in and output).

    The problem i have now is that it looks like it cant keep up with in and output.

    The output slots fill up to 64 and the system wont put any ores/dusts in the machines after some time (1-30 seconds) it puts in the ores/dusts and imports the items into the system, this is not happening all the time, then this machine is slow, then 3 stop working (read: stop inputting and outputting items).

    i did the /cofh tps command but there is no lag, everything is working fine except the system.

    What could cause this problem, is it just overloaded with stuff to do, or does the system need more power? or is it just to big with to many import/export/interfaces?

    I maxed out only 1 dense cable (32 channels) and thats the one with the ore processing, got 4 pulverizers and 4 furnaces auto processing and 4 pulverizers and 4 furnaces for auto crafting/on demand processing, that makes 16x1 import 8x1export and 8 interfaces.
    Machines operate at max speed (resonant + the 3 speed upgrades)
    But that shouldnt matter because if it cant keep up importing into the system it should at least keep up with the export into the machines.
     
    Last edited: Oct 27, 2014
  2. madnewmy

    madnewmy New Member

    do you have a controller?

    Try having only 3 accel card per bus
     
  3. ratchet freak

    ratchet freak Well-Known Member

    TE machines can auto output into other inventories; use that to have them export into interfaces
     
  4. MacSkills

    MacSkills New Member

    Yes i have a controller (its AE2 btw)
    I already have 3 cards per bus, that didnt work.

    I just logged on and now its doing nothing at all :S really strange, i can access the system/items but its not processing anything and there are still ores and dusts in the system, also there are some ingots in the machines that are not getting imported, really strange.

    While i was typing things were starting again but still with delays (big delays) At this moment only 4 pulverizers and 4 furnaces are in use (8 export busses and 8 imports) thats it, there is nothing else in the system that is doing something.[DOUBLEPOST=1414514949][/DOUBLEPOST]Hm, i think i found the 'problem' i disconnected 1 dense cable line with 18 channels, this is the last thing i added to the system

    its 4 Metallurgic infusers with 1 export, 1 import and 1 interface each. The export busses are exporting Compressed redstone etc into each one constantly (untill its full ofcourse)
    I dont know what the specific problem is.
    Also on that line there is a automated induction smelter, interface + import and a enrichment chamber (for the compressed redstone etc) with 1 interface and 1 import.
    And 1 sagmill with 1 interface + 1 import.
    That makes 18 channels.

    I think it might be the export busses on the metallurgic infusers but i dont know for sure and i dont know why that would be an issue.

    any suggestions?[DOUBLEPOST=1414515247][/DOUBLEPOST]Edit 3,

    I connected the line with the 18 channels again and it looks like its still doing fine, thats really weird, before this i already drained the power of the system and 'restarted' it again and that didnt work.

    I requested some items that are made with the metallurgic infusers and its still working fine.

    Thanks for the responses though, if i run into the problem again i will let you know
     
    Last edited: Oct 28, 2014
  5. ljfa

    ljfa New Member

    By the way: AE2 import and export buses accelerate gradually while they're working: They start out real slow, but after a while without acceleration cards they move like 3 or 4 items per second. The acceleration cards increase the stack size. Is that maybe causing you problems?
     
  6. Wraith

    Wraith New Member

    I'm also experiencing issues with import / export buses. I've attributed this to a maximum number of buses being able to work in the system. Once I reach a certain number, the entire system backs up and stops working (much as you describe). I've tried using ME Interfaces to solve the problems, but that too is failing. I think I'm going to be forced to build a second processing ME system, and import the ingots into the main system unless I can find a way to solve the problem. I have over 1000 channels still free in my system to use, so through a very thorough diagnostic troubleshooting I've definitely narrowed the problem down to the buses, but have yet to find a solution.
     
  7. Beleriond01

    Beleriond01 New Member

    I don't claim to be an expert at all in AE2 yet judging from what I've seen Fireball do on stream and the space stations he's built on FC2 over the past 2 seasons, I'd imagine it must be something in your system(s).

    Fireball has huuuuuuuuge systems with literally towers and towers of auto crafting and assembler/interface setups, God knows how many import/export buses, etc. and it seems to be working quite fine. Perhaps putting your problem to him might be an option???

    Bel*.
     
  8. dragonmaster0283

    dragonmaster0283 New Member

    I guess another thing to ask is, do you have enough AE power. If your overloading your AE network power it will stop or grind to a halt. All those exporting/importing uses ticks of power. If your doing a lot, i recommond at least 1 dense energy cell to have (using only just an energy acceptor has limits). Also the more P2P tunneling you have, the less responsive the network can be (hypno from hermitcraft experienced a slowdown with the AE network using just 3 p2p subnetworking groups.
     
  9. Wraith

    Wraith New Member

    You know I never even considered it a power issue, as I have 6 turbines powering my base, but you make a very valid point that perhaps it's not delivering enough power at the time it's needed to run all the buses. I think it's time to upgrade to a few dense cells to see if that solves it. Thanks so much for all the advice. Y'all have been most helpful.

    One more question, do you know if there is a limit to how much power an ME Controller can accept? I presume a grid of Dense Cells would deliver uniform power to the controller, but I can't seem to find what the maximum power delivery/receipt is.
     
    Last edited: Apr 17, 2015
  10. GreenZombie

    GreenZombie New Member

    Given the energy requirements of AE spatial storage, I don't believe there is any limit to how many AE a Energy cell can deliver to a network. You can drain a bank of dense energy cells in a single tick if you were extravagant enough.
     
  11. ratchet freak

    ratchet freak Well-Known Member

    The limit is what you can export most of the time, however you can add more power acceptors on the network connected to the power network.
     
  12. Wraith

    Wraith New Member

    Do you know if Dense Cells require channels? I tried to place them inline after the P2P tunnel and it seems to interfere. I set several up before the energy acceptors but those don't seem to register at the machines so I'm not sure how best to use them. Resources are no issue so I could in theory match my turbine RF power storage (12 billion surplus with Vibrants- yes I like to go big) but I'm not sure how best to integrate that into the system.
     
  13. ScottulusMaximus

    ScottulusMaximus New Member

    Power In---Energy Acceptor----Energy Cell----System

    They store AE power, no they don't use channels
     

Share This Page