Adding Plugins to Infinity?

Discussion in 'Server Tech Support' started by BobSagwet3000, Mar 22, 2016.

  1. I get it.
    There's no .jar
    I'm not a genius when it comes to running servers. At all.

    All I want to do is add RPG like stats to my server.
    I don't care what the plugin is named. I just want it all to work.
    I don't care about permissions and all that other junk. It's just a few buds and myself playing periodically.

    Just tell me how to get something like that on my server. Real nice and easy like.
    And I'll leave peacefully. :confused:

    Thank you.
     
  2. Connor Gavitt

    Connor Gavitt New Member

  3. Connor Gavitt

    Connor Gavitt New Member

    Side note, you need to OP all your friends or you will have to mess with permissions.
     
  4. Not working, appreciate the help though.
    The server starts fine using the dl'ed cauldron, but I've tried three different versions of mcMMO and they don't work. Yes, it is in the "Plugins" folder.
    Any ideas? This is pretty much the only plugin I want to work.

    **It also generates the configurations files and folders in the plugin folder. Sadly, the plugin doesn't show up at all in game nor do commands work.
     
    Last edited: Mar 23, 2016
  5. mc.crab

    mc.crab Well-Known Member

    Which version of Infinity are you running and which version of Cauldron have you downlaoded.
     
  6. Henry Link

    Henry Link Popular Member

    Also, if you are just after stats is it something more than the stats system the is built into the infinity pack?
     
  7. Connor Gavitt

    Connor Gavitt New Member

    It's your job to ensure that the version of the game, the game version that the cauldron.jar you're using, and the game version of the plugin that you're using is all compatible. On the site where you download these it will go into detail about what game versions are supported. Not all latest plugins will work on cauldron because it is usually 1.7.10.
     
  8. FTB Infinity 2.4.2
    Cauldron (Whatever version was on the one Connor gave) Can't find any version number.

    And apparently, by Connor's logic, mcMMO doesn't have anything that works with MC 1.7.1 which would be odd.

    I'm just looking for a decent plugin that has stats for fighting/mining/chopping and etc.
    Nothing complicated.

    Any help is appreciated.
     
  9. mc.crab

    mc.crab Well-Known Member

  10. KCauldron version 1.7.10-1614.201
    Forge version 10.13.4.1614
    mcMMO version 1.5.05 AND trying 1.5.0

    Didn't work. No mcMMO chat messages or things work. When the server was started using Kcauldron, it made new config files for the mcMMO. I tried chopping down trees and etc to no avail.

    So, a part of the server recognizes that config files and folders for the plugin needed to be made, but the game and server doesn't use them.
     
    Last edited: Mar 26, 2016
  11. mc.crab

    mc.crab Well-Known Member

    Can you post the server log?
     
  12. Found the specific part when it enables it, shows the errors, then disables it.

    http://pastebin.com/UsqMHhb0

    Have at it, man. I appreciate the help.
     
  13. mc.crab

    mc.crab Well-Known Member

    Is it the same error with version 1.5.0? You could try with version 1.4.08 or even 1.4.07.
     
  14. Just finished running those. Even tried the Heros plugin which is another rpg like plugin. Says it couldn't load that one properly either.
     
  15. Connor Gavitt

    Connor Gavitt New Member

    Mcmmo is no longer actively updated and the most recent game version it supports is 1.7.4 as stated on it's bukkit dev page that you download it from @BobSagwet3000

    http://lmgtfy.com/?q=skill+plugin+spigot

    Cauldron or kcauldron did successfully load correctly or it wouldn't try to enable the plugin so the issue here is finding a plugin that is compatable with cauldron, game version, and mods.
     
  16. Thank you, that's why I even tried Heroes. Such a picky system when all you want is something so simple.

    I'll keep looking around and testing different plugins.

    I'm pretty sure the cauldron version is right, but alot of these bukkit plugins say 1.7.2. Not much have 1.7.1 listed.
     
  17. Connor Gavitt

    Connor Gavitt New Member

    Look for 1.7.10, or some plugins made for 1.8 can work on 1.7, royalcommands for example was made for 1.3 several years ago and still works just dandy on the latest versions.
     
  18. From some testing I've found out that by adding essentials, it recognizes mcMMO and even feeds back what the help commands are for the plugin, but when typing in those commands there is no error message or feedback.

    I've found out that the latest versions of Races&Classes or RPGEssentials work with zero issues from what I can see. Sadly, RPGEssentials is massively out of date and is only viable for vanilla items.

    I'll keep trying different versions of mcMMO. I'll start from the bottom if I have to.
    I just want to use that one because it seems like the most "expansive" of the rpg plugins.
    Races&Classes will be my go to if mcMMO doesn't work at all.

    **UPDATE**
    Just found out mcMMO version 1.3.09 works.
    I'll keep going up in version numbers until it stops working.

    **UPDATE 2**
    mcMMO 1.4.06 is the highest version that works. Apparently something seriously changed in the newer versions.
    The only issue I have now is understanding how to get other mods to work with mcMMO.
    Tons of pastebin configuration files.
    ???yml files????
    I don't understand what do do with the information given if it should be all pasted into a notepad file or what.
     
    Last edited: Mar 29, 2016
    Connor Gavitt likes this.

Share This Page