100% CPU Usage Caused by root.tick.textures

Status
Not open for further replies.

tsani

New Member
Jul 29, 2019
4
0
1
Hello everyone, this is my first post!

I had taken a break from FTB in order to study for finals and upon returning to the the game, I've been experiencing a pretty frustrating problem that I really can't seem to solve. I've narrowed it down to:
  • It's definitely a client-side problem.
  • The problem isn't with java itself (I've tried downgrading Java 7, using Java 6, using Sun's Java instead of OpenJDK, all to no avail.)
  • The problem is with FTB, as vanilla Minecraft has normal performance, and tick.textures isn't taking up 96% of Minecraft's CPU time.
I've searched everywhere to find another post of someone with this problem, and it doesn't seem like anyone has. The result of the problem is that Minecraft's java process takes up all my CPU and that the game becomes completely unplayable at around 2 fps.
The FTB launcher's output doesn't show anything indicating that a particular mod is causing some kind of error.
I usually run Linux on this computer, and the performance used to be much better than on Windows, but now the Windows performance in slightly better (around 18 fps.)
The output of lshw, for my computer specs: http://pastebin.com/8Y02QMk8

I've also tried running older versions of the modpack, but they also suffer from this inexplicable lag.
The FTB console window lists loads of messages like these:
Code:
2013-05-28 13:22:41 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 465.257237 ms
2013-05-28 13:22:41 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 527.424288 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 523.661556 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 589.003542 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 554.489271 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 618.544901 ms
2013-05-28 13:22:43 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 498.309829 ms
2013-05-28 13:22:43 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 555.100591 ms
2013-05-28 13:22:43 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 520.900869 ms
Here're some screenshots of the ingame profiler pie-chart:



Right now the tick portion of the pie-chart is only filling 60% of the graph, but as time progresses, it will eventually fill roughly 90% of the graph. At a standstill in singleplayer, I get only 2 fps.
If there're any other logs or information you might need to help me out, I'll gladly provide them. I'd really like this issue to be fixed.
Cheers

EDIT: Some modpacks work fine while others have the intense lag caused by texture updates. Very laggy packs are:
  • FTB Ultimate
  • Direwolf20
  • Yogcraft
Whereas packs that work fine are:
  • New World
  • FTB Lite
  • Voxel (it doesn't add much, so this information isn't so useful though.)
  • Tech World
 

Nessiroj

New Member
Jul 29, 2019
855
0
0
A quick overview about the problem and the actual packs that work is that the 3 that don't work have way more mods installed then the onces that have no problem.

Lag, being it from ticks or otherwise is always really hard to debunk. Do you run client and server on the same machine (ea are you playing SSP)? Moving the actual server to an other machine often helps alot.

Minecraft still is and will be for quiet abit be a CPU intense game.
 

tsani

New Member
Jul 29, 2019
4
0
1
The lag is just as bad in SSP as in SMP. What's odd is that FTB Ultimate used to run fine on this computer, but suddenly, it has become unplayable. Could it be a Linux kernel update that messed it up? I hear that Java's performance sometimes varies greatly from one kernel to the next, but downgrading the kernel to play Minecraft doesn't sound like a great solution.

As for Minecraft being CPU-intensive, maybe I just need a new computer. :(
 

Nessiroj

New Member
Jul 29, 2019
855
0
0
Just on an other forum i saw somthing that might be related to this problem. Could you make a output of the console to pastebin.com
i'm curious in the part before
Code:
2013-05-28 13:22:41 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 465.257237 ms
2013-05-28 13:22:41 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 527.424288 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 523.661556 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 589.003542 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 554.489271 ms
2013-05-28 13:22:42 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 618.544901 ms
2013-05-28 13:22:43 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 498.309829 ms
2013-05-28 13:22:43 [INFO] [STDOUT] Something's taking too long! 'root' took aprox 555.100591 ms
2013-05-28 13:22:43 [INFO] [STDOUT] Something's taking too long! 'root.tick' took aprox 520.900869 ms
 
Status
Not open for further replies.