[1.7.10] Texturing problem

Discussion in 'Mod Development' started by lucariomaster2, May 5, 2017.

  1. lucariomaster2

    lucariomaster2 New Member

    Preface: Yes, 1.7.10. I am making a mod to fill in some gaps in my current world and for my friend's server, which both run 1.7.10 because some of the mods they rely on have not updated. Anyway...

    I've been trying to write a mod to add some automation utilities - odds and ends that I feel should exist but don't. So far it has one block, and functionally it works perfectly. The thing is that no matter what I do, it refuses to load the proper texture. I have the 16x16 PNG file in the resources/assets/autoutils/textures/blocks directory, but it still shows the purple and black checkerboard. I also got the following error in the console:

    Code:
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: The following texture errors were found.
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:   DOMAIN minecraft
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: --------------------------------------------------
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:   domain minecraft is missing 1 texture
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:     domain minecraft has 3 locations:
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:       unknown resourcepack type net.minecraft.client.resources.DefaultResourcePack : Default
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:       mod FML resources at /home/<my username>/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.10-10.13.4.1614-1.7.10/forgeSrc-1.7.10-10.13.4.1614-1.7.10.jar
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:       mod Forge resources at /home/<my username>/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.10-10.13.4.1614-1.7.10/forgeSrc-1.7.10-10.13.4.1614-1.7.10.jar
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:     The missing resources for domain minecraft are:
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:       textures/blocks/stackmover.png
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]:     No other errors exist for domain minecraft
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
    [19:00:14] [Client thread/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
    It's reporting that the texture file is missing, even though it's there. Even stranger to me is that the lang file works fine, so it's not a matter of the resources or assets directories being in the wrong place. I downloaded and compiled Pahimar's 1.7.10 LMRB, and his textures worked.

    I have no idea which Java class has the mistake, but if anyone wants to look at it, here's the code.

    I'm sure I'm missing something incredibly obvious, but I'm completely stumped. I would love it if someone could help me.
     
  2. SatanicSanta

    SatanicSanta New Member

    Why have you commented out BlockStackMover#registerBlockIcons(IIconRegister)? You need that IIRC.
     
  3. lucariomaster2

    lucariomaster2 New Member

    Un-commented registerBlockIcons and changed the registerIcon arguments to point to stackmover.png, but it's still giving the same error.
     
  4. SatanicSanta

    SatanicSanta New Member

    It has to be a proper RL represented by a String. For example, iiconregister.registerIcon("steamcraft:blockBrass"). In the code at that repo you are not including the modid, so it is defaulting to "minecraft".
     
    Brotuulaan and lucariomaster2 like this.
  5. lucariomaster2

    lucariomaster2 New Member

    Ah, that's what it was. Probably never would have figured it out myself; thank you! I assume item icons and entity textures follow the same rule?
     
    SatanicSanta likes this.
  6. SatanicSanta

    SatanicSanta New Member

    Yes.
     

Share This Page