1.5.0: Diamond Spikes Deleting Items

Discussion in 'FTB Presents Direwolf20 1.7.10' started by mellamokb, Sep 26, 2015.

  1. mellamokb

    mellamokb New Member

    Version:
    1.5.0

    What is the bug:
    I thought this was just a fluke, but it has happened three separate times now. I have a mob spawner system based on cursed earth/spawners that drops mobs onto 16 diamond spikes enchanted with Looting III/Sharpness V. Then there are two vacuum hoppers that suck up the items/XP and deliver into Tesseracts.

    As of today I have lost three items at different times. Usually I am breaking an item near the spikes, which then gets sucked toward the vacuum hoppers. But then when I check my ME system, the item is not in there, it's not in my inventory, it's not anywhere. I even turn on my Ender IO magnet to see if it dropped somewhere and I can't find it.

    - Two days ago I lost a Diamond Spike (!) this way.
    - Today I've lost a Resonant Exchanger and Enderman Safari Net this way.

    I'm not sure what causes this. 99% of the items get picked up by the vacuum hopper just fine and pulled into the ME system. According to the documentation, Diamond Spikes are not supposed to destroy items. Why am I losing these items??

    Here is a picture of the mob killer causing the issues:

    [​IMG]

    Mod & Version:
    ExtraUtils

    Paste.feed-the-beast.com log:


    Can it be repeated:
    I haven't tried to repeat it on demand. If I break a bunch of items near the diamond spike/vacuum hopper area I will probably lose a couple.

    Known Fix:
     
  2. Trisscar

    Trisscar New Member

    Hum. Ok, so I personally suspect this has to do with the weird jumpy interaction between the way the vacuum sucks in items and how the spikes seem to affect where items land. May I suggest testing an overgrowth grassed hopperhock from Botania (cheat it in if you don't have the necessary stuff, or you'll be waiting or searching for hours to get the overgrowth seed), since the hopperhock just teleports the items into an adjoining chest rather than moving them to it slowly.
    Other ways to move items you could try are the vacuum chest from Ender IO, and using the daffomill from Botania to push all the items to hoppers around the edges.
     
  3. BrickVoid

    BrickVoid Well-Known Member

    It's interesting to note that wiki documentation for the vacuum hopper says it only has a range of three blocks. Have you tried positioning it more centrally to the 4x4 area you're trying to have items sucked in from? It would appear from where the hopper is located, that it can't reach all of the drops that land near it, and it's possible that this is your problem. I had similar problems trying to use a vacuum hopper in FTB Infinity, it definitely sounds like the range on the vacuum hopper is too short, as if items landed more than three tiles away from it, it couldn't suck them in.

    Even upgrading to an ordinary hopperhock from Botania would be a big improvement, as that would mean it'd simply suck - or teleport in the hopperhock's case - items in from a longer range.

    Cheers ...

    BrickVoid
     
  4. mellamokb

    mellamokb New Member

    It's hard to see it in the screenshot, but there is a second vacuum hopper on the right side as well to help cover the whole range. I positioned them carefully so they wouldn't allow items to get "stuck" floating in the middle equally interacted by both vacuum hoppers, which is another problem I've had. I'm not real familiar with Botania so I might try the Ender IO chest and see if that helps. Thanks!
     
  5. mellamokb

    mellamokb New Member

    I too suspect there is something odd going on there. Very often when I walk around the outside of the drop area, I will collect items that have gone "outside" of the drop area completely and appear to be stuck inside of the bricks immediately under the vacuum hopper. The vacuum hopper can never pick them up, but I can when I walk underneath. I thought about opening up the bottom row so items can flow freely through, but then I have to deal with baby zombies who are able to get out of the drop area.

    As far as the original problem goes, are you thinking that items are ending somewhere very different, like underground below the drop area or something? I knew about the problems I was having when I "lost" my items, so I searched all around the drop area with my Ender IO magnet, including going inside the spawner room from the top, and walking around the outside. I didn't find any of the three items I lost anywhere around there and I don't know where else they could have gone except somewhere completely out of reach or stuck inside of a block??
     
  6. BrickVoid

    BrickVoid Well-Known Member

    I don't know if you have access to them, but have you tried Extra Utilities Item Transfer Nodes with World Interaction Upgrades installed? Extra Utilities is easy enough to do for collection of item drops although personally I prefer to grind mobs using an MFR Grinder because it will automatically collect and spit out the drops into an adjacent chest or connected pipe system.

    Cheers ...

    BrickVoid
     
    Henry Link likes this.
  7. Trisscar

    Trisscar New Member

    Ehh, you look like you have a half a blocks worth of space between the tops of the spikes and the bottoms of those slabs already, so that might be enough.
    I've actually had items get stuck in between spikes and just sit there when I've used vacuum hoppers before, occasionally twitching madly or maybe getting unstuck somehow. Don't forget that time limit on items on the ground, so it's entirely possible that your missing items have despawned already.
    I really do recommend Botania though. The hopperhocks alone are amazing for item transfer, and they're pretty low down on the tech tree, plus the adjoining book describes things very well.
     
  8. mellamokb

    mellamokb New Member

    I've actually ended up going with the EnderIO Vacuum Chest.. Although I do still have a couple vacuum hoppers (with item area filled up to prevent item pickup) to pick up the XP drops and push them into a tesseract. So far so good! Thanks for all the suggestions.
    Cheers,
    ~ mellamokb
     

Share This Page