1.0.3: Quarry stops mining after a few minutes

Discussion in 'FTB Presents Direwolf20 1.7.10' started by Jordan Kothe, Jan 22, 2015.

  1. Jordan Kothe

    Jordan Kothe New Member

    Version:
    1.0.3

    What is the bug:
    I have a BuildCraft Quarry set up properly (i've set up quite a few quarries with no problem). The problem is when I go AFK near the quarry and/or leave the area and come back after about five or ten minutes the quarry repetitively mines the same area as if breaking invisible blocks. This is not the vanilla server/client disagreement because placing blocks in the area the drill is trying to mine does not affect it's operation (however it breaks the new blocks without deviating from it's 5-10 block loop).

    Extra info:
    Shaders and optifine are installed
    I get 45+ fps
    I am playing single player, opening to LAN has no affect either
    I have biomes O plenty turned on

    Mod & Version:
    buildcraft

    Paste.feed-the-beast.com log:


    Can it be repeated:
    yes, it has happened several times on different quarries (all in the overworld) and with different setups

    Known Fix:
    Logging in and out works all the time but I would like it to run over night or while I am at school etc. Sometimes (1/10 times) if the drill goes to break a block far away where it has been before (ie higher up in the quarry) it will get out of the looping and continue mining
     
  2. Dannyaaaa

    Dannyaaaa New Member

    I'm not very good a troubleshooting, but have you tried AFKing in the center of the quarry? I used to have that problem 1.2.5 and going to the middle of the quarry would fix it.
     
  3. Voyager_sput

    Voyager_sput New Member

    I've noticed the same behaviour, babysitting a quarry by staying AFK above it works most of the time, but not always. It still gets stuck. I also tried with a chunkloader to force load the chunks of the quarry, but no change.
     
  4. Sen-Mithrarin

    Sen-Mithrarin New Member

    You may miss propper chunk-loading ! A BC-quarry only loads chunks it is in. If you have power-supply and/or ore-proccessing outside of loaded chunk (use /chunkloaders command and/or hit F9 twice to see chunk boundaries) these will unload and the quarry gets backlogt. To avoid this always place a chunkloader near quarry to keep adjacent chunks for proccessing and/or power-supply loaded.
    Otherwise it seems you do something else horrible wrong cause I never got such problems with any version of DW20 1.7.10 pack.
     
  5. Trisscar

    Trisscar New Member

    This makes me slightly curious. Have you tried using an Ender Quarry yet, and if so does it display the same behavior?
     
  6. Voyager_sput

    Voyager_sput New Member

    As i already said above, I already thought of that, the /chunkloaders screen already showed me that the BC Quarry doesn't chunk load even though it says so when you place it. I believe i read somewhere that the BC people disabled this functionality for the time being.

    But even with a Chickenchunks chunkloader keeping a area loaded much bigger then the quarry it still gets stuck on the ghost blocks it keeps on trying to come back to break. Only fix is stop the game and restart it. Then it suddenly behaves again, at least for a little while. I don't use Optifine and play single player by the way.

    Not to steal the OP's topic, just trying to help out :)
     
  7. Sen-Mithrarin

    Sen-Mithrarin New Member

    As for me I really can't re-confirm your claims. For me BC-quarry correctly does chunkloading. I've set-up a test-area in a mystcraft-age on my server, and used the quarry to chunkload creative ae-system and power ... and it fully collected a whole 4 by 4 chunk area without any issues.
     
  8. Trisscar

    Trisscar New Member

    Bugs aren't a evenly spread thing Sen, they don't always appear for everyone, as this forum can attest. XD
    Would really like to know if ender quarry causes similar issues though.
     
  9. Rupnerd

    Rupnerd New Member

    i can confirm this bug, but it does not happen all the times. i had a quarry on a server running on a standard size which worked perfectly (everything in 1 chunk) afterwards i just replaced it with a bigger size to mine and it get's stuck after a while (restart gets it fixed, but it reapers). Also on my server which i play with a friend it worked 2 times with not standard size but just a bit bigger (we then changed to ender-quarry). On a previous server which also was running on 1.0.3 it had the same issue already the first time (max size with markers). maybe it's an issue with the size or the time he needs to mine to bedrock which is kind of depending on the size xD
     
  10. Erro

    Erro New Member

    I noticed this bug today as well, DireWolf20 1.7.10 single player. The quarry arm kept trying to dig 3 phantom blocks. I dug the three blocks directly underneath where the quarry arm was & this fixed the issue. I have a typical setup where the quarry is hooked up to an ender chest which is loaded in the same chunk. After moving away from the quarry & back to my base, the quarry yet again stopped sending new blocks into the ender chest, but resumed as normal when I came back to it.
     
  11. Trisscar

    Trisscar New Member

    May or may not be related. My ender quarry has been mining huge chunks of the Deep Dark for a while, without issue. But now is has suddenly gotten stuck mining a specific coord that, when I dug down to it, it had already mined and then replaced with dirt. It refuses to move past the block, even after I manually removed it and then restarted the world. I'll try restarting the pack itself next.

    Edit; Nope, restarting the pack didn't work. Neither did going out a ways to reload the chunk. I should probably add, this block is at y=41, so it's below ground and therefore not a aura node or something. Also, I've had it mine a LOT of stuff in the DD up to this point, so I'm relatively certain that I've run into every type of block down there before. Also, I've picked up and replaced the EQ and it started to scan the blocks from the beginning, so hopefully it won't get stuck again.
     
    Last edited: Feb 19, 2015
  12. Sen-Mithrarin

    Sen-Mithrarin New Member

    Also another note from my side : you guys keep talking about "ghost blocks" and I'm really not sure what you mean by it, as I can't re-produce anything like it.
     
  13. Trisscar

    Trisscar New Member

    My quarry still hasn't gotten back to the block yet, after 6+ hours of runtime. It's a REALLY big area. XD
    I think by ghost blocks it's meant that you can't see what it's trying to mine, but it's still acting like it's mining something over and over again.
     
  14. Sen-Mithrarin

    Sen-Mithrarin New Member

    Well, with a "vanilla" BC-Quarry you only can mine a max of 64 by 64 Blocks, or 4 by 4 chunks at once. Even starting at the very top of around Y-level 250 wouldn't take that much time to get it done, or at least : on my server it didn't took so long.

    As for the "ghosty ghost blocks" : maybe it's a fault in the "area-scanning-code" where already mined blocks, or fallen down ones like gravel, sand and others, didn't get re-scanned and therefore the mine()-method may return some odd value wich makes the rest of the code thinks something failed and it re-tries to mine the same block over again. It wouldn't surprise me if it's such a beginners-grade fault as I've seen so much bullshit in some of the mods codes I ask myself : how this even compile or run together at all.
     
  15. 10pm

    10pm New Member

    It seems to be an issue with bc and ender quarry
     
  16. Sen-Mithrarin

    Sen-Mithrarin New Member

    Possible true as some of the "ender"-called mods like Ender-IO have some really odd other issues like messed up energy-net.
     
  17. 10pm

    10pm New Member

    I wouldn say that...the name doesn't imply bad coding. otherwise is the enderquarry from Extra Utilities and i see no "ender" in that mod name
     
  18. Trisscar

    Trisscar New Member

    Besides, the ender quarry has mined so much gravel down in the deeps that I had to set up a void barrel for it after a while, and this ghost block silliness only happened recently. Doesn't make it an impossible cause, but does make it less likely.
     
  19. Trisscar

    Trisscar New Member

    New thing, I've been noticing vanilla flowers appearing in the DD, even in areas where there isn't enough light level for them to stay put normally. But only where my ender quarry is currently going over the dirt blocks it had already mined over again, and not every column there either. It's quite pretty, but I wasn't aware gardening was a function of this type of quarry. XD
     
  20. Sen-Mithrarin

    Sen-Mithrarin New Member

    Hey dudes, IT HAPPENED !

    Yes, I don't know whats really happend, but I will tell you the story :

    This evening my buddy called me : Hey dude, can you please restart the server ?
    My awnser : Sure, but why ?
    Buddy : The BC-Quarry behaves really odd.
    Me : What kind of "odd" ?
    He : It tries to mine rows wich already mined.

    Suddenly I remembered : Hey, what was this thread on FTB-forum all about again ?

    So I asked him : Do you know anything what might happend ?
    And his awnser really surprised me : There was some MFR-sewage I removed with a bucket.
    And : "DING, fries are done !". I remembered some odd behaviour of MFR, not just fluids or machines, but also some random world-gen.

    A quick server-restarted somehow fixed the bug, the quarry just ran perfectly again. But suddenly there was another bug : the built-in chunk-loading-mechanic doesn't loaded the quarry on server start-up. Looking up with the /chunkloaders command proofed : there was no more chunk-loading. We didn't replaced the quarry as it was almost done (down to Y-level 20 or so), so we just placed a chicken-chunkloader added by server-command to let it finish it's job.


    So we both come to the plan : maybe it's some odd bug caused by incompatible code from chicken-chunks. Maybe also some MFT-stuff (as MFR by itsefl is fine, but has some problems with other mods) mixed in.

    Hope this helps a bit to track down this wired issue.
     

Share This Page