1.0.2: Phaser Rifle Creation crash on Daybreaker 1.2.0

Discussion in 'Horizons: Daybreaker' started by Dr. inohk, Jun 10, 2016.

  1. Dr. inohk

    Dr. inohk New Member

    Version:
    1.0.2

    What is the bug:
    Whenever someone on my friends server creates a Phaser Rifle the game crashes and they cannot log in to the server again without crashing.

    Mod & Version:
    Matter Overdrive Release Candidate 4

    Paste.feed-the-beast.com log:
    http://paste.feed-the-beast.com/view/3b4757b8

    Can it be repeated:
    It can. This has happened to everyone on this server who has yet attempted crafting the Rifle and I have had to given the instructions on how to fix it every time.

    One must simple join a server and attempt to craft a Phaser Rifle and watch in glory as you crash to desktop.

    Additionally this issue has been reported to the mod creator by multiple users, one of the posts found here: https://github.com/simeonradivoev/MatterOverdrive/issues/325

    Known Fix:
    I know of 3 solutions:
    Method 1:
    1. Install newer version(we used the full release of 0.4.0 as it is closest to the version the modpack maintainers use) of Matter Overdrive into client, renaming the file to disguise it as the older version
    2. Join the server and mess with the Rifle until server crashes
    3. When server crashes, close minecraft and reinstall the old version of the mod. Restart the server
    4. Repeat for every user who wishes to make a Phaser Rifle
    The issue with this method is that it must crash the server, or at least is very likely to and is as such not a good solution. This also involves actually updating the mod, a process many users don't know how to do hence the use of the launcher to do it for them.

    Method 2:
    1. Update the mod on the server
    2. Ask every new player to update the mod themselves
    The issue with this method is that, like Method 1, it requires potentially not advanced users to manually update the mod.

    Method 3:
    1. Ask the Feed The Beast staff to update Daybreaker with the newer version of the mod and set it as recommended.
    I do believe this is the best solution to the problem as most users would see the update prompt and feel a need to update, solving the issue with numbers 1 and 2 and even providing many new features not currently available in the version given.
     

Share This Page