1.0.2: Crash on creation of new world (FIXED in 1.0.3)

Discussion in 'FTB Presents Direwolf20 1.7.10' started by Yaeger, Nov 30, 2014.

  1. Lumartist

    Lumartist New Member

    Hello everyone,

    I registered an account just to tell you what I have done, after I had the same error today. As someone earlier said, the world has to be generated with Biomes o plenty. So what I did, after some research, I added this to my server.properties:

    level-type=BIOMESOP

    After this the world generation worked without a problem. Just make sure, that you replace level-type if already there, or change just the value. Also you might need to delete older worlds, if they're having the same name.

    Hope this helps some of you! :)
     
  2. Yaeger

    Yaeger New Member

    I just teste this, and this seems to be fixed in version 1.0.3 of the modpack.
     
  3. Sphinx2k

    Sphinx2k New Member

    Anyone found a good fix for this error?
    We have this Problem on our Server. There are two areas that crash the server when you come near to close to them. I Updated everything to 1.0.3, still the same error. I deleted the Chunks, when the are generated again -> crash.
    What i can see in MC Edit is that in both areas are villages (other Villages work fine on the Server).
    I would love to get this fixed but can't figure out what is source of this error.

    Server Log
    http://pastebin.com/qTpUyv6C
    FML Error:
    [12:54:27] [Server thread/DEBUG] [FML/]: Gathering id map for writing to world save world
     
  4. Yaeger

    Yaeger New Member

    The problem I originally had was on creation of a new world, not on loading an older one. So an update won't fix an already corrupted / broken world, I think.
     
  5. Sphinx2k

    Sphinx2k New Member

    So i spend some more time testing.
    I tryed a lot with MC edit and the areas that crash the server with the above message. And can reconstruct what is happening:
    First the World Gen generates the terrain -> Works normal
    The Chunk is then marked as "not populated", this means that when the chunk is loaded (a player comes close enough) structures are generated, like villages, caves,...

    This step is causing the crash for me, if i mark the generated chunks as already populated (so the games is not generating structures in them) with MCEdit the server is not crashing. I i can see parts of the buildings in the neighboring chunks, so i am sure it is some kind of building in the village that is causing the crash.
    What mods add buildings is the next step in getting closer to solve this. I know Forestry (Beekeeper House), Thaumcraft, Railcraft, Tinkers construct. Any Mod I am Missing in the DW20 1.7 pack?
    I have seen in the villages that work, Railcraft, Tinkers Construct and Thaumcraft Buildings -> no Beekeepers House so far. Maybe it is not one Mod causing this.

    This is all i got for now, i will continue to test everything.

    ---- Edit ---
    I want to start testing with forestry..is there any way to disable world gen of the Beekeeper in the village?
    btw. found this
    http://www.minecraftforge.net/forum/index.php?topic=13470.0
    1.6 error but it is the same problem
     
    Last edited: Dec 24, 2014
  6. jakehaskins

    jakehaskins New Member

    im not sure if this is a legitimate fix or whether i lucked out but i went into my world save and kept opening every single folder and deleting any file related to world gen (most of the files were "village.dat"). If anyone has a "corrupt" world still would they mind trying this and telling us how it works for you?
     

Share This Page