1.0.1: Nether Quartz not spawning

Discussion in 'FTB Presents Direwolf20 1.7.10' started by MoparDan, Nov 5, 2014.

  1. MoparDan

    MoparDan New Member

    Version:
    1.0.1

    What is the bug:
    nether quartz (vanilla ore) is non-existent.

    Mod & Version:
    Vanilla Minecraft ore generation

    Paste.feed-the-beast.com log:


    Can it be repeated:
    Yes, start a new map, SP or MP, and go into the nether.

    Known Fix:
    None atm.
     
    BladeDancer likes this.
  2. MoparDan

    MoparDan New Member

    It should be noted that BoP is currently disabled on our server.
     
  3. Senseidragon

    Senseidragon Well-Known Member

    DW20, 1.0.1, Went to nether, dug less than 20 blocks from portal...

    Guess what I found?

    Did your server admin maybe tweak the ore configs at all?
     
  4. MoparDan

    MoparDan New Member

    Myself and another person co-manage a very small server.
    The lack of nether quartz was not only on server, but also in SSP (single player).

    No config changes made, but some mods were disabled/added to suite our play style.

    Mods disabled:
    Aroma1997core
    AromaBackup (We use McMyAdmin for this)
    BiblioWoods[BiomesOPlenty]
    BiomesOPlenty
    Opis (disabled by default)
    PneumaticCraft

    Mods added:
    RotaryCraft/DragonAPI
    fastcraft (server side and advised players to add to clients)
    OpenComponents/OpenComputers
    RemainInMotion/Planetguylib
    RandomThings
    RotaryCraft

    The mods added should have no effect with ore gen, but would disabling BoP affect ore gen in the nether?

    Also, we have tried adjusting the vanilla.json file for nether quartz generation, and no effect, eventually set it back to default from a backup.
    And, yes, after each adjustment we fully deleted DIM-1 to force it to regenerate to retest.

    The only fix that did work was changing "ReplaceVanillaGeneration" to false in cofhcore.cfg.

    Lastly, I do need to ask, because I am not 100% sure on vanilla spawn rates for nether quartz, but was the spawn rate turned way down? because there were 0 nether ores visible at all in the nether while we were both flying around.
     
  5. BladeDancer

    BladeDancer New Member

    Yeah, I am having this very same problem.. I disabled BoP and that was it.. I have gone over 2000 meter blocks in each direction, no nether quartz, i run my own server and i don't mess with configs.
    i too also saw direwolf20 had some in his map. I'm running a vanilla map so why would it be any different?
    Hope someone can figure this out.
     
  6. BladeDancer

    BladeDancer New Member

    Im seeing a pattern here, BOP being disabled may be causing this bug to happen. I will gen a new world later with BoP enabled again and will get back to you guys in a bit.
     
  7. BladeDancer

    BladeDancer New Member

    Yeah, its confirmed if anyone hasn't found this already, but I ran a new world with BoP installed and there are nether ore spawns.
    I then disabled BoP and run another new world and dont get nether ore spawns.

    I have figured that much out so far, but not sure what to do about it.
     
  8. Sanaradain

    Sanaradain New Member

    found the solution for those that need it:
    in the /config/cofh/world/Vanilla.json
    change:
    "biomeRestriction": "whitelist",
    "biomes": [
    "hell"
    ],

    to:

    "biomeRestriction": "none",
    "biomes": [
    "all"
    ],
     
  9. BladeDancer

    BladeDancer New Member

    I tried your solution and it did not work. I found that deleting the vanilla.json file forces it to recreate itself upon server restart. It seems a LOT of the files contents was cut out for some reason and the nether quartz was not listed properly. Here is the fix for the Quartz entry if you do not want to delete the file. I now have nether quartz everywhere in a fresh Nether dimension and I don't have to disable the cofhcore overrides. This was really only an issue for people who DN NOT want to use Biomes o Plenty (Like myself.

    "quartz": {
    "template": "uniform",
    "block": "quartz_ore",
    "material": "minecraft:netherrack",
    "clusterSize": 13,
    "numClusters": 16,
    "minHeight": 10,
    "maxHeight": 118,
    "retrogen": "true",
    "biomeRestriction": "whitelist",
    "biomes": [
    {"type": "dictionary", "entry": "NETHER"}
    ],
    "dimensionRestriction": "none",
    "dimensions": []
     
  10. BladeDancer

    BladeDancer New Member

    KEEP in mind the above fix DOES work and is useful for those who do not want to use BoP in their worlds.

    Can a moderator test this and verify then label it as fixed?
     
  11. K4iz0r

    K4iz0r New Member

    This does not work for me.

    Tested it in v1.0.1 and v1.0.2 of the pack (single player)

    Mod's disabled:
    AromaBackup
    BiblioWoods[BiomesOPlenty]
    BiomesOPlenty
    Opis
    PneumaticCraft
    witchery

    Extra mod's:
    Fastcraft
    Veinminer

    Also tested this with Fastcraft disabled, same result (no quartz)
    Is there something else I can try to get the quartz back in the generation proces? I also tried adding BoP and turning everything off in the config files, but there still is all the different plants and stuff in both the overworld and the nether (the two places I checked), and that is part of what I don't want. PC performance is also a small issue.

    I played the entire 1.6 pack not liking BoP... Looked forward to the 1.7 pack, and now I can't turn BoP off.

    Sorry for the message, didn't notice the two post above mine.

    I also removed the vanilla.json file. After restarting the game the file was a lot bigger. Now there is quartz in the nether again.

    I do have another question about this sollution. Does this alter the Ore generation in the pack? Iron, gold and all the other vanilla ores are in this file agian (I only had dirt, gravel and quartz before removing it)
     
    Last edited: Nov 21, 2014
  12. BladeDancer

    BladeDancer New Member

    Yeah, I noticed that too and I'm not sure, but I am also not that concerned about it. They won't spawn in the nether anyway. I doubt it will affect anything in the overworld either. Its just a dimension filter.

    I guess you could take them back out manually, but I'm just leaving mine alone unless I start noticing a change of ore gen, but that should be handled in the world generation config for COFH not the vanilla.json
     
  13. K4iz0r

    K4iz0r New Member

    Even if it does change, that means more iron at lower levels, and the diamonds will be above lava a bit more :p win win. Thanks again for the sollution!
     
  14. MacAisling

    MacAisling Popular Member

    Changing the "overwrite vanilla ore generation" option for the nether from true to false in the COFH config also works. As far as I've seen, nether quartz is the only ore the COFH configs uses a whitelist instead of a blacklist for and is the only ore that has a problem with BoP disabled.
     
  15. Trojan1900

    Trojan1900 New Member

    This doesn't appear to be working for me I have tried this but still no quartz. Do i need to spawn new chunks or will I just need a new world?
     
  16. BladeDancer

    BladeDancer New Member

    I would recommend just deleting the nether dimension from your world folder once youve made the correction. This is because quartz will not spawn in chunks that have already been generated. Just remember to remove anything you want to keep from the nether because you will lose it. Oh and the folder of the nether dimension should be DIM -1
     

Share This Page