1.0.0: Blood Magic recipes not working.

Discussion in 'FTB Presents Direwolf20 1.7.10' started by Desmo360, Mar 17, 2016.

  1. Desmo360

    Desmo360 New Member

    Version:
    1.0.0

    What is the bug:
    I'm hosting a server for this modpack, and everything works fine. But when I try to craft any Blood Magic items, or even look up their recipes, nothing happens. I tried this in single player, and both functions worked, so it seems to be a server based bug.

    So far I've tried removing the jar file for blood magic in the server's mod folder, and replacing it with a fresh copy from my single player files. The items are still accessible via creative but cannot be crafted.

    I've been struggling with this for about a week now. Any insight would be greatly appreciated!

    Mod & Version:
    Blood Magic: Alchemical Wizardry (1.7.10-1.3.3-17)

    Paste.feed-the-beast.com log:


    Can it be repeated:


    Known Fix:
     
  2. Trisscar

    Trisscar Well-Known Member

    Huh. Did you happen to modify the pack at all, like adding server-specific mods?
     
  3. Desmo360

    Desmo360 New Member

    Only change I made was adding a file to the computercraft folder for a program my friend wrote. Besides that I have not touched the configs or anything else.
     
  4. Trisscar

    Trisscar Well-Known Member

    Weird. Ok, can we get a pastebin link (or similar text sharing site) of the server logs?
     
  5. Desmo360

    Desmo360 New Member

  6. Trisscar

    Trisscar Well-Known Member

    Huuuuhh. It would appear that it can't find the recipe. I realize this sounds like something you've said already, but I mean that it knows a recipe should be there, but can't find it.

    I feel like this is going to take a while, and my apologies, but can you try a couple things?
    1. Go onto a server (running a pack with BM, preferably this one) not being hosted by you or whatever you use as a hosting service, and see if the same thing happens. This is to check if it's something to do with your files.
    2. That done, redownload the pack (after backups) and attempt to start the server again. Same issue?
    3.If it's still happening, go to the BM github or forum and see if this has been reported before, and if not, add a report yourself. make sure to mention the pack and what version of said pack and BM is running.
    4.Test a couple other items, and see if this affects more than one mod?

    The thing that interests me most is that you tested it with the Dagger of Sacrifice, which, if my memory is correct, means you used one of the few non-altar created items. So this isn't "NEI can't read the weird altar recipes", it's "NEI can't read the entire mod". Which is weird as hell.
     

Share This Page