Problem World ID mismatch for railcraft

Discussion in 'Server Tech Support' started by Nerdygamer554, Feb 15, 2013.

  1. Nerdygamer554

    Nerdygamer554 New Member

    I am using Windows 7, 64 bit, and I am using Java 7 update 11. I am using my own computer as a host, and am just using localhost for the IP, and everything is port forwarded. I am using the Direwolf20 modpack version 5.0.1. So far I have added no mods to the server.

    I have just downloaded the Direwolf20 modpack server from the website. Everything is port forwarded, the server starts up fine, it's all going well. When I try and join the server I get this " Forge Mod Loader has found world ID mismatches
    World: (ModID: Minecraft, type uv, ordinal 2) Game (ModID: Railcraft, type rc.item.cart.furnace or
    World: (ModID: Minecraft, type uv, ordinal 1) Game (ModID: Railcraft, type rc.item.cart.chest or
    World: (ModID: Minecraft, type uv, ordinal 0) Game (ModID: Railcraft, type rc.item.cart.basic or

    You cannot connect to this server"

    When the "or" part shows up, I cannot see any farther on my screen. On the console it shows me logging in, and then it says I lost connection and I get the message.

    I am a little bit confused about this, and have tried to look up in the railcraft configs, but I have not found anything weird. Any help would be greatly appreciated.
     
  2. dollop_of_mustard

    dollop_of_mustard New Member

    I have the exact same problem. I think the minecart ids in railcraft might be mismatched with the ones in the minecraft.jar in the direwolf20 folder, but you would have to edit the class files of the jar to change the ids. I haven't done this yet so I'm not sure if it works.
     
  3. cjm721

    cjm721 Active Member

    Copy the configs from your client to the server. The ones that come from the download page are messed up.
     

Share This Page