Issue Launching Server From Download

  • Tech Support section is for getting help with FTB related problems. If there's a repeatable issue that can be labeled as a bug, then please use the issue tracker for the pack or the app at GitHub issue trackers - If there's no repository for a pack that means that the pack is old and/or will not be updated. Bugs for older packs will not be fixed, unless they are critical.
  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord
S

skiller185

Guest
Title Issue Launching Server From Download

Launcher Type

Modpack FTB Infinity Evolved Skyblock

Modpack version 1.2.0

Have you modified the pack? No

Link to log file

Details of the issue Here's how things have been going for me each attempt I make at launching ANY version of the server.

1) I download the zipped folder.
2) I unzip the folder.
3) I edit the EULA from "false" to "true".
4) I run the program "FTBInstall.bat".
5) I run the program "ServerStart.bat".

It prompts me with the following message:

Starting server
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=256M; support was removed in 8.0
Java HotSpot(TM) 64-Bit Server VM warning: Using the ParNew young collector with the Serial old collector is deprecated and will likely be removed in a future release
We appear to be missing one or more essential library files.
You will need to add them to your server before FML and Forge will run sucessfully.java.lang.ClassNotFoundException: net.minecraft.launcherwrapper.Launch
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Cladd.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:25)
at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLauncherWrapper.java:12)
Exiting...
Press any key to continue...


What do I do?
How do I fix this?

P.S. I typed out the console output by hand.
 
Last edited by a moderator:

DaemosDaen

New Member
Jul 29, 2019
232
0
0
I am getting this exact same issue I can run the Minecraft server, but it coughs up some errors, but seems to load.

output copied from attempt to load:

<server path>java -server -Xms512M -Xmx4096M -XX:permSize=256M -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -X
X:parallelGCThreads=2 -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10 -jar FTBserver-1.10.2-12.18.2.2171-universal.jar nogui
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=256M; support was removed in 8.0
Java HotSpot(TM) 64-Bit Server VM warning: Using the ParNew young collector with the Serial old collector is deprecated and will likely be removed in a future release
We appear to be missing one or more essential library files.
You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:44)
at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31)
E:\Minecraft\DW20 server>pause
Press any key to continue . . .
 

DaemosDaen

New Member
Jul 29, 2019
232
0
0
I was able to get it to start, but I had to go about manually installing the minecraft server, the forge, the add in the mods/configs from the pack and that seemed to work.... you guys need to work on your server downloads.
After creating the directory;
I installed MC (basically ran the server jar Mojang gives you.)
Then installed Forge's latest 1.10.2 using the installer (running this on a windows 2012 server so the win installer works for me)
Then copied over the mods and configs folder and it started up, so it's definitely something the FTB team did wrong.