Open 1.2.0: Turn off Auto Backup

  • This section is closed. Please do bug reports over at the FTB GitHub repos.
  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord

BloodyError

New Member
Jul 29, 2019
16
0
0
Version:
1.2.0

What is the bug:
Hey,
I'm running a private server of Infinty mod pack and I found out that the Auto backup, which coming with the modpack, eating all of my storage.

For example, yesterday the world size was about 500MB, but today it is over 4GB.
every 120 min this mod create new backup and so my server storage went low really fast.
I wand to increase that this mod will backup only after 6-8 hours and not every 120 min.
Where I can chance this?

Mod & Version:


Paste.feed-the-beast.com log:


Can it be repeated:


Known Fix:
 

Marker248

New Member
Jul 29, 2019
5
0
0
Iv'e tried configuring that mod as well but i'm still having backup done all the time. I want to turn it off completely and i've already set the autobackupdelay to 0 but it is still running. Do i have to turn it off in the client as well?
 

DeathOfTime

New Member
Jul 29, 2019
823
0
1
There are settings for how often it creates a backup, how many backups it keeps, and the compression level it uses for the backup. Adjusting all of those should have a influence on the total size of the backups kept. Though the most influential would be number of backups kept. I set the configs on my server to create backups every half hour, to keep the latest twenty four backups, and to use level one compression. I keep the compression level low as it is the option of those that will have the most influence on CPU used by the backup system.

For me even a half hour of progress seems like a lot to lose. The main reason I even use backups is to have something to go to if my server crashes and no longer loads. If it won't load this system shouldn't be able to create any more backups. So the latest backup should be all I really need. I think I might actually lower the number of backups to eight now.

The server provider I am using provides the option to schedule backups of entire areas of the server. I schedule that one to run once a day and to delete all but the latest 7 backups at the end of the week. That setting is actually pretty useless. A single day is either no progress for me or a lot of progress. To the point that all the data I would lose would actually be a game breaker for me. So I might just turn that off and manually use it as needed. Especially seeing as if the Save file won't load the backup system won't even notice and will backup the save too while it is doing all the rest. Just doing this part manually might actually save me tons of memory.

Thanks, answering this thread has caused me to walk through my thoughts on the matter and decide on a better course of action.
Iv'e tried configuring that mod as well but i'm still having backup done all the time. I want to turn it off completely and i've already set the autobackupdelay to 0 but it is still running. Do i have to turn it off in the client as well?
Try setting enabled to false. By default it is set to true.
 

Marker248

New Member
Jul 29, 2019
5
0
0
I've changed the following setting on server and client side:

# How frequently a automatic backup is done in minutes. 0 means Auto-Backup disabled.
I:delay=0


Above is the only setting in the config for Aroma1997 backup that relates to how often the backup runs. As you can see i've already disabled it but I suspect it is not the mod I need to disable.
Whenever I log in to the server this shows in the console...and yes it does not matter which player logs in as soon as they do it runs a backup.

[FTBU Backups]: Backing up 1522 files...

I've tried to identify what mod it's from but so far have had no success.
I already have the ability and config to make a backup with Mcmyadmin and would like to prevent having two backups running all the time. I know how to restore a mcmyadmin backup but have no idea how to restore a FTB done backup so really it's just wasting space for me right now.

Any further help is greatly appreciated!
 

Someone Else 37

Forum Addict
Feb 10, 2013
1,876
1,440
168
... Oh. You've got FTB Utils, and that's what's doing the backups. I don't know where its config file is, but it's in some weird place not in the config folder... Somebody else will post here with the exact location, probably.
 

Henry Link

Popular Member
Dec 23, 2012
2,601
553
128
USA - East Coast
You can disable it by editing the config.json file located in local/ftbu folder where ever your instance of infinity is at.

"backups": {
"autoExportInvOnLogout": false,
"backupsToKeep": 12,
"backupTimer": 2.0,
"compressionLevel": 1,
"displayFileSize": true,
"enabled": false,
"folder": "./backups/"
}
 

mti_

New Member
Jul 29, 2019
126
0
0
The FTBUtils config can be found in ./local/ftbu/config.json
I will admit that the lack of correct version selection for bug reporting on the forums makes it a bit harder to tell who is running what.
Recent versions of Infinity do not use AromaBackup anymore as FTBUtils takes care of that functionality.