1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Wither boss crashing FTB server

Discussion in '[Archived] Tech Support' started by ItsDom, Jun 5, 2013.

Thread Status:
Not open for further replies.
  1. ItsDom

    ItsDom New Member

    So I'm running a Yogcraft FTB ("minecraft server 1.4.7") server for some friends. I play a little bit, but I more enjoy tinkering with and running the server.

    They've spawned a wither boss but after fighting it for a bit (bringing the health down to around 3/4) the server fails.

    It looks as though it consumes all the memory.

    It's a VM running a custom stripped down build of OpenSuse 12.3 (running on Xen Cloud Platform - the CentOS package.) Initially the machine was allocated 1.7gb, with 1gb for ftb. The wither boss caused an out of memory error (something along the lines of heap full.) So I added an extra 1gb swap, and allowed some more space to ftb. This time, it just died, no error, it just became unresponsive. Had to terminate the screen session but the server was fine.

    I decided to try allocating more actual RAM. I gave the server 6gb of RAM + 1gb swap, setting -Xmx to 5.5gb, and still the same problem - no errors, just becomes unresponsive. It's still gobbling up all the memory it can get and then dying because it can't get any more. On a whim, I tried adding 3 extra CPU cores too but still got the same issue. Does it really need this much RAM and more????

    Apart from this, everything is running fine, it's running exclusively survival, people have quarries and other semi-intensive things and it's absolutely fine, but the wither boss seems to make it die. It's a bit of a pain now, because it's spawned and wandering around, but if we try kill it, the server dies....

    Any suggestions?
Thread Status:
Not open for further replies.

Share This Page