1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Why is Applied Energistics crafting stopping?

Discussion in 'General FTB chat' started by Ricewind19901, May 28, 2014.

  1. Ricewind19901

    Ricewind19901 New Member

    Hello,

    I was wondering if someone could help me with a problem I've been having for quite a while. When I attempt to craft something more complicated with Applied Energistics it never quite finishes crafting, far from it actually. (I am using the latest version of Monster's modpack)

    While I'm typing this I'm attempting to craft a medium solar array so I'll use this as an example. Multiple times now the crafting has halted while making tin item casings for the RE-Batteries. Crafting hasn't stopped, it's just... halted. The solar panel is still in the crafting terminal but the system never actually crafts the tin item casings. Sometimes when shift clicking the required item, the solar panels "currently crafting" will remain empty instead of resetting or continuing where it'd left off.

    Things I've tried (with the results):
    Cancelling and re-requesting (Same thing happens after a while)
    Removing and replacing ME-Controller (Same thing happens after a while)
    Manually crafting the items it gets stuck on (Same thing happens as soon as the items run out or it gets stuck on a different item)
    Using a level emitter and precision export bus for forced crafting (Same thing happens or it just ignores the buss' request)

    Additional Information (For troubleshooting):
    The solar panel is the only thing being crafted currently (apart from scrap boxes every 10 seconds)
    All items in my AE network are most certainly chunk loaded
    No parts of the network are being removed or modified while crafting
    All required materials are most definitely available
    The network has plenty of power
    The machines doing the crafting are powered, working, and empty at the time when it stops crafting
    All recipies used are definitely correct
    I am using AE Conduits (from Ender IO) here and there (this might be the problem?)

    If anyone can come up with a fix for this problem I'd be very glad!
     
    Last edited: May 28, 2014
  2. Not_Steve

    Not_Steve Over-Achiever

    Do you have any dark cables on your network?
     
  3. Adonis0

    Adonis0 New Member

    Or an extension of that, is there a chance that your AE network could partially unload (chunks it's in unloading) while it's crafting?
     
  4. Not_Steve

    Not_Steve Over-Achiever

     
  5. malicious_bloke

    malicious_bloke Over-Achiever

    It's a power issue. If you're spamming lots of the same recipe through the same machine (as an autocrafting setup tends to do when you give it a repetitive task), there will come a point where the machine doesn't have enough power to start a job at the time the network tells it to and the whole process will stick.

    I had this when I was trying to make extreme voltage windmills, eventually I solved it by giving each of my IC2 machines its' own MFSU, but i'm pretty sure you can do something similar with storage upgrades.
     
  6. Ricewind19901

    Ricewind19901 New Member

    No dark cables, and as I said, every component of my network is loaded 100% of the time 24/7
    The ME Controller has it's own MFE that doesn't ever even come close to running dry. The same goes for the IC2 machines that are crafting the required items. They all have 1 MFE (combined) which doesn't even go lower than 4m -512.
    It's not a power issue, nor an issue with loaded chunks
     
  7. Not_Steve

    Not_Steve Over-Achiever

    Try breaking off sections of your network and trying to craft an item. Once it starts working you repeat until you find the source
     
  8. Ricewind19901

    Ricewind19901 New Member

    The IC2 machines are literally 10 blocks next to the controller. The ME drives are right next to the controller and the crafting cube is also about 10 blocks away.
    It's not a big network at all
     
  9. malicious_bloke

    malicious_bloke Over-Achiever

    It's not an overall issue with the power, but the timing of the power usage and the network sending jobs to the machines. If you use a lot of overclockers (because why else would you use IC2 machines :p) you can easily flatline the machine's power in a single instant and receive a new task before the MFE has had time to refill the machine's power buffer. At that point it gives a "not ready" signal to the network and the whole process stops.
     
  10. Ricewind19901

    Ricewind19901 New Member

    Because IC2 machines are the fastest machines in that modpack even without overclockers :p, that and metal formers.
    But no, that can't be an issue either. Yes I've overclocked my metal formers 4 times, but even if I throw in 64 ingots, it never runs out of power.
    Even if all my IC2 machines were working at the same time it'd only use up 200eu/t from the 512 the MFE can deliver.
    The red power "arrow" in the machines never ever turns grey or even partially grey

    Edit: Using the same metal former for both tin plates and tin item casings. Could this be the issue? Since it's mostly getting stuck on tin item casings. It used to be iron plates but I've made a separate machine for those.
     
  11. XLT_Frank

    XLT_Frank New Member

    Or your recipe is calling for a tin you may not have?

    Sent from my Galaxy Nexus using Tapatalk
     
  12. Ricewind19901

    Ricewind19901 New Member

    As said in my first post:
    All required materials are most definitely available
     
  13. Not_Steve

    Not_Steve Over-Achiever

    Are you there's no issue with the ore dictionary? Check if it's calling for the type of copper you have. Ex it wants ThermEx copper but you only have ic2 copper in your network
     
  14. rhn

    rhn Too Much Free Time

    Have you installed the recipe fix for the MV-transformer?
    http://forum.industrial-craft.net/index.php?page=Thread&threadID=10433
    If not then the ME system is trying to craft something that is bugged which is an obvious reason why it would stall.
     
    Padfoote likes this.
  15. Brian Cherrick

    Brian Cherrick Well-Known Member

    Are all the areas where the machines are located chunkloaded?
    What about the areas where the the items are stored?

    The only thing I could think of offhand is that your system is trying to perform more actions than it is capable of. So expanding your autocrafter, and putting it more crafting cpus might help if that is the case. Especially if the system is doing other things.[DOUBLEPOST=1401248790][/DOUBLEPOST]
    This is also true. Especially if your autocrafted recipe uses one ingot, or the other. Best bet here is to do one of two things. First would be using something like Jabba Barrels to store your like items (TE copper is the same as IC2 copper), or using the dictionary converters various mods offer.
     
  16. steve g

    steve g New Member

    ive had this before...the re-batteries (and several other container type items in ic2) are a bit buggy when it comes to autocrafting...i think the way i solved it was to craft the battery manually, then use the one you just crafted in the recipe pattern that is stalling, not the one off of nei...this is extremely annoying but i had to deal with that nonsense a lot when messing with autocrafting ic2 items. i believe lapotron crystals also exhibit the same behavior, i know those will haunt you as well.
     
  17. rhn

    rhn Too Much Free Time

    Yes a lot of the IC2E NEI recipes are bugged and will refer to a wrong sub-itemID.(the numbers after the : ). So if you blindly shift+click in the recipes from NEI without any further going over you are going to have a hard time. Look over the items in the recipe and double check the itemID for the items with charge status etc.
     
    Padfoote likes this.
  18. netmc

    netmc New Member

    Besides the buggy nei recipes with ic2, you may have also hit the queue limit. The recursive crafting limit is quite large, but mv and hv solar arrays can hit the limit. You can test this by specifically crafting the sub components first, then once those are ready, try crafting the finished product with ae auto crafting. If it works, you hit the queue limit. You will have to find a way around it for the large number of steps/crafts needed.
     
  19. GreenZombie

    GreenZombie New Member

    I get similar issues quite often in AgS. I will ask the ME system to craft something and it will... just stop after a while. Ill check the crafting terminal and it will indicate its crafting some item. Checking the inventory levels I will see that item, in stock.

    Picking the item up (to remove it from the network) and re-adding it makes crafting resume.

    Its like there is a (race condition) where items being added to a ME network can go unnoticed by the automated crafting system.
     
  20. Platinawolf

    Platinawolf New Member

    Isn't that a known bug with the latest version of AE? I usually use the workaround of picking up and then putting back a pattern in the MAC.
     
    Narc likes this.

Share This Page