What causes this lighting/illumination glitch?

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

zenkmander

Member
Jul 29, 2019
68
0
16
Anyone else get this? Very annoying flicker. It happens regardless of textures used (vanilla included). See spoiler for screenshots.

2014-01-03_12.16.13.jpg 2014-01-03_12.16.15.jpg 2014-01-03_12.40.28.jpg 2014-01-03_12.40.33.jpg 2014-01-03_14.52.28.jpg 2014-01-03_14.52.30.jpg
 

Sadistical_satan

New Member
Jul 29, 2019
43
0
0
Looks to me like your game is "Z" fighting with Minecraft's wonky lighting engine.
A not so common problem while running Java 7. If it bothers you that much you should place down some light sources around, if the lighting bugs don't drive you crazy,then surly the creeper's and bat's will...
 

zenkmander

Member
Jul 29, 2019
68
0
16
Yeah I tried removing and replacing all lighting sources and it still happens either way, so frustrating.
 

Shirkit

New Member
Jul 29, 2019
189
0
0
It's OptiFine, it doesn't work well with a lot of mods. I'm sorry, but if you are playing 1.6 you can disable it.
 

Shirkit

New Member
Jul 29, 2019
189
0
0
Woah =\ let's see if someone else who may know why this is happening sees and responds to this.
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
Using wrath lamps? Those things have been causing lighting errors for god knows how many versions.
 

immibis

New Member
Jul 29, 2019
884
0
0
Is this the bug where tile entity renderers (mainly chests and liquid in tanks) get lighter or darker depending on the angle you're facing?

That happens, even in vanilla, on certain graphics cards - my old computer did it, this one doesn't. I have no idea what causes it.
 

zenkmander

Member
Jul 29, 2019
68
0
16
Yes that's exactly it! It's mostly chests and liquid containers, although a few other blocks do it too. I'm using a Radeon 7950, which should be more than enough for Minecraft. Hopefully a driver fixes it at some point.
 

GreenZombie

New Member
Jul 29, 2019
2,404
2
0
You have Archimedes Ships in your pack?
Is there, perhaps, a ship with balloons parked near your base?
 

GreenZombie

New Member
Jul 29, 2019
2,404
2
0
Well, ive had the derpy lighting bug. and it seems entirely related to "some mod" with a transparent (self rendered block) not restoring openGL state properly when its done rendering its stuff, resulting in a cascade of shading problems for stuff subsequently rendered. As the render order changes (as you move the viewport around) this alters the point at which the derpy renderer stuffs with the openGL state, and changes - randomly - the subsequent shading.

Tracking down the mod responsible is no small task as, if you really wanted to pin it down, you would need to exhaustively add / remove one mod at a time, restoring the world each time as the block removal caused by removing a mod, will doubtless perturb the world enough that replicating the shading issue will change anyway. And I found the problem would only manifest after a while.

Unless of course, someone with sufficient expertise (I certainly don't) writes an OpenGL call validation mod that can track OpenGL state before and after each mod does its draw calls, to validate it hasn't been altered in a bad way.
 

Runo

New Member
Jul 29, 2019
370
0
0
May sound weird, but have you tried turning off smooth lighting? It can actually cause lighting issues, for example, the black unlit textures you can get with microblocks sometimes. Give it a whirl, smooth lighting blows ass anyway.
 

zenkmander

Member
Jul 29, 2019
68
0
16
I did but the glitch still occurs, just with the added bonus of the weird tiled lighting that comes when Smooth Lighting is off.
 

budge

New Member
Jul 29, 2019
273
0
0
Do you have the Morph mod? I found this to be a problem after morphing in the first two releases.
 

zenkmander

Member
Jul 29, 2019
68
0
16
Yes I do and it could have something to do with that but I can't say for sure. I'm using the updated version, 0.6, since the DW20 pack only has 0.40 and that was causing crashes when Iron Spikes killed mobs.
 

GreenZombie

New Member
Jul 29, 2019
2,404
2
0
Last night I added Barrels mod to my Monster derivative.
As I logged in my lighting was glitched. without even making a barrel.
I logged out, removed the barrels mod, and logged in. Lighting was normal.
 

GreenZombie

New Member
Jul 29, 2019
2,404
2
0
My buildcraft room *suddenly* had a bunch of items that were either full-bright, or deep in shadow if I looked *At* them.
Near the edges of the screen, items would suddenly revert to being properly lit.
The effect is somewhat random - some of the items are properly lit even when looked at which makes the exceptions even more glaring.