Problem [WARNING] Can't keep up! (Lag Galore)

  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord

Old_Smokie

New Member
Jul 29, 2019
5
0
0
What OS are you running?

- Mac Mini Server (Mid 2011)
- Mac OS X Server Lion 10.7.3

Are you using minecraft hosting provider or a dedicated/local server not designed for minecraft?

Dedicated Local Server (LAN Play)

What version of FTB are you using? (Dont just say latest tell us the version)

FTB Ultimate Server 1.4.7

Did you add any mods to the server pack?

No, however I removed chicken chunks while trouble shooting my issue because of the world leak.

What are your server specs?

Processor 2 GHz Intel Core i7
Memory 8 GB 1333 MHz DDR3
Graphics Intel HD Graphics 3000 512 MB

(More Indepth Hardware Specs)

Processor Name: Intel Core i7
Processor Speed: 2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB

Java Details

java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03-424, mixed mode)

A good detailed paragraph about the problem

A just made a jump from hosting a vanilla server (no problems) for a couple of friends (the most on the server at one time = 3 players) to FTB. I don't run any other programs on the server and currently have no services running except the FTB server. It seems that even when I am playing solo the animals jitter around from lag right from the start after a period of time digging blocks, after a block is removed it reappears again.

My Console shows that I am only using 123mb and have 97% free (avg tick .55ms) and I then receive the message from the server console "[WARNING] Can't keep up! Did the system time change, or is the server overloaded?" from the get go and it progressively worsens.

I would consider this to be consistent lag that makes the game unplayable.

I only really had the problem when I had 2 other people on the server with me but it is happening frequently now. I dedicate 6G of ram to run the FTB Server. Is my hardware not good enough?

My server command file looks as such:

#!/bin/bash
cd "$( dirname "$0" )"
java -Xms5102M -Xmx5102M -jar ftbserver.jar

Thank you in advance.


Paste bin link

http://pastebin.com/Mamzd1B0
 

Nessiroj

New Member
Jul 29, 2019
855
0
1
I see a few things:
Java aint the latest java 6 (.33 while .45 is the latest i believe)
Code:
java -Xms5102M -Xmx5102M -jar ftbserver.jar
I whould change it to
Code:
java -Xms1G -Xmx5G -jar ftbserver.jar -nogui
 

Old_Smokie

New Member
Jul 29, 2019
5
0
0
Thank you for the quick response! :) I will jump on that, make those changes and update you on the result.
 

Old_Smokie

New Member
Jul 29, 2019
5
0
0
I see a few things:
Java aint the latest java 6 (.33 while .45 is the latest i believe)
Code:
java -Xms5102M -Xmx5102M -jar ftbserver.jar
I whould change it to
Code:
java -Xms1G -Xmx5G -jar ftbserver.jar -nogui

Ok so just a quick note, even after I add '-nogui' to the end of my code I still get the stupid little gui server box popping up.

Also I have had the server on for about 5 minutes idling and I have not seen the warning message yet. So seems a little progress at the moment.


Edit: Don't need the - in the -nogui
 

Nessiroj

New Member
Jul 29, 2019
855
0
1
that's odd, indeed the -nogui should disable the serverGUI, and atleast saving memory for the servers that need it the -xms is the starting value of the mem usage when the java program starts.
 

Old_Smokie

New Member
Jul 29, 2019
5
0
0
Yep the ftbserver.jar is the original that came in the ultimate server pack. I modified the startserver.sh to startserver.command and made the necessary server changes in there. I took out the ' - ' and the gui didn't show up.
 

CoderJ

New Member
Jul 29, 2019
135
0
0
yeah, .sh is for *nix machines... you want .bat (or. command works).

I'd also throw in (at the minimum)
Code:
-d64 -server -XX:PermSize=128M

Of course, you'll want to make sure you have the 64-bit version of java installed before running that. Those flags force 64-bit mode, the server VM (which is more ideal for... servers... yeah) and sets the initial Permanent Generation size (a must in this version of Forge, especially if running a lot of mods).

There are a lot of good threads/blog posts about what flags can help performance and why. If I wasn't on my phone... I'd look them up.
 

Old_Smokie

New Member
Jul 29, 2019
5
0
0
yeah, .sh is for *nix machines... you want .bat (or. command works).

I'd also throw in (at the minimum)
Code:
-d64 -server -XX:PermSize=128M

Of course, you'll want to make sure you have the 64-bit version of java installed before running that. Those flags force 64-bit mode, the server VM (which is more ideal for... servers... yeah) and sets the initial Permanent Generation size (a must in this version of Forge, especially if running a lot of mods).

There are a lot of good threads/blog posts about what flags can help performance and why. If I wasn't on my phone... I'd look them up.


Well I haven't received the Warning message and I have had 2 players on the server for about an hour now with no glitching or lag from npcs/mobs or block lag since I made the corrections supplied by Ness.

CoderJ I just added the extra parameters and will update on the server status upon further review. (I was using 64x Java so I went ahead and made the changes)
 

LongPlayerHD

New Member
Jul 29, 2019
3
0
0
I had a similar Issue: QuadCore 2.8 GHZ with 8GB Ram. Server Lagy as hell, and he stands direkt besides me. nonstop console message: cant keep up, on normal linux it bitches about redpower nullpointer exeption but with the changes made by CoderJ it runs smoth as heaven! Thanks Guys!